Microphone does not work Zorin 16

Hi guys, having the same problem here with Zorin OS 16 core.

The internal microphone shows as unplugged and funny enough if I try my headphones and just insert it halfway through, the microphone works. If I insert it all the way in, it stops working again...

I have tried the suggestions above but nothing seems to work...

I appreciate any help!

Sound problems can be difficult to diagnose. Here are some things to try, but can be a bit hit or miss.

In Alsamixer hit [F4] to display Capture Devices e.g. Mic's. Post a screenshot.

In Alsamixer, increase levels of all Mic channels to max and check.

Also whilst you are in Alsamixer. Try changing "Automute" and "Loopback" settings one by one and see if any effect.

1 Like

Hi Zabadabadoo, I just plugged in my external monitor using HDMI cable and for some crazy unexpected reason, the internal microphone started working... hahahaha (it took me 3 days on the internet looking for an answer and now this magic...).

But then what happens? The HDMI sound output is gone and can not watch the movie with the sound coming from the TV...

Now, I have to figure that out..

Thanks for your time anyway!

Sometimes you have to try several things on Alsamixer before you stumble on a solution.
I hope you tried the suggestions re Automute and Loopback as that sometimes helps, but for no logical reason.

As you mentioned, for no logical reason my microphone stopped again... It seems that I will have to google around and hope that someone find a definitive fix for this.

I have tried your alsamixer suggestions one by one, but it did not solve it...

What is your laptop make/model and what sound card?

Do you have Pulseaudio Volume Control also installed? If not install by:

sudo apt install pavucontrol

Open pavucontrol

pavucontrol

Check out the settings there look correct.

If you do go for a websearch, try search term: "name of your sound card Ubuntu 20.14" as Z16 is based on Ubuntu 20.04.

EDIT: You could check the link provided by @Aravisian here: Microphone and speakers don't work in Zorin OS 15 - #22 by Aravisian

I have a brand new Tuxedo Infinity Book Pro 14... can you believe that? A pure linux laptop that should work out of the box and having the same issues as my old Asus...

Tuxedo team go as far as to tell me that they only support pure Ubuntu or Tuxedo OS...

I took a screenshot of the info, everything looks fine...

Just saw a command on the post you mentioned and this is the output of it...

arecord -l

**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC256 Analog [ALC256 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0

I can't understand why pavucontrol is showing Internal mic as "unplugged".
You said earlier that plugging in a headset jack resulted in the internal mic working.
Is that still true?
Seems like internal mic and external mic are seen swapped somehow.

Does the same problem occur with "Try" ZorinOS from Live USB?
Are you able to create a Ubuntu Live USB and see if the same problem occurs with that distro?

I consider it a poor show by Tuxedo, that after you have gone to the trouble and expense of buying a Linux Laptop they respond by saying they only support Tuxedo and Ubuntu distro's. Especially as Z16 is based on Ubuntu 20.04.

If I find anything else during web searches, I will add to the thread.

We don't know if this will be the right suggestion or not but you can try this also.

On mine that I just tested now, I attempted to replicate your issue. I tested the mic, after clicking that padlock Icon, then I re-clicked the Icon before closing pavu control out and the mic continued to work.

In terminal can you enter

sudo nano /etc/modprobe.d/alsa-base.conf

In the configuration file that opens, scroll down and look for the following line:

options snd-hda-intel model=auto

Use your arrow keys to navigate to the bottom of all the “options” line and add the above line if it is not already there. Then hit ctrl+x to exit, hit the Y key to say 'yes" to save, hit the “enter” key to save it as the original file. The terminal will now revert to normal.

Open pavu control and put all on proper settings- hit the lock, then immediately Reboot.

finally, you can do mic test by any online mic test.

2 Likes

Hi Zabadabadoo,

Thanks for your msg and sorry for taking sometime to answer... I am a photographer and had to focus on my job instead of hunting a solution for this problem...

As for your question about the live USB, it happens with all the distros I have tried in the last 2 weeks: POP OS 21.04 and 20.04, Manjaro 21.1.1 (with kernel 5.13), Fedora 34, Elementary OS6...

As for Tuxedo, no support will be done unless I format my computer using their WEBFAI usb stick (which removes everything from my computer and install again Tuxedo OS). I have gone into too much work installing windows and the drivers for this machine so, not really sure I want to format everything. I need dualboot with Windows 10 to use Adobe Photoshop and Lightroom (they work not so smooth in the Virtualbox...). Tuxedo will not supply Tuxedo OS .iso file to install, like a normal linux distro...

So, my setup is first installed Win10 and then with the partitioning tool of windows, created some space for Linux. Then, installed Zorin OS 16 as normal with 3 partitions (536 mb for Bios, /root and swap).

I am not sure if Win10 installed first is the issue here. I also have reset the bios to see if it would help, but nothing changed.

For now, I am currently using only windows and running linux on virtualbox... (ironic, right?).

Thanks again and when my work gives me a break I will try again to install Zorin and see if it works.

Hi RoseArline,

thanks for your time too. I have tried that a few times and nothing has changed (some distros this line was already there)...

I will keep looking and will post any news here.

I suggested you try Ubuntu live USB as you said "Tuxedo only support pure Ubuntu or Tuxedo OS".

I have also seen something recently about sound jack sockets being mixed up with internal mic in sound software on some machines. Maybe worth a websearch on this odd headphone jack behaviour:

There is a lot going on in this thread, some of which may be of interest. But as I have previously mentioned, sound problems are a hit and miss affair and involves much experimenting and frustration.

1 Like