Help me get wifi (8188CUS)

Hi! I just installed Zorin 16 os core on an off-brand PC. I had Windows 10 and it worked fine with that. But now the only way to connect to internet is by phone's mobile hot spot. Sad face emoji.

Can someone please help me figure out how to get wifi to my stupid computer? I was very excited to download my first Linux, but now I'm dispirited. This is my computer btw:

1 Like

This cracked me up...

The link, sadly, does not display the Wifi Card. It only states that it exists.

Can you open a terminal with the keyboard shortcut ctrl+alt+t
Paste into it:

sudo apt install inxi

Then run in that same terminal:

inxi -N

Paste the output here.

1 Like

After I ran the two things, I got the message below. Does that make sense? If it's not already obvious, I'm somewhat clueless when it comes to this.

Message: No Device data found.

1 Like

Straight faced emjoi.

Can you paste the output of:

inxi -Fxz

1 Like

Much more this time!

Kernel: 5.11.0-27-generic x86_64 bits: 64 compiler: N/A
Desktop: Gnome 3.38.4 Distro: Zorin OS 16 base: Ubuntu 20.04 LTS Focal
Type: Desktop System: SHENZHEN X&F product: PC1068 v: N/A serial:
Mobo: AMI model: PC1068 serial: UEFI: American Megatrends
v: A818_SU2L_A12_8M_xinshixun_6000_L026.2020.1228.1442 date: 12/28/2020
ID-1: axp288_fuel_gauge charge: 71% condition: N/A model: N/A
status: Discharging
Device-1: apple_mfi_fastcharge model: N/A charge: N/A status: N/A
Topology: Quad Core model: Intel Atom x5-Z8350 bits: 64 type: MCP
arch: Airmont rev: 4 L2 cache: 1024 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 11520
Speed: 483 MHz min/max: 480/1920 MHz Core speeds (MHz): 1: 543 2: 620
3: 491 4: 480
Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx
Integrated Graphics
driver: i915 v: kernel bus ID: 00:02.0
Display: x11 server: X.Org 1.20.11 driver: i915 resolution: 800x1280~60Hz
OpenGL: renderer: Mesa DRI Intel HD Graphics (CHV) v: 4.6 Mesa 21.0.3
direct render: Yes
Device-1: Intel Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series
Imaging Unit
driver: N/A bus ID: 00:03.0
Sound Server: ALSA v: k5.11.0-27-generic
Message: No Device data found.
IF-ID-1: enx9a00c6a4331e state: up speed: N/A duplex: N/A mac:
Local Storage: total: 58.56 GiB used: 7.72 GiB (13.2%)
ID-1: /dev/mmcblk0 model: SCA32G size: 29.12 GiB
ID-2: /dev/mmcblk1 model: SDU1 size: 29.44 GiB
ID-1: / size: 28.05 GiB used: 7.71 GiB (27.5%) fs: ext4
dev: /dev/mmcblk0p2
System Temperatures: cpu: 43.0 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 237 Uptime: 1h 08m Memory: 1.85 GiB used: 1.00 GiB (54.3%)
Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17
inxi: 3.0.38

1 Like

When you installed Zorin; Did you disable Secure Boot in the EFI settings?
As it had Windows on it, did you disable the Windows Fast Startup/ Fast Boot?

Still this, though... We need to know the device in order to know which drivers you need.

Let's try something else:
In terminal, please run:

sudo apt update && sudo apt full-upgrade

Once done, please run

inxi -N

again and see if the device shows up.

1 Like

It didn't show up. Said:

Message: No Device data found

1 Like

sudo lshw -C network

1 Like

description: Ethernet interface
physical id: 1
bus info: usb@1:1
logical name: enx9a00c6a4331e
serial: 9a:00:c6:a4:33:1e
capabilities: ethernet physical
configuration: broadcast=yes driver=ipheth driverversion=5.11.0-27-generic ip= link=yes multicast=yes

1 Like

Well... it is showing your Wired Connection (Cat Cable).
But it does not show any wireless device whatsoever.
Even then, it does not show the product or the vendor...

The website is very generic on what it has too, only listing it as "Wireless capable device."

I do need these answers...

Tearing up my other PC because I remember having a PC with the ecxact same spec.

Ummmm...... I wasn't keeping track, I'm not sure. I was just excited I got it to boot. I did completely install Zorin, though. I didn't do the option where I kept Windows.

Not sure what you mean by "live USB" but wifi and bluetooth both worked fine with Windows 10.

Windows Fast Start up Locks the drive, preventing write access to it. It must be set to disabled, to ensure it does not block write access while installing Zorin OS.

If you have already removed Windows, you cannot do anything about this now... But it may have been set as default to disabled.
LiveUSB is the Bootable copy of Zorin OS that you can plug into the USB and "Try Zorin" on. You may have used it when you ran the installer.

Can you opent he app menu and start typing software until you see Software & updates. Open that, then go to the last Additional Drivers tab. It will run a scan (It may take a minute) and relay what the results of that scan is?

Yes, I did use the LiveUSB. It says software up to date and no additional drivers available

I think I have the same issue. It's one a Mini PC with the same CPU but 4gb of Ram and 32 GB of Storage. I only use the pc for testing

The wifi card that came with that machine may be a very generic card, designed and built only to work with Windows. It's cheaper that way. The listing for the machine even refers to it only as a "Windows Computer."
You might try using a relatively inexpensive USB Wifi Dongle to access your Wifi, replacing the use of the onboard card.

Without being able to get even the most rudimentary information on what make and model the network card is, I am at a loss.

Sounds about right. Have a 32 gb sd card as well.

Yeah, mini machines cut corners and costs everywhere they can.

1 Like

Makes sense, I guess it's such a low spec computer. 2GB of RAM is very small.