Help Pls... Zorin Os detects extarnal Hard disk but cant acces it

Can anyone help me with this? I have tried almost every code possible but my Zorin Os doesnt want to open my external hard disk, it only detects it.

I tried all codes possible and this external hard disk is filled with 1TB of precious pictures and files from years and years and I cant LOOSE them!

Try replacing the cable connecting the disk. Further, can you access that disk using any other OS?
The last time I saw a topic like this, the end result was the disk was likely defective.

Thank you for your reply.

I have tried different cables and different computers … It was a hard disk where the company went bankrupt and stopped providing updates so I had to take the hard disk and put into an new shell and thats what I did. I hoped Linex could help me because Windows couldnt.

You are correct that Linux can read certain partitions that Windows cannot. In this case though, I don’t know what else to recommend since the disk is not even mounting.
I am not aware of any updates needed for USB drives to function - simply plug and play. Maybe someone else on the forum might have ideas to help you out.

Thank you all for your replies, I appriciate it.

This was orginally a media hard drive (Iomega) and this connects to the TV and has it own remote and stuff and it sometimes needed an update because to put movies etc on them you mount it as a normal hard drive. I removed the internal hard drive and put into a new shell (Nedio) because it already crashed 2 of my laptops. Now that I have the internal storage in a new shell it get identified but doesnt want to mount nor open such as a normal drive disk.

If anyone there can help me, I would really appriciate it.

Please store the disk safely. The short answer is YES; your data on the drive can probably be extracted. I cannot say how much data may be lost, however. As long as the disk itself is not damaged (armature slamming into the disk due to dropping, for example) and will spin; That is all you need.
Mounting the disk- that is another issue. But data recovery Does not always require mounting the drive. This is true on Windows, Mac and Linux.
This does almost always require the help of a specialist, though and many can be expensive. In order to help you - almost anyone on here would need the disk in hand in order to try data recovery.

On your own, I would recommend you try using Disk Digger (It is what I use at home) and see if it can access the recognized but unmounted drive. The Free Version will not sort your files-- so it can get tedious. You will want to isolate what you want pulled from the drive in the settings before running it. For example, do not search for all image files if your personal photos were all saved in .jpeg format. Just select .jpg, .jpeg when you run the Disk Digger software.
I hope this helps.

Thank you very much I am really shocked that it actually worked! I dont know how to thank you but you made my year!

Thank you