Hibernate not working - Not enough space

I followed the steps for adding hibernate to Zorin OS, it kinda works but as the screen turns off, it lasts 3 seconds and turns back on the the lock screen. I checked the logs and it says that it ran out of space and resuming. The swap partition is 20 GB while my Memory is 16 GB, I tried many tutorials but none of them worked. I dont know what other info to provide.


If there is plenty of space in your Swap Partition, the first thing I would check is your grub file or grub.cfg

Did you update grub after making any changes?

Yeah... I did that (I followed [HOW TO] Enable Hibernate Option on ZorinOS 16 or other Gnome distros ) I also followed [HOW TO] Enable hyberneation in Zorin which it said hibernate as the button action but after 3 days it randomly changed to 2 seconds ( idk what thats even supposed to stand for)
image and when i press it it just opens the shut down dialog.

This may be tedious...
But in my experience, hibernate not working after setting up with plenty of space can usually mean a step was missed. (For example, forgetting to update grub...)

Can you follow and check each step of your linked guide and cross reference that you performed all steps?
I have done this more times than I can count on all fingers and toes - forgotten some step somewhere in something...
In coding
In mechanical
In life... lol

1 Like

Do you have an Idea of why it shows 2 seconds instead of hibernate in power button? Maybe it has to do something with it...(I attached a pic in the previous reply) I don't know what I messed up lmao. Checked the steps like 7 times today. Thanks for your help

That is a drop down menu - you can set it to Hibernate, suspend, power off, nothing or "2 seconds".

The option allows that the

event=button[ /]power

is set to act after a 2 second hold down delay rather than immediate. This helps prevent accidental shutdowns if the power button is bumped inadvertently like a cat jumping on your desk or tipping over an object that lands on the notebook computer.

ah alrh thanks, I didn't remember it being there :sweat_smile:

1 Like

Alrh, I looked though the steps and i didnt have one (offset), I did it but it still dosent work but now whenever i start it after shutdown it gives me this (takes like 2 min. to startup [normal 7 seconds])

/dev/nvme0n1p5: clean, 1265771/14647296 files, 37026652/58589184 blocks
[ TIME ] Timed out waiting for device /dev/disk/by-label/Zorin\x20Hibernate.
[DEPEND] Dependency failed for /dev/disk/by-label/Zorin\x20Hibernate.
[DEPEND] Dependency failed for Swaps.

Thanks btw!

Gday @SamGo , Just a thought,
As the error indicates "Not enough space", i'm thinking that the system is still using the installed swap file.
It may have been easier just to enlarge the original swap file? Create or Resize Swap file/Partition
Could you show us the output for the below please.

swapon --show

Heres what it shows:

I mean I could try to enlarge it but I only have 1.4gb left of free space


1 Like

16 gigs for swap is a lot.
It's overkill, really.

Aside from it being on a 20gig partition, it implies that a lot of that space is not actually being used or is inaccessible. This could be due to the partition containing bad sectors in that partition.
You could check this by running a S.M.A.R.T. test.

@SamGo Thanks for the update.
Yes you have two swap places.
I suggest you delete the 20gb partition , resize your main partition back to normal.
Resize your swap file
i see a lot of recommendations for swap size.
If using hibernation swap size should be double your RAM +20% so for 16gb you'll need approx 40gb

I usually stick to a maximum of 1.5xRAM
Usually minimum 4 gigs to 1/2xRAM.