How do I play "Mass Effect Legendary Edition" on Zorin OS?

Hi all,

I am a new user to linux and i want to install mass effect legendary edition on my linux setup. I installed steam and i "tried" to follow this tutorial

but i get stuck in the proton part, i don't have root access and can't find the folder. Anyone has a good tutorial on how to ?


Are you talking about this part?

If this folder does not exist, create it:~/.steam/root/compatibilitytools.d/

Just open your File manager, hit
ctrl + H
to display hidden files to see if you have this folder.
If you do not see it, you can create it by right click in the parent folder and select"create new folder" from the drop down list.

Hi FrenchPress,

Yes that folder but i assum that must be created under home folder ? that folder i don't see. Personal map shows the home icon though

Yes, you need to create it in in your home directory.

means your home directory in Linux language.

Why does it look different then when i look in the steam app it self ? I don't see the files i added (created the folder as you say)

Also why does steam not allow ntfs partition ? i can't select my windows drives where the games are installed on.

I've never used Steam myself.
I think you need a someone like @Storm to help you with that.

Alright thanks for your time, hope @Storm can help with this.

cd Downloads
mkdir -p ~/.steam/root/compatibilitytools.d/
tar -xf Proton-6.8-GE-2.tar.gz 
mv Proton-6.8-GE-2 ~/.steam/root/compatibilitytools.d/

restart steam.
Then the rest of the guide you link should be follow-able.

Title changed to fit problem.

1 Like

Which .exe? The guide only explains The Steam version of Mass Effect. I guess you got the GOG version?

@Storm, steam does not detect the installed proton. I get the feeling that steam has a root folder that cannot be accessed.

That is directing to your home folder.
Open your file manager in home (Where documents, pictures etc. are) and hit ctrl+h if you do not see the folders with . in front of them.
Once you do see them (like .config, .cache, .fonts etc) you sill see one .steam
That is the folder being directed to.

1 Like

Actually if you purchased a Zorin 16 Pro, you could directly ask Zorin group for help. Just send a message as a reply to the mail you received when you made a purchase.

On the second picture it shows the install custom Proton. Proton-GE-xxxx


The first picture you see the /home/michel/steam/ and all the files that are in the steam folder.

When i press ctrl + h i only see the folder from proton (the downloaded one). Why dont i see the files from what steam shows. When i look into steam and look in the /home/michel/.steam/ it show their own files and not the folder i installed.

The Proton-GE-xxxx was already listed before i installed the proton from the internet

Stream is probably looking for an executable or the Linux equivalent... at the bottom change the dropdown from application to all files and folders, or just all.

The stream directory everyone is refering to starts with a period, making it a hidden system folder in Linux. In ms it was $. By creating a "steam" folder you only confuse yourself. Your stream software doesn't even know it exists.

Steam also warns that the windows version is not recommended to be played on Linux, especially if there is a Linux version. How they are programmed (architecture and os specific interfaces) make doing so problematic (low frame rates, application freezes and not starting at all are some). If a Linux version is offered, it is recommended to install it on a Linux system. Usually there is a Linux version because the ms version will not play, even through wine.

A quick side question for @Storm or other people who could help: I try to play Windows games with Proton (Experimental by default) but when I click the "Play" button, it automatically Cancel, then Stop, then it gets green again "Play". So can't launch the games. I tried Glorious Eggrolls, but doesn't work either. Weird thing is that Proton versions 5.10 and earlier do work, the games launch. I'm at lost because I saw so many posts about that issue but can't make it work... Anyone had the same issue on Zorin OS and has a solution?

A good idea is to check to check which Proton version works with X game.
Some games works with earlier version and not later version. You can set up in Steam different Proton version per game.

Yes same here, no matter what i try to do it always says "launch failed". Installing the older protondb manually does not get picked up by steam either.

i was wondering ...
How did you install Steam? .deb/flat/snap? There can be a problem if you installed Steam as flat/snap as they run in sandbox.

1 Like

Just like what I experienced with FlatPak OnlyOffice.
It is in the sandbox and unable to connect a network printer nor a network drive. It is puzzling why they bother to create this mode of installation. Office suite without printer is completely useless :frowning:

1 Like