How restore Zorin Connect after removing it

i deleted zorin connect from my zorin-os and need to reinstall. how can i do that?

Please try

sudo apt install gnome-shell-extension-zorin-connect

I went ahead and removed both kde connect as well using :

dpkg -l | grep kdeconnect
killall kdeconnectd
sudo apt-get remove kdeconnect
For removing its dependencies type this
sudo apt-get autoremove

i tried your code and it says it's already installed. but when i search for it ,it's not there.

i uninstalled both kde and zorin connect, yet for some reason it's still in my software store, but it doesn't launch.

what to do now, i want a fresh start.


You cannot have Zorin Connect and KDE Connect or GSConnect and KDE Connect installed together. They will conflict with eachother.
You must stick with having only One installed at a time.

Since KDE Connect carries more dependencies with it, removing Zorin Connect is easier:

sudo apt remove --purge gnome-shell-extension-zorin-connect

i went ahead and removed zorin connect. should i do "sudo apt autoremove" as well and then what?

I'm not sure if i have KDE Or not , how can i tell ?

You have Gnome.

KDE is similar to Gnome: It provides a Toolkit, framework, Desktop Environment and applications for Linux.

Because these applications are often cross compatible, you can install Gnome applications on KDE and KDE applications on Gnome.

The KDE application in this topic is KDE Connect.
Zorin Connect, GS Connect are both based on KDE Connect.

Since you already installed KDE Connect once, this suggests you already have all the dependencies for KDE connect. So running:

sudo apt install kdeconnect

Will re-add the application to your software.
Once done, you can run the autoremove command:

sudo apt clean && sudo apt autoremove

that's going to remove KDE CONNECT AS WELL?
I'm doubting that when i removed zorin connect , i may have removed its dependecies as well, is there is a way to check. i was able to find kde on my linux, however it doesn't show in search, but it opens.
the same problem my phone isn't showing.

is there is a specific ports i need to open on router itself or my phone?

this would install, not remove.

That is fine.
Running the kdeconnect installation command will also install any dependencies needed.

No, but if you have UFW enabled, you should allow the ports:

sudo ufw allow 1714:1764/udp

sudo ufw allow 1714:1764/tcp

sudo ufw reload

Download and install the kdeconnect app onyour android phone.

so i ran both commands:
i turned off my firewall

it's not showing my phone still
right now when i search , i get 4 kde applications, they all work, except " KDE CONNECT"
i also have this GSCONNECT running under wifi section.
at mobile devices, mobile settings.

GSConnect is the application Zorin Connect uses.

It should have been removed right?

Is KDEConnect app installed on your phone?

You can disable this.

yes, version 1.19.1, downloaded from f-droid

Please open the Phone app on your phone and configure the settings.
Ensure the phone is connected to the same Wifi Network that your Computer connects to.
You may need to hit the Hamburger Icon on the upper left and select Pair New Device.
If your computer name is not showing, you can pair by IP Address. Tap the three dots icon upper right and select add devices by IP

You can get your computer IP address on your computer by running

ip a

and looking under inet

i did that and it showed my ip , i added by clicking "add devices by ip" and clicked okay, then went back to main screen and refreshed.
i wanna point out that 1. my gconnect icon is now turned of and the KDE CONNECT ISN'T opening, only kda connect settings is opening.

This is normal- the settings window that you have open is the one you need.
Check the box on the left and click the Refresh Button on the lower left.
See that your Phone Device appears in the list (Left pane of the window)

I'm clicking refresh on both my window and my device , still not showing unfortunately
i have my bluetooth connected to my device and i'm on the same wifi network.

Is your phone currently connected on Mobile Data or on Wifi?

same wifi, i only have one.