How should the 'Z' icon behave?

There's an odd inconcistancy here in Zorin OS. In this layout mode (see attached), I have two app menus - the top left Zorin icon menu and the app drawer on the dock bar at the bottom of the screen. I keep finding myself clicking on the Z icon in the top left and typing to perform a search as I'm expecting it to work like the Windows start menu or even like the app drawer in the dock.

Over time, I'm getting used to knowing there's no app search feature in the Zorin (start menu-esque) app menu in the top left. However, I thought I'd point it out here and see if people feel this is an odd thing for them as well - is it a design issue? Should the search be added to the top left as well or am I just a user who's used to the search feature being in the start menu on Windows?

I'm a new user to Zorin Pro (I've been using Windows since 3.1 days). It could be just me who keeps making this silly mistake of searching in the wrong place.

I'm currently not using Zorin so I can't confirm this, this is just a guess, but I think this may be because the Zorin Lite version uses the xfce desktop environment under the hood, which does not have a search feature built-in into the menu.
I know that with Zorin Core, which uses gnome instead, this works as expected.

However, like I said, I'm not sure if this is because of the desktop environment itself or because of the desktop layout you picked. Could you test with other desktop layouts and see if this functionality appears?

I've tried all the other desktop layouts and the search feature works as intended in the start menu's. It looks like the search doesn't work on just this one selected layout option (unless you click on the '9 squares/show applications' icon in the dock/Zorin Dash).

Then it's probably because that is the default behavior of the underlying xfce desktop environment. I seem to remember there was an option to have that search functionality but ... maybe wait for confirmation from someone with more knowledge about this.

If you press the Super key (the Windows key, or Command in Macs) does it open the menu at the top or the dots from the dock?
Check if the settings have a setting to change this keyboard shortcut to adjust this. I personally use this for all my searches since Windows Vista and got very used to this workflow by now. Hopefully this help you as well.

That is helpful thanks. That key does work as intended.

I really like Zorin OS and so figured this 'Z' icon in just this layout missing the search feature didn't reflect the same kind of flow and consistancy that the rest of the OS has.

I'm really liking ZorinOS part thanks to the consistancy of design and function across the OS (opposed to where Windows has multiple Control Panels and different ways to accomplish the same thing).

You've explained why it works like this which makes total sense. I don't know if ZorinOS devs might want to consider adding search so the icon matches the other layouts this as it doesn't feel as consistant to me.

The fact that I picked this up as in issue is evidence about how consistant and well thought out the rest of the OS is :blush:


I agree, very few Linux distributions pay so much attention to this sort of thing, with numerous layouts all well aligned in design and user experience. And the fact that there are so many means that most of us won't really be using all desktop layouts, but rather stick with one we really like, which sadly means this type if issues may go unnoticed or unreported.

You could add this suggestion to the list of things people would like to see in Zorin 17 (coming up around July 2023). It's not an official list but, hopefully the devs will pick up on this and try to add it.


The Zorin Menu Lite does indeed include type to search in the app menu.
As does the Core Zorin Menu.

The layout in question is not using either menu on the upper left; that is a specific plugin for Quick Access to Launchers, not a full Application Menu.

@Charlie-C , are you using Zorin OS Pro or Zorin OS Pro Lite? Your profile actually lists both, separated by a comma.

1 Like

I'm using Zorin OS Pro

Ok, no problem. Then you are on Gnome Desktop, not XFCE in that case.
The Lite version uses XFCE.
I see you amended your profile and also that you added your suggestion here:

In the meantime, I wonder of any other Zorin OS Pro users are willing to change layouts and double check this to see if they get the same result.(I use the Lite "XFCE" desktop.:wink: )

When you have the grid menu, the search function is above the application grid as in KDE Plasma like I use:

Shouldn't this be in #general-help?

Only if we can verify if this is a bug (unintended behavior) rather than feedback on a Layout that could use some enhancement.
I am not sure which it is yet, myself...

Oh, right. I feel like a broken record repeating that first sentence in this post.

I have just installed Zorin Pro (Gnome) on an old PC to look at this question and others. If you use Zorin Appearance to set up the IOS style desktop, and you open the top left-hand Zorin menu, there is no search item. Perhaps the Zorin Team might want to look at this. I did look to see if it was hidden somewhere else.


@ian4238 thanks for taking the time. I have not had any... It seems all I can do is rush in, handle what I can and then rush out.
I have had little chance to do much in-depth investigating and this is going to get even worse by the end of March...

1 Like

Charlie-C, the reason you only get that particular menu is due to the layout you have chosen. You could try going to the Zorin Taskbar, and make Show Applications Button - Visible. At least that will give you a list of packages.
Or, you can use a different layout. (Please forgive my lame Gimp highlighting,
I'm not gifted as so many others on here)

1 Like

Thanks Jeff! I'll give this a go, but I'm already getting used to it. For this thread's intention though, we're trying to work out if this is an oversight or intended by design by the devs. I think most people expect the search to be there for all layouts as it might be jarring to see it works on default for all layouts except for one where it seems randomly disabled.

1 Like

Not sure if you are familiar with gnome extensions. If so, maybe trying the arc menu may help.
(In case you're not, and want to give it a go make sure your browser ie Firefox, Brave, Chrome, are not Snap Packages. they don't play well with Gnome Extensions. I'm not sure about flatpack either. I installed the deb packages)

1 Like

I believe, because we aren't on Gnome 43 for a few reasons, it may be a Dev. issue. But I'm thinking it's more just the way the layout is designed to work.
But I honestly don't know for sure. I tend to just work around issues.

Being I never used a mac, I was curious. The layout you picked, is the macOS layout. So the menu 'Z' is going to mimic that. I found an image, so I'm going to guess it's by design.