How to assign printscreen button to flameshot

Hi,
How can assing preetnscreen button so it wont work with default zorin preentscreen app but to work with flameshot?

I check keyboarshorcuts system settings, and i didn't find anything, also flameshot doesn't allow allowed to change it (or i dont see it) ver. app 12.1

To use Flameshot instead of the default screenshot application in Ubuntu we need to remove the binding on Prt Sc key, and then create a new binding for /usr/bin/flameshot gui (adaptated from Pavel's answer on AskUbuntu).

Remove the binding on Prt Sc:

Ubuntu 18.04/20.04 using the following command:

gsettings set org.gnome.settings-daemon.plugins.media-keys screenshot '[]'
Ubuntu 22.04: Go to Settings > Keyboard > View and Customise Shortcuts > Screenshots > Take a screenshot interactively and press backspace

Add custom binding on Prt Sc:

Ubuntu 20.04: Go to Settings > Keyboard and press the '+' button at the bottom.

Name the command as you like it, e.g. flameshot. And in the command insert /usr/bin/flameshot gui.

Then click "Set Shortcut.." and press Prt Sc. This will show as "print".

Now every time you press Prt Sc, it will start the Flameshot GUI instead of the default application.
2 Likes

You should have disabled Save a screenshot in Images option, but personally I never had to change screenshot service, for me the default one is fine and can also capture cursor and set a countdown for a delayed screenshot.

I usually need only some part of screen to capture than i chose what i want to do , save to file or paste to e.g doc. With default app it's not possible at least from my first touch. After second instalation od flameshot, everything works fine. For windows and mac similar program is Lighshot. Ty for help :slight_smile:

1 Like

I usually use the simple default screenshot tool, then edit in Gimp to perfect the portion I wish to share.

I got the system that makes this fast:):
Simple use preent screen->Capture screen->Ctrl +c ->ctrl V (into file, text field in text app). It takes 1s .Probably much more faster than editing aditinally in GIMP.

And i have mouse with buttons mapped to this config so actually its even faster .
That's why i need app like flameshot to achieve that .

1 Like

You are probably right.
I'm just different, is all. I prefer fine tuning screenshots often which editing in Gimp allows, but guessing with a mouse selection on screen does not so much. Just a matter of preferences.

Should work if you activate that option that I'm pointing, should let you choose the area to screenshot.

my newly (several times) installed flameshot runs crazy after activation. It blanks screen, switches resolution and is moving windows. re-install doesn't solve the misbehaviour.

Sure the usual suspects have a solution what to do :wink:

here a same screens of what happens:

1 Like

any ideas anybody?

Are you using Nvidia or AMD graphics?

before the reinstall of zorinOS yesterday it worked perfectly well. For sure not Nvidia, where can I find the information you requested?

internet says: Intel HD graphics 620

sudo lshw -C video

Probably accurate, but running the command above to be sure would be wise.

Chain of Events:
Flameshot was working normally.
You reinstalled Zorin OS
Flameshot became a Tasmanian Devil.

The first thing I would have thought is graphics (clearly)... barring that, a misconfigured configuration file in ~/.config.
But... A reinstall of the OS kind of disputes that.

The only remaining thing I can think of is that the reinstall managed to get a corruption on it.

Screenshot from 2022-11-22 20-41-03

so confirmed, and flameshot is really the only app which makes a problem, everything else is running smooth and fine

1 Like

How did you reinstall Flameshot?
Did you remove all configuration files and installation files before the next attempt?

I installed via download and later via software. I de-installed via software and I have done a purge. Don't know the order anymore.

Did Software store install via .deb (APT) package, snap or Flatpak?

flatpak list

snap list

can't remember, did the two commands and there is nothing about flameshot

Ok let's try terminal

sudo apt remove --purge flameshot

sudo apt clean && sudo apt autoclean && sudo apt autoremove

I notice that this is a Qt not a GTK app.
Had you ever tried setting it to use gtk theme using qt5ct?

I run the last two commands now. Your last sentence I can't understand, I did a install and used the app. Now if I click on the icon nothing happens (or strange things)

now everythink should be clean (I will do a reboot also next) what do you recommend as preferred next step for installation, @Aravisian ?