How to hide open apps from other workspaces in the panel?

Pretty much it. I thought I saw that in the Settings once, but now I don’t find it.

Manu1Volta, are you using Zorin Core or Zorin Lite?

Core.

Try running in terminal:

gsettings set org.gnome.shell.app-switcher current-workspace-only true

I am about 82% sure that should do it. I do not use Gnome Desktop so…

Isn’t that for the alt-tab-switcher?

alt-tab is used to key-show open windows on all workspaces.
I could be wrong. As I said, only 82%.
I would just plug that in and log out, in, then test. If it does not fulfill your need, you can just

gsettings set org.gnome.shell.app-switcher current-workspace-only false

Didn’t worked. At least not for what I need. Sorry if I didn’t explained properly. What I was trying to say is that I want that when I am in workspace 1 with Nautilus open and Atom in the second workspace, hide Nautilus in the second one and vice versa in the panel, make it invisible.
In other words: When I press alt-tab it shows just the open apps from that workspace, which I like, and I want that similar behaviour with the panel.

I think you explained it properly and that my lack of Daily Use Familiarity with Gnome is the larger problem. I started out on Zorin OS Core and once I went to Zorin OS Lite, I never looked back.
Happy to stand corrected and bow out clumsily and let a more adept Gnome User help you resolve this.
:slight_smile:

Now you gave me a desire to try ZorinOS Lite for my daily driver… Thanks Aravisian for trying, you inspire everyone here!

For future reference, should you test out Zorin OS Lite (XFCE);
The method is pretty direct.
Right click the panel, hover over the listing on the popover menu “Panel” and use the Menu Arrow to slide over to “Preferences.” This will open a pop up menu for the Panel Settings.
On the third tab over, “Items” you will find a list of all items on the panel, where you can set the settings for each.
Scroll down to “Window buttons” and highlight it, then click the settings icon on the right vert. toolbar.
In the new popup window for Window Buttons Settings, go toward the bottom under Filtering and Uncheck the box “Show windows from all workspaces or viewports.”

1 Like

I asked Carmar and he suggested looking at this thread and jgordons response: