How to Make These Custom Keyboard Shortcuts in Zorin Education Lite?

Hi. I want to add shortcuts to ZorinOS (Education Lite version).
I found this post:

And I found out where to add shortcuts. But it looks like this:


And I don’t know what command to type for that.

So how can I make the following shortcuts below? I tried looking for a command, but it’s not working and I’m probably too noob at Ubuntu to do that.

Shortcuts I’d like to add:

  • Make a window occupy left or right side of the screen with Super + Left or Right

  • Hide all windows and show desktop with Super + D.

  • Go to an app with Super + #. But if it’s already open, don’t open a new window.
    So there’s Super + W which opens a web browser.
    But if I already have my browser open, Super + W doesn’t go to that window. It opens a new one.
    I’d like it to go to an opened-window instead of opening a new one, like in Windows.

I cannot recall a command on XFCE for window snapping - I use the Cinnamon desktop Environment installed on Zorin and it does that automatically. Just toss the window over there and it snaps into place. It also does it for upper and lower. I will try searching this.

For Show Desktop with super+D

sudo nano ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml

tab down to where it says property name=“custom” type+“empty” and scroll down slowly and look for the line that says
EDIT: Sorry, I need to post a picture because the Discord Forum Software keeps parsing the code and will not allow me to show the proper thing to paste in. You’ll need to type it out, I guess…
—and replace the line with (Leave The Carrots!)----
superdkey

Here is a link to a list of XFCE desktop default shortcuts for your last query.

exo-open --launch _____

Is the command to launch an app where the _____ is the app name to launch.
For some, you may need to install xdotool

sudo apt install xdotool

Thanks for the link! It showed how to add shortcuts for volume (something else I wanted). I didn’t realize that this OS uses Xfce (even tho it said xfce in my screenshot lol).
The link shows how to show desktop, but for some reason, that shortcut doesn’t work on Zorin OS Lite Education.

P.S. You said:
property name=“custom” type+“empty”

I couldn’t find this exact same line,
but I found two lines that, instead of a + sign, it had an = sign. Is that what you meant?

Also, I don’t fully understand your instructions (I guess maybe because discord wasn’t displaying it properly).
Which line do I replace with the ."<Primary&gt etc etc?

I think this May Be related to how Zorin assigns the key “Super” to the menu. I recall Azorin posting a fix to this on the old ZorinGroupForum but I cannot recall the fix.
I think we should bump this up to him and see if a Guide on it can be added to the Tutorials section.

As to the rest of your post… Let me try a screenshot of the whole thing. The line highlighted in Blue Rectangle is the one you are looking to replace with the copy screenshot in the above post:

@Aravisian is this the thread from old Forum you were referring. If so see the last post by Azorin re workround. https://zoringroup.com/forum/5/14666/

The link @zabadabadoo posted relates to the same issue that was previously present in the non-Lite (Gnome Shell) editions of Zorin OS, and was fixed in a software update soon afterwards. However, it doesn’t have any effect on Zorin OS Lite.

Based on our preliminary research, it looks like the way XFCE handles the Super (logo) key shortcut (which is mapped to the Zorin Menu by default in Zorin OS Lite) can interfere with other keyboard shortcuts that begin with the Super key on some systems. We’ve added it to our roadmap to fix this issue in Zorin OS Lite, so this shouldn’t be an issue in the future.

In the meantime, the easiest workaround would be to disable the Super key shortcut to open the Zorin Menu by following these steps:

  1. Open the Zorin menu > Settings > Keyboard > Application Shortcuts
  2. Scroll down the list to select the “xfce4-popup-zorinmenulite” item
  3. Press the “Edit” button to change the keyboard shortcut, or the “Remove” button to delete it entirely

This should have enabled the other Super+ keyboard shortcuts. These shortcuts include Super+Left/Right to tile the active window to the left/right of the screen and Super+number to open the numbered app from the taskbar.

Alternatively, if you’re a more advanced user and wish to keep the Super key shortcut for the Zorin menu as well as the other Super+ shortcuts, one of the following tools might help you with this:

The default keyboard shortcut to show the desktop in Zorin OS Lite is Ctrl+Alt+D. If you wish to set Super+D to show the desktop, please follow these steps:

  1. Open the Zorin menu > Settings > Window manager > Keyboard
  2. Scroll down the list to select the “Show desktop” item
  3. Press the “Edit” button below the list
  4. Press Super+D to set this as the keyboard shortcut
4 Likes

Thanks! I changed the menu shortcut to Super + Spacebar. Now the Super +D and Super + Arrow shortcuts work.

Also, for anyone else: the shortcut for tile windows Super + Arrow
(and other shortcuts)
are in Settings > under Personal > Window Manager > Keyboard tab.

They’re in a different location than the other keyboard shortcuts
(which I just noticed is called “Application Shortcuts”

P.S. Sorry that I didn’t end up using your instructions and screenshot. Thanks, tho. The link still helped me with other shortcuts.

I hold no monopoly on methods; so as long as you got it solved, that is all that matters. :wink:

After a software update, Super + # now works the way I want it to! :slight_smile:

Setting new apps to a Super + # shortcut is a little different from Windows 10:

  • Dragging an app to the bottom taskbar won’t make it work with Super + #
  • You have to open the app first
  • the app’s icon will appear in the bottom taskbar. Right click it.
  • then choose “pin application”
    Also, you can use Super + # for any app that’s open.

I don’t mind this setup process,
But is there a way to re-order apps that use Super + # aftwards ?
I couldn’t find any.

Anyways, thanks for the update!
(crosses fingers hoping another problem stays fixed permanently…)