How to stop an app from updating (Kodi FlatPak)

Hi :slight_smile:

I use Kodi Flatpak version on my Zorin OS 16.3.

Yesterday, Kodi automatically updated to version 21, even though I want to stay in version 20.5 (I use Kodi with a shared mysql database and I need to update all my Kodi at the same time, which I didn't plan to do right away).

I managed to downgrade Kodi to version 20.5 by following this guide.

Now I would like to turn off automatic updating for this app, but this same guide shows a command to

$ flatpak mask tv.kodi.Kodi

but apparently you need to have Flatpak in version 1.5.0 at least, and apparently, I have version 1.14.4.

I still typed the command, but will it work?
If not, is it possible to just update Flatpak or is there another way to disable Kodi's automatic update?

Thanks :slight_smile:

Flatpak 1.14.4 is actually newer than 1.5.4 so your command should work.


Ah yes, indeed, 14 is greater than 5 :flushed:
I don't know what my brain did yesterday :sweat_smile:
Problem solved, thanks

Don't worry, it happens to the best of us :joy:


I almost commented about the various times I have done this as well. I am reminded of the 1/3 lb burger:

1 Like

I'm French, so it's not just Americans who are bad at math :wink:

Maybe they should have used a leading zero. e.g. 1.05.4
Not just humans, but most speadsheets etc would fail to order these in correct version sequence.