How to upgrade from "lite pro" to "regular pro"?


I was having some issues with my screen displaying upside down, and after a few months of dealing with it, I blew the install out and started over. Fun Fun.

So I installed "lite pro" but had purchased "regular pro". What commands are needed to update my lite pro to regular pro? I've tried googling it but haven't had any luck.

Thank you.


This would be a sidegrade, not an upgrade, actually. You would be moving sideways, not upward.

One option would be to just reinstall using the Zorin OS Pro .iso as your purchase includes both Pro and Pro Lite.

I am not sure the exact terminal command for installing the Premium Packages, but you could use the Contact Form for Pro users to get installation support directly from the ZorinGroup.

The ISO i download and put on my USB for PRO couldn't be booted from on my Lenevo so I used the lite instead. Otherwise I would have installed FULL PRO in the first place.

They are both "Full" featured and functional desktops.

Should we try troubleshooting the issue with your LiveUSB using Zorin Pro, in the meantime?

I've done some troubleshooting but with some distros it works while in others it doesn't. It's really weird.
Linux Mint installs
Ubuntu installs
Zorin 16 Full PRO does not
Zorin 16 lite pro does not
Zorin 15.3 lite installs **(which is what I ended up doing)
mxlinux does not
linuxfx does not
The link didn't prove much help, as I was already tinkering with the various bios settings/boot order.

That is strange. What kind of error or message do the Install Fails give?

I've had issues after upgrading an old Dell Latitude with SSD with differing outcomes.
Having read that thread you posted about being unable to boot from USB I wonder if PLOP boot manager might help?

1 Like

It's not an install fail so much as it's a failure to boot from the USB. It just doesn't.

1 Like

So I downloaded 16.1 full PRO again. I created a boot USB on my windows machine using the latest RUFUS portable and installed versions. Neither boots up on my Lenovo laptop. I logged into my lenovo laptop running "lite" and tried once more to create the boot USB of full PRO again using balena-etcher.

None of these attempts are recognized by my laptop to boot from.

Does anyone know where I can download 15.3 core again since I know that will work?

Did you mean to post this someplace else?

@emaildave , have you yet contacted the ZorinGroup @AZorin and @zorink in regards to your Zorin OS Pro install?

Zorin OS Pro does come with installation support directly from the developing team. They may have some ideas or at least a more productive path of investigation as to why your Lenovo machine is struggling to recognize and boot the LiveUSB.

In the meantime, have you fully covered the usual suspects like AHCI vs RAID, MBR vs EFI and checking the integrity of the USB stick?

I removed the post in question as it is a duplicate of one he had posted in his thread on that separate issue.

Hello Aravisian,

I sent a notice to the zorin support group via the web site but I have no idea what a "@AZorin" and "@zorink" are? Sorry I'm not that fluent in l33t speak.

As to your second point, AHCI vs RAID, MBR vs EFI. I know what RAID is but not AHCI. Its a regular laptop, no funny stuff with the storage. MBR vs EFI is also confusing. The laptop has a UEFI or legacy mode and I put the thing in legacy mode hoping that would do it. It also had a protective boot security thing, which I disabled. That was how I was able to get Ubuntu/Mint to install when before they weren't. (M)aster(B)oot(R)record? What are you saying I should try?

Success of some sort. I found 15.3 core on the web moved it to a USB drive. Right now its been discovered by my lenovo laptop and is booting from this very moment. SUCCESS/sorta :slight_smile:

@AZorin and @zorink are the CEO and CTO of Zorin Group.

I suppose there are a lot of partitions created in your system. Due to So, many distro's that you previously installed. Maybe clearing them out will sort your problem from its root :smiley:


I don't think there is that many install bones as I've formatted the drive during each of the instalations.

You have formated the drive using?


the installer process.

1 Like

15.3 is installed and now running. :slight_smile:

1 Like

Hope you can now update and do all the other stuff :sparkling_heart:


and now the wifi isn't working...