[HOW TO] Upgrade Zorin OS using Direct Upgrade feature

Please refer to the ZorinGroup guide above for the procedure to perform a Direct Upgrade for a Zorin OS release.
Remember, this is for upgrading the Major Release of Zorin OS without needing to reinstall. You can upgrade from Zorin OS 15 to Zorin OS 16. Or Upgrade from Zorin OS 16 to Zorin OS 17 (When it is released.)

Core and Lite users can also use the Upgrader to upgrade from Core or Lite to Pro or Pro Lite.

This tool is not for running standard package upgrades or for Point Releases (for example, Zorin OS 16.1, Zorin OS 16.2...) These are Point Releases and upgrades happen with your already in place Software Updater.


2 posts were split to a new topic: Discussion on Zorin Upgrade Tool


I thought, I share my little experience with upgrading Zorin OS Lite from version 15.3 to 16.3.
In general, it was a pleasure to use this tool, since it saved me a lot of time upgrading 5 computers which are being used in my family. Not having to take one out of service for several days was definitely a benefit. Half a day was enough to upgrade one of them.

Actually, the second one took a little longer, since the Upgrader wasn't willing to upgrade fully - unfortunately, I forgot the error message at the end. However, the upgrade was done partially.
To finish it, I did the following steps:

  1. run "apt -y update"
  2. run "apt -y full-upgrade" and found out that one package (apparmor) didn't install. The reason was a subdirectory in /etc/apparmor.d/cache, which needed to be removed. So, I did rm it.
  3. run again "apt -y full-upgrade"
  4. After a reboot I had (superficially) the same result as with the first computer, which upgraded with no error message

However, it was not the same, but it was better. Later I discovered that on two computers, which upgraded with no error message, the smbd service wasn't running properly. I couldn't access a share, which was there in version 15.3. When checking "systemctl status smbd.service" it told me the service was inactive and masked.
The reason for this problem was that the new samba version 4.15.13 wasn't installed fully - two packages were missing: samba and samba-vfs-modules.

This was easy to solve. I just ran "apt-get install samba" and the missing part was back. Now the share worked as well.

So, I am still very happy about this upgrade tool. It took me a while to figure out the solutions for the problems, but I still saved a lot of time and the family hardly noticed a difference, because I did it, when they were out of the house.

1 Like