HP laptop refuse to see zorin os usb

Hi all,

Today i tried to install zorin os 16 core on my wifes hp laptop (model i will post later). For some weird reason the laptop refuse to read the usb. When i attach the usb and turn on the machine the screen is blinking. When i remove the usb its booting in windows 10. I flashed with balanaetcher and with rufus, both have the same result. I turned off the hp recovery settings and secure boot but that did not help. I swapped the old hdd for a ssd and that did not work either. I redowloaded core to make sure i have the efi fix but that did not work either. Any ideas what i can do ?

The only thing i can think of now is to use a new usb stick to try out.

Does R1 really fixed the efi ???

1 Like

Yes, I can assure you of that, at least.
Are you hitting F9 or F10?

Its blinking, when i press f9 or f10 it gives the text left under to enter bios or boot menu. But nothing happens and screen keeps blinking. When i remove the usb windows 10 is booting.

If you want i can make a video tommorow.

1 Like

The most common cause of this is USB not working properly or the burner. And... opinions vary. Some say use Rufus to make it work. Others say, don't use Rufus, use Balena.

The short of it is, though... to try another etcher. If Unetbootin, Balena and Rufus are out, you can try Universal USB Installer (Windows link below):


Will check it out when i have some time left tommorow.


Since you have already tried belena you may want to consider that the usb drive is finished. Attempt another usb drive and don't try belena. It bricks more usb's than creates bootable drives.

1 Like

Or, you could burn Zorin OS 16 using Popsicle, I highly recommend it, never had a bad burn using it once!

If you confirm the SHA256 checksum, and the integrity of the downloaded ISO is good, then I would strongly suspect USB drive is dead.


The usb drive is not dead, the usb boots fine in my laptop without screen blinking. I just tested this. I will search for my core usb stick, if i remember right it is the launch version (not r1) and i think i booted that one just fine on her laptop when zorin launched.

I will report back with the results

I forgot about Popsicle.

Awww its ok, I forget things all the time. I am lucky if I remember to take my vitamins. :joy:

Working with Zorin OS Core R0 (launch iso that was burned on a different stick)

I will use the same usb now to flash R1 on it with UNetbootin. Will report back with the results.

Update: With the other usb stick R1 does not get reconized by the bios. Tried 2 usb sticks and 3 different programs to burn the image to usb. Yes the hashes are matching.

Troubleshooting Step: Please switch USB ports. Yes I know, sounds strange, but that alone has worked for some people.

I love the look of your notebook. I see you have two USB keys there, one has the retractable design, the one in the computer probably uses protective cap, the kind people lose lol. Nice looking USB cable.


:no_entry_sign: Stop using Balena Etcher. This could be your whole issue the whole entire time. Its the worst ISO burner for Linux.

Please download Popsicle from the Software Store, its light weight, doesn't take up much space. I am sorry to say, I think you might have to start over with a new ISO burn.

Format the flash drive to EXT4, then use Popsicle to burn Zorin OS to the flash drive.

I'm sorry, I had no idea you were using Balena Etcher.

My friend, that was the first flash from yesterday. I made a picture of it for the forum for the hash check. I already wrote i used 3 different programs to flash. Yes i switched different ports with no results.

It seems the Core launch iso without the efi fix from R1 is working and the updated iso is not for this machine.

I will try one more flash now, if it fails i am pretty sure it's the R1 "fix"

1 Like

WOW! Dude! That is so weirdly, oddly, and satisfyingly, cool!

Version 1 of the ISO works on your machine, PRE EFI fix.

Version 2 of the ISO doesn't work on your machine, POST EFI fix.

OK, now that is very telling aint it. Would you like to know why that is? So would I! Is there someone in here who can make sense of that?

I literally just booted up my medical tricorder and took a reading on myself, it says my brain is not on file.

1 Like

Well it seems the usb from sandisk is working now and r1 is booting. I gaved balanaetcher another chance haha. Flashed everything and it said flash failed. When booting into live it does file checking. It didnt gave any errors.

I wonder why this machine has so much trouble with R1 on USB.

1 Like

Still do some tests

Balenaetcher: Flashed 6 times, 4 times it killed my usb which i recoverd all the time and of course i tried again and again and again. It was painful but it worked. 1 Time HP did see the usb (after a failed flash according to Balenaetcher) and 1 time i flashed correctly and the laptop did not see the usb stick.

UNetbootin: Flashed 2 times correctly, no error messages popped up. Rebooted the machine, reattached the usb in different ports. The laptop did not see the usb stick.

Rufus: Flashed 2 times correctly, no error messages popped up. Rebooted the machine, reattached the usb in different ports. The laptop did not see the usb stick.

The only one that did work great with 1 flash: Universal USB Installer. I used that one too in the past with linux Mint 17.x, Manjaro, Elemantory OS and Zorin OS. Never failed me in windows.

Will now try the stick that didn't work with any of the tools. Will try Universal USB Installer on that one as well now.

1 Like

This is why it helps to buy 16GB USB flash drives in bulk, like a dozen of them. So if you ruin a couple, no big deal, grab another one lol.

1 Like

What i don't understand is the HP machine refuses almost everything, when i use the same USB into my Acer machine it just boots up fine. So i wonder...what am i missing here.

The only tool that creates a good bootable drive is Universal USB Installer

Eventually you might have enough of them to create one paper weight :wink: