HP officejet 4635 does not communicate with computer

Installed zorin 16.3 as an upgrade to my zorin 15. Now my printer is recognized but I can not communicate with it. It is an HP Officejet 4635 and was working well before the upgrade. I have installed th HPLIP device manager but it does not solve my problem. Help Please!

I do not have that printer so I cannot test this. But you might try the tips here:

Thanks for trying to help. I've gone through the process described above and still getting a connect error 5012. I'd like to connect my printer wireless to my computer but I'm stuck trying to find a wireless printer driver. Any suggestions?

Like I said before, my computer sees the printer but for me to set up a wireless connection I first have to connect the printer by USB and that is where I get the connect error. I'm stuck until I can connect via USB. Suggestions please.

Have you tried rolling back the kernel to see if the printer returns to a working state when connected?
This can be done from the Grub Menu > Advanced Options for Zorin

Thanks for your input, but since I'm not familiar with how to do this could you please send me the exact commands to use. Thanks

If you are dual booting with Windows, then the grub menu should appear by default asking which OS you want to boot into.

If you are not dual booting and are booting only Zorin OS, then you may need to make the Grub Menu appear. If you are using EFI boot, you can pull up hte grub menu by tapping esc or tab when you see the motherboard splash screen. This can take a lot of tapping or a few eye-rolling attempts.
It takes some practice to get the timing right...

If you are using MBR (Legacy) Boot; hold the left shift key down during boot.

Once you see the Grub menu, you will see the option to boot Zorin OS, and below that, the Advanced Options for Zorin option. Arrow key to that and tap enter.
This will show you the options to boot Zorin on a Different Installed Kernel. Your previous kernel appears to have been working, so try the Zorin on 5.15.0-76 listing.
Arrow key to it and tap enter key.

Thanks for the information. I will try your suggestion. I do have a dual boot set up with windows 11 as the second partion. I hope your suggestion works and I can use the printer. Thansks!

I booted up using your suggestion and when I used the recovery option the printer worked. There has to be a better way. I've tried connecting to the printer via wireless, but even though the printer is on my wifi I can not print to it unless I boot up per your suggestion. If you can think of anything else, please let me know. I appreciate your help.

Recovery Option or Previous Kernel? There are both listed and which you choose matters.
Please try selecting the previous kernel (But not Recovery) and booting from it.
If it works, you can lock it in with this guide:

I booted using the earlier kernel (not the recovery mode option) and my printer did not work. When I booted from the recovery mode the printer and scanner worked great. What is the difference in the two processes? I'm still hung up about the printer not working when I boot up using the regular 16.3 configuration. Do you have any other thoughts on this? Should I get rid of HPLIP? Since that was introduced as with the advent of 16.3?

When you boot into Recovery Mode, the keyboard defaults to English Language. Are you using multiple regional languages in your language settings?

No, I'm using English.

You could try reinstalling hplip and then running hp-setup from terminal while booted into regular 16.3.
It may be that the configuration files need to be replaced. I am not sure why booting into recovery would change that but... it may be falling back to defaults in Recovery mode so reinstalling and re-running the setup may also restore you to defaults for your regular system.

Thanks! I'll give it a try. Appreciate you staying with this.

1 Like

Thanks again! One quick note. I'd like to uninstall HPLIP completely before I reinstall it. Could you please give me the commands to uninstall HPLIP? Thanks

sudo apt remove --purge hplip hplip-data hplip-doc hplip-gui libsane-hpaio

For residual files that you may wish to also purge - just in case they retain any configurations - you will need to look in two places.
The first is in /usr/share/hal/fdi/preprobe/10osvendor/ and it may contain different files or only one with a different name than what is listed in my folder.
You can elevate to root

sudo -i

Launch file manager Zorin OS Core


Or Zorin OS Lite


Navigate to that directory and right click and remove any files in that folder. Do not remove the 10osvendor folder. Just the .fdi files within it.

The other can be cleared with:

sudo rm -rf /usr/share/hplip/

Thanks for the great information. While I was runing in the zorin recovery mode, I used HPLIP to connect wirelessly to my printer. All worked well. I just can't figure out why (new and improved) 16.3 can connect with the printer like the 15.3 version. Oh Well! thanks again. Cheers!

Here is the solution from Zorin Team that worked:
To try and resolve this issue, please open the Terminal (Ctrl+Alt+T) and enter this command:

sudo apt purge ippusbxd

Afterward, please restart your computer and switch off your printer & unplug/replug the printer in before trying again.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.