I am locked out so I can't install Updates

Just want to preface this by saying that I know my way around a computer but I am not well versed in programming lingo. So I need very clearly broken down instructions and preferably screenshots and then I can find my way around. Thanks!

I can't install updates with the software updater anymore, because the popup that says "Authentication Required" will not accept any password.

I have tried entering the BIOS and changing both my Admin and User password to the same thing. It has a capital letter and numbers and all of that to meet the requirements.

And yet it still says that I am not using the correct password.
I have been dealing with this for a few months now, and I don't know what else to do.
Any help would be much appreciated!

You will have set a pasword when you installed ZorinOS. I don't know why you have been looking in your BIOS for ZorinOS passwords.
What error message do you see when attempting to input your password?

See this for some explaination re Authentication Password.

and

The solution suggested there was re-install ZorinOS again. You should backup your /home partition containing your data before doing that.

EDIT:
I did a webserach using Ubuntu 20.04 which ZorinOS is based. I found this item, but seems quite involved compared to a reinstallation and I do not intend to test that method myself.

Thank you for the answer. I think I will try a clean install and report back. I had a valid Zorin password at one time, but now it is no longer accepting it. I can't change anything in the OS without a valid password.
That is why I tried changing both my overall admin and my user password in the BIOS, because that is what another tutorial said to try, but it didn't work.