I cannot get WiFi working


My wifi works fine in windows 10 but does not appear at all in Zorin 16

I have the following for sudo lshw -C network

  *-network DISABLED        
   description: Wireless interface
   product: RT5592 PCIe Wireless Network Adapter
   vendor: Ralink corp.
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlp3s0
   version: 00
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=RALINK WLAN driverversion=5.11.0-27-generic latency=0 multicast=yes wireless=Ralink STA
   resources: irq:17 memory:f7200000-f720ffff
   description: Ethernet interface
   product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:04:00.0
   logical name: enp4s0
   version: 11
   serial: 10:c3:7b:94:87:be
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=5.11.0-27-generic firmware=rtl8168g-2_0.0.1 02/06/13 latency=0 link=no multicast=yes port=twisted pair
   resources: irq:18 ioport:d000(size=256) memory:f7100000-f7100fff memory:f2100000-f2103fff
   description: Ethernet interface
   physical id: 2
   bus info: usb@3:1
   logical name: usb0
   serial: 4e:5e:9a:30:b9:3c
   capabilities: ethernet physical
   configuration: broadcast=yes driver=rndis_host driverversion=5.11.0-27-generic firmware=RNDIS device ip= link=yes multicast=yes

I am not sure how to enable wifi.

In terminal type the following:

sudo iwconfig wlp3s0 enable

That should turn it on. If the driver is good you should see available networks. You may also check the function combination of your computer to see if that is a faster way to enable/disable wifi.

what does lsmod return in terminal?

There is a driver for this card @

but you would have to build it. If the generic driver works, I wouldn't worry about it.

1 Like

Thank you @337harvey,

I tried the above command and get iwconfig: unknown command "enable"
I've also tried the follow command which did not work either.

sudo ip link set wlp3s0 up

I have followed the instructions on the github readme.md, but I must be doing something wrong. There are no errors, but still no wifi

Your printout above shows Two distinct Wireless devices. Which one is the USB one? Which are you using (Or trying to use...)?

Try nmcli radio wifi on

May require sudo

Still says network disabled for lshw -C network and status Down for ip a

If you have tlp installed you can simply type, or create a keyboard shorcut, wifi on or wifi toggle


According to Ralink:

you need to download their driver to get it to work. That or build the one from Git repo I posted above

This was tested as working as of Ubuntu 20.04, which Zorin is based.

It does say that i have driver version 5.11.0-27, but wifi = (no device) for the wifi commands

Use the linux-hardware.org link I provided above and install the driver for you wifi card. It's recognized, but the default driver isn't allowing you to enable the device. You will have to install the driver provided in the zip file on the linux-hardware.org site.

1 Like

Thank you for helping so much on this. This is literally my first week using Linux. I get the following error after downloading the file and running make.

make -C tools
make[1]: Entering directory '/home/skrhee/driver/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory '/home/skrhee/driver/tools'
cp -f os/linux/Makefile.6 /home/skrhee/driver/os/linux/Makefile
make -C /lib/modules/5.11.0-27-generic/build SUBDIRS=/home/skrhee/driver/os/linux modules
make[1]: Entering directory '/usr/src/linux-headers-5.11.0-27-generic'
make[2]: *** No rule to make target 'arch/x86/tools/relocs_32.c', needed by 'arch/x86/tools/relocs_32.o'.  Stop.
make[1]: *** [arch/x86/Makefile:211: archscripts] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-5.11.0-27-generic'
make: *** [Makefile:382: LINUX] Error 2

May need to configure first. Try



sudo make install

Be sure to be in the directory you're trying to build. Instructions should be on the page you downloaded from if not included as read me in zip

1 Like

3 posts were split to a new topic: Fresh install ZOrin 16 Core No-Wifil Wireless 3165

A post was split to a new topic: New wifi adapter stopped working Zorin OS 16 Core