I can't install Zorin OS, always restart

Hello, I want to make fresh install Zorin OS version Core on my new HDD

By the way, my PC specs are:

Processor: AMD A4-7300 APU with Radeon HD Graphics, 3800 Mhz, 1 Core(s), 2 Logical Processors
Ram: 8GB
System type: 64-bit
System Manufacturer: MSI
Motherboard: MS-7721

I followed the installation guide on Zorin OS website.

After I flash the Zorin OS using the balenaEtcher, I rebooted my computer and select the (F11) key, then select the UEFI:‘myusbname’. Then, the installation menu appear. I choose the ‘Try or Install Zorin OS’ but it keeps restarting my PC and nothing happens.

So I decided to change my boot menu and choose the Legacy boot and tried the same thing, but it restart as always. So I’ve seen there’s another option that I could install it. It’s 'Try or Install Zorin OS" (safe graphics), gladly it boot to the desktop of linux and ask me to Try or Install it, of course I choose install. I followed what to do on zorin os website and as I said my HDD is new so going to full install the Zorin OS.

After the installation, a pop-up window appear and says it required for a restart so I click the ‘Restart Now’ . After that it ask me to ‘Remove the Installer medium’ it was called like that, so I remove my USB bootable drive.

Then it restarts but ended up on black screen but it didn’t stuck there, the PC restarts again but something shows up the Grub menu, so I enter ‘Zorin’ but it always restarts :cry:

Please I need help, I want to feel the new OS ony my life. Thanks you everyone who will respond!

@misterv. Welcome to the Forum.
I wonder, before you attempted an install of Z15Core, did you have a look at Swarfendor’s unofficial manual:

There is a section in there advising preferred method of creating disk partitions and “Something else” way to install Zorin.

2 Likes

Could you please try instructions on Aravisian’s first post here: [SOLVED] Black screen after install ?

1 Like

Hello, I haven’t check this one. I’ll read the instructions. Thank you I hope it fix the installation.

Okay will do, thank you

Update:

I followed th instructions from the Unofficial Manual for Zorin 15.

So I made changes, I have also another HDD that I could re-download the Zorin OS .iso file from the official website and I didn’t use the download accelerator this time. I’ve also use Rufus to flash the OS.

Unfortunately, after I selected the UEFI - boot. There’s an error appear ‘failed to load ldlinux.c32’ so I tried to restart my PC again, if there’s changes. But nothing happens.

So I decided again to find another solution some people says that Universal USB Installer will be more. reliable and easy. So I insert my Flash drive clean/formatted. Then I use the UUI and flash the Zorin OS file, also there’s suggestion that the persistent patition size must be 4GB so I did that.

Now I restarted my PC, back to my empty/new HDD, press the F11 key then select the UEFI:USB. This time the monitor flashes and appear new error its called

‘SYSLINUX: No DEFAULT or UI configuration directive found!’

I tried this:

  • Typing in mboot.c32 -c boot.cfg into the boot:__ prompt *mboot is unknown that was like appear there.
  • Rename the isolinux file to syslinux done, but another problem here is I don’t have any file inside that folder. So I’m thinking was it UUI fault?

Well I’m really out of my mind and still here trying to figure out what to do ad instal this new OS at my house.

Thank you for the respond.

Many say that formatting the USB to FAT instead of FAT32 resolves the issue. This is primarily the case if burning a copy using Rufus on Windows.

1 Like

Okay, I’ll try that. Thank you

I did your suggestion

I use cmd to format it to FAT, but sadly it isn’t succesful. There’s message appear says that ‘not supported for Fat12 and Fat16’ it was like that.

So I didn’t worked

Now, I’ve really tried everything right to flash iso file

  • balenaEtcher
  • Rufus
  • Universal USB Installer (UUI)
  • YUMI (Multiboot)
  • UNetbootin

All of these softwares didnt work properly. This signals me that I can’t install Linux Distribution easily. By the way, I’ve also tried the Ubuntu 20.04.1 LTS, but it’s the same things happens I select the USB key and this boot to me ‘Minimal BASH like line editing is supported. For the first word, TAB lists possible command completions. anywhere else TAB lists possible device or file completions.’

Well overall, this process give me headache because another problem again occured. I don’t know if it’s my USB flash drive fault, Hard drive or on how I flash those ISO file. Maybe Linux OS is not for me. Thank you for the help, will gonna stay as Windows user.

That is very frustrating to be cut off at every angle. I do wonder if it is not Linux, but the USB device itself and Windows that are interfering.
If the USB device is not supported for FAT or FAT16…
That will not help you much unless you can acquire a different USB device.
But it is the most logical common factor- When everything after the USB device fails, it must be the USB device.

Hopefully, the headache improves.

1 Like

Amen. With 5 boot creating programs and two distros not working, I don’t see what else could be the issue.