[SOLVED] Black screen after install

Hi guys.
My wife’s PC had Win 7 and that started giving problems - would boot in Safe Mode but not normally. System restore didn’t do anything - what a surprise.
Got tired of that, installed Core 15 using Unetbootin and a 16 GB USB drive.
Hardware: Asus H97M-E, 4TB WD HDD (also a 6 TB but I installed on the 4 TB) which had Win 7, Nvidia 750Ti, 8GB RAM.
I used “something else” method, wiped the 4TB clean of all Win7 and installed. 20GB root, 16GB swap, 50MB EFI, rest was home.
I had used Try Zorin option, and then installed while in it. At end of install it asked me to reboot otherwise changes wouldn’t be made. So, I rebooted. Then I see this screen: https://ibb.co/t2sG8XC and after a minute or two, this screen: https://ibb.co/7JkgBfF
I noticed the same thing happen just before install, so I had used the “Safe mode graphics” option for installation.
I tried Swarf’s suggestion on the older forum of pressing E at boot and typing “acpi=off nomodeset xforcevesa” but nothing comes up whether I press “E” or any other key. My own desktop has an older Asus mobo and the same 750Ti and had no problems, so I’m lost. Please help. Thanks.

1 Like

Carmar, good to see you moved over here.
Could you please Hold the left shift key down on the Asus PC you are working with during boot to enter into Recovery Mode?
For some, it is stabbing the esc key that works.

You should see a menu that says

  • Zorin
  • Advanced options for Zorin
  • Memorytest

Press the “e” key at this point. It should bring up a terminal text editor for grub.

Read down the print until you see

ro quiet splash

Replace that “ro quiet splash” with

nomodeset quiet splash

This is a Temporary change to grub that will work for this boot up only.
Hit ctrl+x to exit, select “y” to save (I am going off memory here… You may not need to hit “y” at this point)… and continue to boot up.
If this successfully boots up your machine allowing you to see the screen normally (or at least near normally, you may get lower resolution) then it gives us a good idea of what the next step should be.
Assuming it has; update your sources list from terminal first

sudo apt-get update

Then, upgrade to the latest version or Zorin with all updates

sudo apt upgrade

The above may do the trick but, as an additional step you may try checking the Nvidea graphics drivers anyway:

sudo ubuntu-drivers autoinstall

Once the above is complete, remember, the grub setting of nomodeset was Temporary. Reboot and see what changes. If you are still getting a blank screen, repeat the steps above to ‘nomodeset’ to get back into your screen and if you like, you can update the grub to permanently set to ‘nomodeset’ to get the machine working while we continue to troubleshoot.


Thanks, Aravisian. I’m very relieved to see you here (and hopefully Swarf lurking somewhere). I miss the old forum (definitely the look).

I followed your advice. After the boot, Zorin lettering showed up as normal boot. After a few seconds, the lettering vanished and I expected the Desktop but instead my monitor powered off. Please advise. Thanks.

1 Like

He is.

Does this machine have a Graphics card port and a motherboard built in graphics port?
If so, can you switch the cable from one to the other with the computer off, then try booting up and see what happens?

1 Like

Yes, it does. I switched from the 750Ti to the motherboard, booted, and the monitor didn’t power up at all.

1 Like

If the monitor did not power up at all… odd. It should have done something… Can you check if the power cable jiggled loose a bit when switching out the card to motherboard port?
What happens if you hit ctrl+alt+(F1-F8) during boot?

1 Like

Sorry, I meant the monitor went to standby (no signal to be precise) mode and stayed there. Bad choice of words. It goes to standby within 2-3 seconds of booting up.
No response to ctrl+alt+(F1-F8), it stays on standby.

1 Like

Usually when this happens, it is because the computer sending the signal to the monitor is out of range of the monitor specs.
Which is why I was hoping that switching to the onboard graphics might make the screen visible again where we could make adjustments.
ctrl+alt+F1 (or something) should have put a text based terminal up that would allow you to make adjustments and then reboot to see if they worked.

Have you tried a Hammer?

If utterly unable to get the screen working, may need to wipe and reinstall while connected to the Motherboard graphics and see if we can get things working that way. Then install the Nvidia drivers after that.

1 Like

A hammer would solve it because then my wife would leave me in a condition where I wouldn’t need to deal with this any longer.
I looked in BIOS and there is a dual monitor option that allows both GPUs to function but now the monitor goes to standby right away no matter whether hooked to mobo or 750Ti.
So, I’m thinking I’ll take out the 750Ti from its slot, connect to the mobo only, and then install Zorin. And then once I have it all running, I power down, reinstall the 750Ti, and then boot up with it connected. Correct?

PS - The nomodeset option you mentioned in your first post didn’t allow me to boot this time. I’m guessing that its nixed because of the updates?

1 Like

After a fresh reinstall and connecting up:
Install the drivers

sudo ubuntu-drivers autoinstall

OR open Software and Updates and click the “additional drivers” tab.

I would guess similar but I would only be guessing at this point. I am a bit confused, too. Even so, the ctrl+alt+F1 should have allowed text based input, so I am at a loss, too.

When troubleshooting becomes fun, we are not doing Misery Correctly.
Your wifes computer’s not working. Come on, let’s be serious.

“Ducks and runs”


All things crossed (I haven’t found how to cross my blankety-blanks yet! - self-moderated myself there!):


Also take a look here:

1 Like

Thank you both.

I documented what Aravisian taught me as well as the permanent fix section on Swarf’s recommended site. Gonna keep the Nvidia fix suggestion as a bookmark if I need it in the future.

Removing the 750Ti did not help. But then i may have discovered why. The BIOS has a setting where if an external GPU is plugged-in, it disables the mobo integrated graphics. I disabled that to allow both GPUs to function. Then I reboot. Still on standby. On a whim, I unplugged the monitor power and replugged (the monitor also happens to be Asus). But this time I kept the monitor connected to the 750Ti instead of the mobo. Voila, it started up with full graphics. I checked for any updates and noted that Nvidia drivers are under the “other drivers” on the software updater. Then I reboot, switched off the mobo GPU again and it booted just fine.

My take - the Asus components (mobo and monitor) were being annoying. The mobo BIOS dual GPU setting (under Main->System) may have contributed but eventually this worked on the 750Ti which means the signal reception issue was a major part of the problem as Aravisian suspected. Powering the monitor off and then on again allowed it to receive signal again.

My wife is now happily on her desktop and the only machine in the house with Windows still on it is my dual boot desktop which gets powered up about once a month.

For future readers - Aravisian’s instructions in post #2 were the prerequisite to this working.


Carmar, great troubleshooting. Hopefully this will help others, as well.

1 Like

Thanks to Aravisian for great support as always, and Carmar for reporting he is now (or rather his Good Lady) is in Zorin heaven! You could also now give your good lady a change to give KDE a try! :wink:

1 Like

Both of us happen to like the Zorin Gnome look. But I’ll try KDE out some time - thanks for the tip. I did try Xfce several months ago but preferred Zorin’s default.
Oh, and I lied: my work laptop is the second machine in the house that runs Windows (Noooo!) but I have no control over that. :grimacing:


Well I managed to crash my install last night (writing from different machine as been on with ISP as no computers and no phones could get to internet even though router was displaying connected to internet. I was installing a new wallpaper in KDE and the system crashed so I need to do some repair work on it today! LOL!

1 Like

If you call an IT department, one of the classic things they are going to ask you is, “Have you tried turning it off and on again.”

While these days considered much cliche, there is also much truth to it. Back in the day when computer’s didn’t have nearly enough RAM, turning them off and on again would clear the RAM cash, which allowed the system to operate normally again.

But since monitors and TV’s have become smart devices now like mobile phones, they too sometimes need to be powered off and on again. Glad you got the annoying problem figured out.

1 Like

I just responded in kind to your post on the other thread. Perfect timing.

1 Like