I can't paste copied files from second disk to desktop

I'm new user of Zorin OS 16 Core. I switched from Zorin OS 16 Lite. I fall in love with this OS but I have problem with copy and paste files. I have two hard disk installed in my PC. I can't copy files from second disk to desktop or first disk where Zorin OS is installed. Paste option is disabled. The same is with coping files from desktop to second HDD. I tried tips from similar topics and most of them not working for me. I used Zorin OS 16 Lite earlier and it has worked well till last week - I mean copy and paste files. I installed Zorin OS 16 Core few days ago and it doesn't work. I tried change permissions to disks, folders etc. I don't know what to do next. I installed Ubuntu later and I had this problem too but when I installed updates the problem dissapered. Only Linux Mint didn't have any problems with copy and paste.

You can open a terminal and type

sudo thunar

You'll need to type your password at this point,
and this will open the file manager with escalated privileges to allow this.
It sounds like you need to change ownership or permissions or both of the files.

Are the partitions in NTFS format? In that case you will need to use ntfsfix.

First disk - 320GB is dedicated for Zorin OS - file system: ext3/ext4, default during installation.
Second disk - 80GB is NTFS
I can't copy files from zorin's desktop to second disk and from second disk to desktop. Paste is disable.
But it's weird but I tried copy file from downloads folder (firefox) to desktop - paste is disabled lol.

Have you checked the permissions of the Second Disk Drive?
Do you have ntfs-3g installed?

sudo apt install --reinstall ntfs-3g

1 Like

I tried this command... doesn't work for me. When I'm changing ownership or permissions on main partition/disk where Linux installed is... some icons on the desktop disappeared lol.

Zorin OS 16 Lite and Core seems to be two other systems. I say that because I had special commands in terminal to install Wifi card TP-Link T3U Plus. With Lite version it does work.... with Core it doesn't.

This is odd... installing a driver should be totally desktop independent. I wonder, though, if a gnome-extension is interfering on Core, that could cause the issue...

Can you please try the marked solution in this thread..

I tried this solution. Terminal refused some of commands. Only reinstall ntfs works for me. The same is with installing wifi card tp-link. With Zorin OS Lite it works. It's weird because in Lite version I could copy and paste files... then I lost this option. I tried change persmissions, ownership and... that's all. Only Linux Mint doesn't have any problems with copy and paste files.... I'd like back to Zorin OS Lite but I don't have Zorin Connect there and Core version is more better. I had problem with 64GB pendrive with Zorin OS Lite, I couldn't mount it - errors, it works with Core.

Zorin Connect is based on GSConnect - which is based on KDEConnect.
I install and use KDEConnect on Zorin OS lite and experience the same as a user having Zorin Connect on Core.

I reinstalled Zorin again and wifi tp link t3u plus working! (with special ubuntu commands in terminal). But I decided move files from ntfs second disk to main linux partition and I formated it as ext4 file system. And I copied file to second drive and wanted copy back to desktop.... lol it doesn't work! Paste is still disabled.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.