Icons not visible in system tray

Mailspring and stacer while running in background usually shows the icons in system tray and it's still there but not visible. The space is fully white and while hover the mouse I can see it as in the screenshots below.

I think this might have something to do with your theme. Have you tried altering your theme colors, or turned on DARK mode variation of the theme? I made some settings alterations with my install, whole new theme and all that, and I can see my APP icons just fine.

Just out of curiosity, have you tried restarting your desktop?

ALT F2 hit r press ENTER

1 Like

EDIT: I misread the O.P. and the below is not relevant to this thread.
Leaving the shame below for posterity. :smiley:

This is an issue that others have noted in other threads. Below is a response from the ZorinGroup on troubleshooting that you may try:



Thanks for the reply, I changed my theme to dark and now the icons are fine but I prefer light theme over dark so what should I do?

1 Like

Sorry, Shyam, I misread your O.P.

It looks like the icons for mailspring and Stacer are light colored .svg files. You could replace those two icons with darker ones.
Or, you could recolor your existing icons with inkscape to darken them.


Thanks Aravisian, I got little confused by the other thread which you mentioned where the OP said the tray icons were gone but mine was still there but not properly visible. would you mind If I ask you how to replace the .svg files with darker ones?

This reminds me of what Yoda says about how we learn most through our failures, and how they are the most powerful lessons that we can teach others.

1 Like

Which icon set are you using?
I would probably need to install both of those applications in order to figure out where the icons are.
The icon for Stacer is usually stacer.png or stacer.svg in the Icon set you are using:

Or generic added application icons are in

1 Like

Do you agree that does not look like same icon as on panel?
I may be failing to tell from the screenshot.

yeah surely It does not look like the icon on the panel. Panel icons are placed somewhere else I believe.

Ok, I found the icon, named Dash, by perusing the devs github:


The best I can suggest is to contact the dev on the page above and Note the issue.


Sorry to not be more help. You can see all the icons there in github; and I even installed Stacer in order to try to suss out their locations. Sadly, it appears to all be wrapped in the bin file, which would restrict your access to it.

1 Like

No problem and thanks for installing it on your own device to look into it.

I think Stacer is an awesome APP, it wouldn't hurt Aravisian to check it out, and play around with it, and have a little fun. Yes, I can see the emotionless look on his face right now. But seriously, it is a good APP, so maybe you will like it Aravisian?

I hate it.

Well that escalated quickly, to a full backfire and reversal. :frowning_face:

1 Like

I like some of what Stacer offers, but generally, I find other smaller apps serve my needs much better. I also find Stacer restrictive, considering that it is closed off in a bin file.
I cannot adjust the python or java in it- I cannot readily source the code... and that bothers me.

I didn't know this, thank you for bringing it to my attention. Maybe we should watch the development of Stacer more closely in future updates, to determine if the dev's are going the way of Gnome style management or not.