Inconsistent cursor on flatpak

What I have tried so far

Which suggested

flatpak --user override --filesystem=/home/$USER/.icons/:ro

flatpak --user override --filesystem=/usr/share/icons/:ro

Changed settings in flatsteel too as suggested here

I have no clue what more can I do, and any help is appreciated.


A Question: Where did You put the Folder with the Cursor Theme?

I agree with @Ponce-De-Leon, you should copy the icon set to your ~/.icons directory (Create it if it does not exist. Remember, the hidden system directories have the period in front of the name).
Flatpak/Seal will not access /usr/ directory.


I also tried copying the entire icon folder in usr/share to local/share still no luck

In Flatseal, you also need to specify the theme by name in:
Environment > Variables
by adding:

ICON_THEME might have to be CURSOR_THEME when changing the cursor, I'm not sure.

You can set for "All Applications" or a specific application in the left panel of Flatseal.


Okay, I understand. In the Past, I had the same Issue with that. I had put it in this local Path too. And then I had on some Programs or the Desktop with my chosen Cursor Theme and some not - it was a Mixture.

So I changed the Place for my Cursor Theme. I have put it to /usr/share/icons/ (not to /usr/share!) because when you put it there it is use systemwide. But you need sudo Rights. I think the easiest Way to do it is in the Terminal.

And when You placed Your Cursor Theme Folder in the usr Path make a reboot and then go to gnome-tweaks an change Your Cursor Theme. For me that works. I hope for You too.

Thanks, this worked :smiley:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.