Install Alongside Does Not Come Windows 11 and Zorin 16 Core

I am trying to install Zorin Core 16 on a Windows 11 PC which runs from an SSD.

So I want to be able to Dual boot.

It does not display install alongside windows.

I have attached a screenshot of the disk layout. It is the sabrent SSD . The 3 partitions after the C drive are the zorin partitions I created as part of the install process. (root, home and efi boot).
The disk normally only has 3 partitions on it.

Any suggestions on what could be wrong?

Thanks
Raymond

I think that is your problem. You have created a second (unwanted) efi partition.
Wait for others (e.g. @337harvey, @Aravisian) to confirm my opinion and advise best way to fix the problem.

Also maybe worth having a look at this:

What does terminal run:

efibootmgr

show?

If it's still a fresh install, not moded much, you can run the installer again and point it to the windows efi partition. Otherwise, you can open the drive in disks, remove the boot flag on the Zorin efi, delete that partition and run boot repair, which should install grub in the windows boot manager efi partition.

Backup prior to performing any of these options.

Hi Guys,

I think there has been some misunderstanding:-

  1. Zorin is not running obviously so I cant issue commands like efibootmgr. This cant be issued on Windows?
  2. I have now deleted the partitions that I created as part of my failed attempt to get Zorin working so I am attaching these.
  3. In my first attempt to install it did not have the option to install alongside which surely must point to some obvious thing for me to check.
  4. I have looked at the Before You Install guide for Zorin 16. But I have at least 1 question. Do I point the Zorin 16.0 install to the Windows 11 EFI partition which is the first one and is 1.5GB in size and if so will it update it without impacting the windows part. So if the Zorin install fails I will still be able to boot back into Windows.
  5. I did again to install Zorin 16 on my system after I cleared up the disk and it still did not have the install alongside option. I had created any of the Zorin partitions like root or home using gparted as I just wanted to see what it would do.

You can run this in the Trial Demo of LiveUSB.
Boot from your Zorin OS installation Medium, then select Try Zorin.
Open terminal with ctrl+alt+t or from the app menu.

The file is added to, not overwritten.

Here is the output from the efibootmgr:-

zorin@zorin:~$ efibootmgr
BootCurrent: 0006
Timeout: 1 seconds
BootOrder: 0006,0005,0000,0002,0003,0004,0007
Boot0000* Windows Boot Manager
Boot0002* SATA3 480GB SSD
Boot0003* ST1000DM003-1ER162
Boot0004* Sabrent
Boot0005* Windows Boot Manager
Boot0006* UEFI OS
Boot0007* HITACHI HTS541680J9SA00
zorin@zorin:~$ 

I booted live Zorin from a USB Hitachi Drive which is Boot0006 and the drive I want to boot from is Boot0004 once I have installed full Zorin 16.

Windows entry in the EFI is showing up, though.
Can you run

sudo os-prober

Then open the Zorin OS installer and run the installer. See if you get the option to install alongside.

I'm curious why you have two windows efi partitions (windows boot), are you running two versions of windows?

If you aren't running two versions of windows, i would remove the boot flag on disks on the live image and attempt to boot windows. If it doesn't, boot the live image, enable the boot flag (check box) and disable the first. Reboot into windows. If the first disable didn't effect windows, delete the second windows boot efi partition. If it did, then remove the first partition instead.

If you chose something else installation type, in the drop down choose the windows boot manager partition 0000 for the grub install. Set root (/) to partition 0004. Unless you want home on another partition and swap partition (for hibernation), you are done.

I did that and still the Zorin Installer did NOT find any operating systems.
zorin@zorin:~$ efibootmgr
BootCurrent: 0005
Timeout: 1 seconds
BootOrder: 0005,0000,0002,0003,0004,0006
Boot0000* Windows Boot Manager
Boot0002* SATA3 480GB SSD
Boot0003* ST1000DM003-1ER162
Boot0004* Sabrent
Boot0005* UEFI OS
Boot0006* HITACHI HTS541680J9SA00
zorin@zorin:~$ sudo os-prober
zorin@zorin:~$

Thanks Raymond

No I am not running to versions of Windows. There is an EFI partition, then the windows install operating partition and at the end the system reserved partition which contains windows utlities etc.
Thanks Raymond

Ps I did do the os-prober command before the efibootmgr command but did not capture that. I did try and install after I did the first os-prober and then came back to the live USB version and issue the above commands.

I think that is what the GIGAbyte bios has kept in cash and it might be that I can boot using legacy as well as efi. I dont really know. I get two option to boot for the USB Hitachi as well.

If I run these commands I get the date and version for Gigabyte bios. I am on the latest for the TPM support

sudo dmidecode -s bios-release-date
10/13/2021
sudo dmidecode -s bios-version
F35d

Latest Update

I tried to install Zorin on a separate disk and that did not work either. So I tried Ubuntu and that did not work either, so I tried LXLE and that did not work.
They all got to the point in the install when they say they are creating ext filesystem for / and the little display window has some log entries that do change but after 2 hours in one case still no Linux was installed.
All the Linux installs above did not come up with install alongside Windows so I used the manual setup option and choose a newly added SSD drive to install them onto and not my main M.2 NME S.2 drive which has Windows 11 on it.
I did manage to install Zorin 15.3 ultimate last year on this same PC and it dual booted. The only changes that I can think of are 1. I am now running Windows 11 and 2. I updated the bios.

I dont have fast boot set.

I dont understand this at all. I must be missing something.

I am... running Windows 11 dual boot alongside Zorin OS 16.
It seems unlikely that the presence of Windows 11 is the cause. However, Win11 (Which Zorin Installer saw) is on the nVME and Zorin OS is on the spinning HHD.
BIOS -Update: maybe...
This is a stumper. That it is not just Zorin OS implies it is something more general.
What if you try Debian with a different installer? Perhaps it is Ubuntu related.

I have tried debian and that fails as well. I am attaching some screens shots.

The consistent error is " The attempt to mount a file system with type vfat in /dev/nvme0n1p1 at /boot/efi failed. This has happened with all of the installs so far.
I have done a web search and it is logged but no solutions listed and the reports have just gone dead. It seems people dont know how to fix this.



Thanks

Please see here:

Thanks for the above article as it confirmed that the EFI partition on the C drive was causing the problem. So I formatted it and rerun the Zorin 16 install and it all worked fine.
I think a possible issue was that I did have ultra fast boot set in windows and maybe it makes some change to the EFI partition. Or the partition had some other issue.

Any I have Zorin 16 up and running.

Thanks again for all your help Zorin Support

1 Like