Install attempts on a laptop no longer boot from any USB sticks

Hi there. I tried installing Zorin on a 6-year old laptop that had a few partitions already. The Windows partition had been acting up, so I was hoping to have a dual-boot machine. My plan was to install Zorin first, and then later on go back and use a new install of Windows in a second partition. I created a boot USB stick and everything started fine. Eventually I got to a screen with partition and formatting choices. To be honest, I don't know if I was looking at the partitions on the USB stick or partitions on the C drive. Anyway, I thought I was formatting and installing on the C drive, but turns out it was the USB stick. When I rebooted the computer, it no longer looked at the USB stick to boot. Even worse, when I took out the USB stick and tested it in another computer, it was a brick. No computer here would recognize it or format it. I found another USB stick and created a Zorin boot stick using the same steps. However, the laptop doesn't recognize it or boot from it, like it did the first stick I used. Now the laptop is a brick, and the 1st USB stick is a brick. My two questions - does Zorin make changes in the BIOS setup during install that might prevent me from making a second attempt at an install? And, any thoughts on how messing up an laptop install can brick a USB install stick? Thanks - Mike

The computer does not boot up at all?

No, neither Zorin OS or the Ubiquity installer make any changes to BIOS settings. Neither is capable of doing so.

It is possible you made a mistake and somewhat possible that your mistake messed up the USB stick, but I would think it unlikely that a mistake you made could truly brick the USB stick.
So if it is in fact totally bricked - I would suspect USB Stick hardware failure that coincided with your install attempt.

But it is also likely that The USB Stick, which contains its own hardware programming contained on the stick, needs only to be properly wiped and reformatted to be viable again.



Thanks for helping so quickly!
Okay, an update. When I boot the laptop without the new USB stick, it goes right to a Microsoft [Windows] blue error Recovery menu with error code x0000001. When I tried with the new stick, the Acer logo was on screen for about two minutes, and then it rebooted and I have a "Perform MOK management". I googled that phrase and it told me it was indeed related to linux/ubuntu, so think I'm on the right track.
I put the computer aside with that menu. ugh, while I was typing this, that MOK menu disappeared and it rebooted to that same Microsoft screen. I'll keep researching to see what to do with the MOK menu. If anyone can recommend the next step on the MOK menu, please do. Thanks. --Mike

Follow-up. I got a different menu called something like slim mok menu. I chose something and got that MOK menu again. I chose something again and now it appears Zorin is actually installed properly again like yesterday! [I have the Acer logo with the "Z" logo below it]. The million dollar question will be, what should I look for in the partition table to install on the internal drive, and what to look for to avoid installing back on the USB stick?

Okay, continued with the install. Got to a very similar place as yesterday. It appears that it's showing me partition information about the USB stick and no mention of the hard drive.
The USB stick is 32Gb, the C drive has about 1TB.
the device is /dev/sda
/dev/sda2 4MB unknown
free space 3094MB
/dev/sda3 ex4 27942MB 619MB
Device for boot loader installation
/dev/sda PNY USB 2.0 FD (31.0 GB)

I'll it right then until I hear back or I can dig around and find the next step. Thanks for helping! - Mike

MOK manages the Secure Boot management on hardware so that Linux applications can be permitted at boot.

Secure Boot is a Windows Only Feature.

Linux Operating Systems cannot change your BIOS Settings - but you can disable secure boot in your BIOS Settings prior to proceeding to install a Linux OS.

1 Like

I read the help page on manually partitioning the drive. My device list is included above; I don't see my hard drive in my list there, just the USB stick.

Below the "+ - Change" heading, I see the PNY USB stick first, and /dev/sda3. Do I need to create a new partition table on the internal hard drive?

[FYI my BIOS is set for UEFI , not legacy. If that's a problem, let me know.]

Thanks. - Mike

Isn't /dev/sda3 a partition of your hard drive?

I am wondering if a Gparted screenshot from @MSLtechie would help show his disks and partitions setup and aid diagnosis.

1 Like

I have to admit, I'm not sure. It appears to be listed under the /dev/sda header, and it only has 27942MB, which added to the 3094MB seems to add up to the total storage space of the USB stick.

I looked up Gparted. I'm a *nix newbie, but I've worked with partitions, virtual machines, dual booting, on and off during the years. Are you recommending I quit my current Zorin "Install" screen [snowy mountain background], create a gparted stick and try again?

I am suggesting if you are having problems with disks and partitions, Gparted will give a clear illustration of them that you can post as a screenshot to aid diagnosis and forum help.

As some say: "a picture is worth a 1000 words"

Here's a picture as you suggested...

/dev/sda3 formatted as ext4 used 619mb

This looks like the partition you want to install to.

To my eyes Gparted picture is showing only the USB stick, but there is a ext4 partition sda3 on that. I assume intention is not to try install ZorinOS on the USB stick.
@Aravisian is that your understanding?

The USB stick would be /dev/sdb rather than sda, right?

Thanks everyone.
My intention is to install on the 1Tb internal hard drive, not the USB stick.
I don't see "sdb" in the list.../dev/sda is the header, I assume, of the other items below it.

@Aravisian Did the USB stick become /sda as result of that formatting episode mentioned in OP.
/sdb seems to be missing.

On the LiveUSB version of Zorin OS, the Disks Utility should be able to answer these questions and hopefully clear up the confusion.

Launch Disks from the app menu.
In the left pane, the Disks that are recognized will be listed, including their ID and Maker.
On mine for example, I have a Western Digital SSD 500 gig disk and a 32 gig USB plugged in.
I also have Seagate HDD 1 Terabyte disk:

  1. I quit out of the running install and put aside that working USB boot stick.
  2. I created a 2nd USB boot stick.
  3. I restarted the computer. The first time through, I got that Windows Recovery blue screen error. The second time, I got the MOK menu. I clicked through that and got the Zorin install screen.
  4. Rather than install, I started the OS from the USB stick.
  5. I ran a few of the desktop apps. Gparted only shows the USB stick. Same with the other disk utilities.
  6. So...asking as an acknowledged relative newbie...maybe the internal hard drive is dead? is there a BIOS setting perhaps set wrong? I didn't see a 'LiveUSB' option.
    I am enjoying learning more about BIOS setting and this OS, so thanks much to those assisting me! - Mike