Install failed on Dell XPS 9550

Failure to install Zorin 16 Core on my Dell XPS 9550. This problem matches the one described here https://github.com/elementary/triage/issues/74

The following error appears before the installer GUI loads:

Failed to open \EFI\boot\? - Invalid Parameter
Failed to load image \EFI\boot\?: Invalid Parameter
start_image() returned Invalid Parameter
  • Flashed thumb drive using Rufus (GPT, UEFI, FAT32), also tried using Etcher.
  • Verified UEFI settings match Dell documentation (ACHI, Secure Boot on).
  • No other OS on target drive.
  • I am able to load Zorin 15.3, presumably because it has compatible bootloaders included.

It appears to be a problem specific to Dell UEFI and the latest bootloaders that were included in the Zorin 16 image. I tried workaround 1 and 2 in the above link (manually set target bootloader in UEFI, and tried stock bootloaders from vanilla Ubuntu 20.04 image); not willing to try workaround 3. Workaround 2 gets me to the black screen where I can select the type of startup run I want (normal, safe drivers, or Nvidia), but upon selecting any one of those options I only get a black screen and I can only do a hard shutdown.

2 Likes

Thanks for letting us know about this issue! We have now issued a fix for it:

2 Likes