Install window doesn't show m2 ssd

Hello!

I am new to Zorin, I am trying to install in via a bootable USB. After I reach the installation type section, my m2 ssd is not seen.

I have 2 ssd's: Crucial P5 and Crucial P3, both visible in BIOS (hence compatible with the Gigabyte motherboard that I am running).

I can only see one of the SSD, not the one I am trying to install it on.

  1. I've tried removing all other storage options that were connected to the motherboard, still nothing.
  2. I've rearranged the SSDs, since one port is for PCI4 and one for PCI5, but both SSD's have PCI4 connection (PCI5 ensures backwards compatibility so that is fine)
  3. Both SSD's are visible from in the BIOS.
  4. I have used Balena Etcher to flash the image on the target SSD before trying the USB, MAYBE that has had something to do with this, but I'm not sure

What am I doing wrong?

Thanks for the help!

Are you dual-booting with Windows OS?

Is secure boot disabled in the BIOS / EFI settings?

In your BIOS / EFI settings, is your drive set to AHCI?

In your BIOS / EFI settings, is TPM disabled?

RR: dual boot, I have disconnected other SSD, only empty ones are connected.

RE: Secure boot, have just disabled secure boot and trying now

RE: SATA mode is set AHCI, but I have M2 SSDs connected (I think those are NVMe's, in which case I can tell you that I have NVMe RAID mode disabled)

RE: I am not 100% if I am looking at the right thing, but the Security Device Support option is enabled under Trusted Computing. Shoul I disable that too?

1 Like

Yes, that should be TPM.

I still can't see the SSD with secure boot disabled.

Same with Security Device Support disabled

Some users have had this issue with the newer kernel.

Would you be willing to test if Zorin OS 16 detects the m2 nvme?

Here are some screenshots. One of the ssd's can be seen, but the wrong one

sure I will give it a shot.

1 Like

I think I did not partition the drive properly, but it's weird that both SSD's were out of the box and one was seen and one was not.
Do I have to create an ext4 partition, with mount point being /?
If I do that, it warns me that EFI System Partition was not found and the installation might fail.

Yes.

This likely is caused by the BIOS / EFI settings being set to Legacy (MBR) boot instead of EFI boot, or the bootable LiveUSB you are using to install Zorin OS being booted as MBR.
Can you check your BIOS and see if you are set to Legacy?

Storage boot option control is set to UEFI only

The EFI partition may be set on the device that has Windows on it that you mentioned here:

Your other drive is seen, in the installer picture, at the bottom, it show that the boot loader will be installed on nvme0n1, while the partitions are on nvme1n1.

You may need to use the try zorin option, open gparted, and on nvme0n1, create a 500MB Fat32 EFI partition, and at least 30GB ext4 partition (Zorin OS system partition). Include more space as you prefer.

Something similar occurred when I bought a WD Black Drive. For whatever reason, my system didn't register the partition that was available from the factory. If you ever have formatted a 5TB drive, you know my frustration. After creating my own partitions, I have not had issue with the drive visibility. The same may be occurring here.

Thanks! I will attempt this as well. Right now I'm waiting for a different RAM, the previous set were unstable and motherboard stopped POSTing.
Will come back with updates. Thank you

When you do this you will have to use the something else method to install.

An alternative is to create one huge partition then have the installer format the drive and install on it.

Hello, thank you for helping so far. I have managed to install Zorin, it was a pretty smooth operation after I sorted out the hardware compatibility issues (RAM incompatibility with the motherboard and GPU, which was a fun experience).

As I have mentioned, I am dual booting Windows 11 and Zorin. After setting up Zorin successfully, a windows update probably made changes to the BIOS and now I can no longer boot into Zorin, as I cannot see it from boot options.

What I tried to bring the boot menu back up:

  1. Disabled secure boot and CSM
  2. Tried to enable bootmgr from powershell
  3. Reinstalled Zorin from USB
  4. Used the BootRepair tool from Zorin (after I try it from the USB) -> this led me to a NVRam memory locked issue.
  5. Tried clearing NVRam by reseting the CMOS, both with the jumpers on the motherboard and the dedicated button for that, that didn't work.

I tried different options from the bootrepair tool and I get similar fail messages, ubuntu/zorin could not be found. I can paste the exact message if that helps

Are there specific options in that tool that can help me with this NVRam issue? or is this a hardware issue that cannot be sorted out from that tool?

Make sure both SSDs are correctly connected, using compatible PCI ports on your Gigabyte motherboard. Connect only the Crucial P5 SSD during installation. Also, ensure the SSD isn't corrupted by re-flashing the Zorin image using a reliable tool. Moreover, check for any specific BIOS settings related to SSD detection. If the problem persists, try a different USB port or recreate the bootable USB.
Best Regards

You could always power down the computer and completely remove the cmos battery. This is different from resetting the bios in that everything will be wiped away and the default configuration will be applied. While it sounds the same, resetting may not change all of the values.

You will have to turn off secure boot, fast boot, tpm and any other security settings as well.

1 Like