Install Zorin on Asus Vivobook S15 OLED (M3502QA-MA141)

Hi, first thing first, I'm not a linux guru and I just got my new Asus Vivobook S15 OLED (M3502QA-MA141).

Here is the specification of this one:

  • AMD® Ryzen™ 5-5600H 6 magos 3.3 GHz Processor (16M Cache, up to 4.2 GHz)
  • 16GB (2x8) DDR4 RAM
  • 512GB M.2 NVMe™ PCIe® 3.0 SSD
  • GPU: AMD Radeon™ Graphics
  • Display: 15.6" 2.8K (2880 x 1620) OLED (PANTONE Validated) 120 Hz, 550 nit
  • Wi-Fi 802.11 ax
  • Bluetooth v 5
  • HDMI normal
  • USB 2.0 1 db
  • USB 3.0 1 db
  • USB3.1 Type-C 2 db
  • microSD card reader
  • keyboard with backlight
  • Audio: Smart Amp Technológia, Harman/kardon cert, 1 db 3,5 mm Combo Audio Jack
  • 720p HD Webkamera
  • battery: 3 cells 70Whr
  • TPM chip
  • size 359.80x232.90x18.90 mm
  • 1.80 kg

The problem description: When I start with usb installation stick, I see the menu with "Try or Install Zorin OS", "Try or Install Zorin OS (safe graphics)" etc. Even if I choose to try or install with or without safe graphics after a long loading session (checking md5sums) and after that a zorin icon logo + asus logo and zorin text logo+ asus logo I got only the mouse, black screeen and that's all.

Any Idea how can I use my new notebook with a zorin or maybe other ubuntu based os?

I tried the linux /casper/vmlinuz file=/cdrom/preseed/zorin.seed boot=casper quiet splash nomodeset — settings and the secure boot thing too, nothing helped me like this...

First, I would suggest a look at this pre-installation advice: Before you install

Are you intending to dual-boot with Windows?

Your profile states both Core and Lite. Which of these are you attempting to install?

Thanks for the answer!
No, this time I want a simple zorin notebook, without dual boot. This is core usb, I think on this notebook the lite version is causeless

After reviewing that pre-installation checklist, are you now making progress with installation of Core?

If you do not intend to use "Lite", please remove that from your Forum Profile, leaving just "Core". Reason being Core is gnome DE and Lite is xfce DE. We need to know which is being run to help users.

On my workplace I'm using Lite :slight_smile: And at home I have an old 10+ year old pc where we use Lite.
BTW what do you think which one is better for this notebook?

That machine could run with either Core or Lite, but if you are already conversant with Lite then why not stick with that. Lite is a fully functional, not cut-down edition of ZorinOS, so you get the full Zorin flavour and more customisation with XFCE.

After disabeling fast boot I got "The installer encountered an unrecoverable error. A desktop session will now be run so that you may investigate the problem or try installing again" in a gui window, but the else part of the screen is still black and I have only a cursor.

What program did you use to create your bootable USB?
(Not Balena Etcher I hope.)

Either. Given your specs, Core or Lite should run just fine. I have very similar specs to yours except Nvidia instead of AMD. And I am running Zorin OS Lite.
It's just a preference.

For testing, you might try Ubuntu 22.04 or a Rolling release of Fedora - to see if the AMD Radeon Drivers included in the Zorin Kernel are not the right ones for your machine.

1 Like

The lite version got me the same error: "The installer encountered an unrecoverable error. A desktop session will now be run so that you may investigate the problem or try installing again" but at least I got a desktop.

I'm using sometimes rufus sometime balena, why? Balena is not ok?

BalenaEtcher can destroy USB sticks.

Now I created a new one with rufus and the core version has booted and installed but now after installing I got only the zorin logo with the asus logo, when I booting after restart and that's all...

And this tutorial didn't worked in this case: Unable to Boot From the USB Install Drive - Zorin Help

Considering the spec and newness of your Asus Vivobook S15 OLED, can you download and create a live USB of maybe Ubuntu 22.04, as suggested by Aravisian in his post above, to see if that gets any further.

Ubuntu 22.04.3 LTS give me this error:
ubiquity crashed with dbus.exceptions.DBusException in call_blocking(): org.freedesktop.DBus.Error.TimedOut:FAiled to activate service 'org.Freedesktop.UPower':timed out (service start timeout 250000ms)

For either Ubuntu or Zorin OS...
Can you boot computer into the BIOS Settings and ensure you are set to AHCI, not to RAID?
Disable Secure Boot.
Disable TPM.

1 Like

I disabled it, and AHCI is by default as I see, but didn't find TPM in my BIOS, is it possible that is not exist on this motherboard?

It is not always Directly Called TPM in the BIOS.
Here is the Asus page on it:

Yes It should be under Advanced tab, but in my case: