Zorin Forum

Installation crashes

Honesty, ZorinOS Lite would be perfect.
I searched and no other distros even come close to Zorin in what I want (lightweight, design, ease of use for really new users).
Linux Lite would be great but the design is not great.
And Linux Mint is not as lite.
Since I don't have a great internet connection here I cannot easily test any distro. So I think I will stay with windows until there is a fix, or maybe Linux mint (debian édition) or Linux Lite...
I have only two days left to find out what I will do before leaving for several months. Hard decision for some bugs.

Otherwise, I tried Linux Lite and Linux Mint debian edition and seems to be working fine at first then some of the same issues occured on Linux mint (without compatibility mode) and issues with the installer on Linux lite

In these two distributions I had the same errors :

It's to be working with Linux mint in compatibility mode even with the errors.
I can't test every case so it's a bit random when issues occures...

Hope this can help

I'm a bit hopeless now.

I get this feeling a lot... trying to help users on this forum...

Can you try booting the Installer LiveUSB, but at the grub where it asks if you want to "try or install Zorin" tap the e key to enter the grub editor.
You should see that option listed at the bottom of the Grub Menu...

After tapping the e key, scan the page looking for "quiet splash"
Once you find it, add the grub parameter pci=noaer to it so that it looks exactly like:
"quiet splash pci=noaer"

Exit the editor and continue the boot... see what happens...

Yes, I see you everywhere...

I did that :

It seems like I can install zorin os !!!!
Do I install ? Risk ?

Go for it. Fortune favors the bold...

Worst Case Scenario is that we may need to permanently add pci-noaer to grub once installed.
Which we know we can do and how to do it...

I think there is an error :


What should I do ?
If I click cancel it goes back to the type of installation page (partition)

Are you installing as Encrypted or are you installing on a previously encrypted drive?

I don't think the drive is encrypted, let me check.
I can't check...

Repeat the installation procedure, including the e, to open editor, the noaer parameter.
Once you get to the screen that says,
"Install Zorin alongside" etc... you should see a last option below: "Something Else."
Select Something else.
This will open the partition manager. Once at that point, can you take a photo of the screen and post it here?

I rebooted and no errors.

Did not need since a reboot worked

1 Like

Installation worked.
I booted without the "PCI=noaer"
And seems to be working fine for now !

Thank you.

1 Like

Ok, good. So we only needed it for the installation. Rock on.
Fortune has favored the bold.:wink:

1 Like

I'm still getting those in logs :

Should I do something?

Yes, you can still use the pci=noaer by

sudo nano /etc/default/grub

arrow key down and then over to "quiet splash" and add the parameter: "quiet splash pci=noaer"
tap ctrl+x to exit, then the y key to say yes to save, then the enter key.
The terminal will revert to normal. That will make that grub parameter permanent.
Reboot and test...

Does this have any downsides (performance, features) ?

No downsides to performance, no. It merely quiets the error reporting, since the error is corrected (as you can see in your screenshots.)
However... You may prefer to use pci=nommconf - as this disables the PCI memory mapping. This one can potentially cause a loss of performance if the computer is left running for a time, though. For some it is several days... for others a matter of hours.
So, I usually aim for the noaer.

Ok, thank for the explanation. I update the system and see after that. Errors still here, don't mind for now.
Also I'm having issues when rebooting, it stays on boot logo and nothing, I have to force shutdown.

Thank you.

There are many things that can cause that... it would be best to start a new thread on that issue.
Possible causes can be MEI module
Nvidia Graphics
The EFI boot...
Solutions may be using a different Kernel. Blacklisting the MEI module. Or using the noefi grub parameter...

1 Like

Thank you again.
I'll stop for today.