Installation of wifi driver

how can i install a wifi driver

Can you please post the terminal output of:

lshw -c network

heres the results

1 Like

I am not sure if this will work, given the 5.11 kernel but let's try it:

sudo apt-get install dkms build-essential rtl8821ce-dkms

ok heres the photo i took of the results

It looks like you already have the driver installed...
Can you try:

sudo modprobe 8821

here the results

I was afraid of that...

you where afraid of what

Lack of support in the 5.11 kernel. I am looking around now to see if I can find the appropriate support...

Can you please try:

sudo apt install linux-modules-extra-5.11.0-37-generic

here are the results that i got.

Is secure boot enabled in your BIOS settings?

Some info i found on the wifi card.

Source: networking - How do I install drivers for the RTL8821CE Network Controller on Ubuntu 20.04? - Ask Ubuntu

You do NOT need to disable secure boot since apt-get handles everything for you. I installed the driver under Lubuntu 20.04 with secure boot enabled. Based on other posts, I ran

sudo apt-get update
sudo apt-get install dkms build-essential rtl8821ce-dkms

During the 'apt-get install' process, the system installed the MOK certificates and prompted me for a password. When it finished, I rebooted, selected 'Enroll MOK', entered the password, rebooted again, and it worked.

I have doubts that Secure boot is enabled, since above, the O.P. ran that same command and posted a screenshot showing the output. It did not set up mok-utils in that output.

However, I am grasping at straws here. The driver is installed. The system is recognizing the device, but does not see the driver for it.
Modprobe disagreed with the kernel - the kernel says modules-extra is installed. I am nearing toward "stumped" on this one.

heres what i got so far.

now what do i do.

Secure Boot is a setting in your BIOS:
You can access your EFI or BIOS settings at boot or fromt he Zorin Grub Menu f you see Firmware Settings listed. Arrow key down to Firmware Settings and hit enter.
There should be a security tab in the EFI BIOS settings. Scan that tab for "Secure Boot" and see if it is set to enabled or disabled.

do i restart my pc and press f12to go to bios. how do i get to bios

Yes, you must restart to access it.

a little problum i cant seen to save sources list. it tells me can be read only

Thought you already saved it, since the sudo apt update worked.
Is the File Manger still open in /etc/apt? If so, right click sources.list and select open with Text Editor and check the contents.
If not... you'll need to climb through the file directory tree again...