Installation stuck at "Updates and software"

I'm having some issues with installing Zorin OS Core on my main PC. I literary just created my account so please tell me if I need to provide any other info.

I tried flashing the ISO to my USB with balenaEtcher, Rufus and UNetbootin without any luck. I've already read other people's post with a similar topic but they didn't help me.

I also tried unchecking the checkboxes on the same page to not install updates and drivers, but that sadly didn't help. In some cases there is an error saying that "Ubi-partman" has crashed.

I also cannot enter the "Try Zorin OS" area, I get dumped to a read-only terminal.

Interestingly enough, I could install the same edition and version of the OS on my laptop without any issues.

I believe this could be the issue with my SSD which has a corrupted windows install (the result of force exiting the Zorin OS install many times), sadly I could not find a way to delete it without a working OS on the PC. I tried removing it by flashing Ubuntu to my USB but when hitting "Try Ubuntu" the same thing happens as on Zorin OS.

1 Like

I assume the same installation medium was also used to install on your laptop?
If so, could you check if secure boot is disabled (BIOS) on the problematic machine?

Yes, you are correct. And it is not disabled, I will try installing with it disabled. Thanks for your help! (Won't close the issue yet in case it didn't work)

I've checked the BIOS and secure boot was already disabled. But I went with resetting my BIOS settings anyways. Now it boots from the USB, but when the setup start chime is played, I get this screen:

I will try deleting every data from my SSD and HDD and install Zorin OS that way..

Change the boot string to

nouveau.blacklist=1 nolapic

Or try with

  1. For UEFI boot, press e when it says “Start Linux/Ubuntu”.
  2. Find the line that says quiet splash
  3. Right after that, add nomodeset and then press F10 to boot (or whatever key it instructs you to press).

Did not work sadly, the install window now shows, but its empty...

I think that there's something wrong with my BIOS settings. What settings generally need to be set in there?

Disable fastboot (if available) and secureboot.
Can you run a checksum test of Zorin media? On the safe side.

Fastboot was enabled which I have disabled now, where can I run that checksum test? (If you mean the one that runs on every boot, I did not skip that)

I will check the checksum of the ISO though..

1 Like

Update: All errors are gone by flashing the ISO with balenaEtcher. The only problem now is that the installation is stuck at "Updates and software":

Untick Download updates while installing.

1 Like

Try installing without "Download updates while installing..." and do not connect to the web.
Once the OS is installed, open a terminal and run

sudo apt update && sudo apt full-upgrade

1 Like

Same thing happens.. Just the loading cursor and nothing else...

Are you dual booting with Windows?

Nope, I do have a corrupted version on there that I'm trying to override though...

That may be it. In the LiveUSB, before installing, open Gparted and delete the bad partition. Then reformat it to ext4 or move it (resize) to be engulfed by another partition- whatever it is that meets your goals, but get rid of that partition.
Once done, click apply - then try running the installer.

I have formatted my drives as you said, but I'm still stuck at the same page. Are there any logs I could view maybe? I have even disconnected from my network.

You might try unmounting and remounting the disk a few times.
If that fails, run a SMART check on the drive. As you mention that it had a corrupted volume, there may be something wrong with the Drive itself.

There are no logs that would be easy to check at this point.

You may check in your BIOS EFI settings and see if you are using AHCI or RAID.

What am I supposed to do here? (This happened after me spamming unmount and mount)

Clicked yes and now got to the next part of the setup, everything should be going fine now! I'll get back to this page when it has installed.

1 Like