Zorin Forum

Installed apps tab in Software store has goes blank after each and every restart

Installed apps tab in Software store has goes blank after each and every restart.

The solution from Installed apps tab in Software store has gone blank only works till I start my system again.


The person in the other thread was asked for an image, so I took a screen. This has 100% repro for me and is driving me nuts, because I cannot figure out what to do. I do auto daily update checking, so I have everything up to date.

Crosspost:

You might try opening terminal and running:

sudo dpkg --configure -a && sudo apt install gnome-software-common

1 Like

I tried it, restarted and it's blank. :frowning:

Without knowing what was removed previously... It could be hard to guess it out.
Can you check with

grep "remove" /var/log/dpkg.log

If that is blank, try

grep "remove" /var/log/dpkg.log.1

1 Like

Everything from the pre-installed remove-able list. I know it doesn't narrow it down, but yea. I only have GIMP and Print Settings left there from those.

Neither worked. It only temporarily works with sudo apt install --reinstall gnome-software but then goes blank after a restart again.

I have zero idea if that's of any help, but I took screenshots of what is installed:





I installed Steam through there, but for some reason it doesn't show. I think I borped my system, but since everything apart from this works and I'd borp it again when I'd reinstall and start uninstalling stuff, I don't see a point reinstalling. I hope devs release a true minimal install in the future since I've seen other people complaining. Then I'll buy and reinstall. If you figure out what I'm missing, I'd still appreciate help. If you think I'm missing something necessary unrelated to the issue, you can also mention. I appreciate the time you put into it btw. Cheers, mate.

Neither what worked?
The grep "remove" ... terminal commands were to show what has been removed. They were not for restoring the Gnome Software app.

1 Like



Ah, sorry, thought they were akin to the other one. Here's screens:

Oof... You did do some removing...
Well, I recommend restoring

  • gnome-disk-utility
  • file-roller
  • gstreamer
  • All the python3 packages...

Much of what you use relies on Python.

File Roller manages compressed files and compression / decompression. Unless you have replaced it with another File Compress Utility, you will want to reinstall that.

1 Like

Do I need to use ' sudo apt install --reinstall [insert name here from the ones you've listed (albeit unsure about the python3 stuff)]' to do so or do I do it in a different way?

Edit: it worked on the first two, gstreamer gets "E: Unable to locate package gstreamer" and not sure how to proceed with the Python stuff.

Try

sudo apt install -y libgstreamer1.0-dev libgstreamer-plugins-base1.0-dev libgstreamer-plugins-bad1.0-dev gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly gstreamer1.0-libav gstreamer1.0-doc gstreamer1.0-tools gstreamer1.0-x gstreamer1.0-alsa gstreamer1.0-gl gstreamer1.0-gtk3 gstreamer1.0-qt5 gstreamer1.0-pulseaudio python3-lib2to3 python3-paramiko python3-bcrypt python3-fasteners python3-future python3-lockfile python3-monotonic

1 Like

I thought that solved it for a momenet, because I got the loading circle in the Installed tab, but it dissappeared and its blank after Restart again. :sweat:

We may have not gone back far enough... How long ago did you do uninstalls?
Anything older than a month gets compressed as a log, requiring using zgrep (zip) to read. The month, going back is numbered. so month 1, month 2, month 3, would be log.1, log.2, log.3...:

zgrep "remove" /var/log/dpkg.log.1.gz

1 Like

Oh no, I've been on Linux for days, not months, unless I got time warped and didn't realize.

Then it may be just as @DeanG pointed out:
Gnome-Software sucks.

2 Likes

I'll accept my fate, then.

use : https://app-outlet.github.io/ instead of gnome-software

Update: I didn't uninstall anything, but the tab is blank again. I give up. I tried installing app-outlet via sudo apt-get install app-outlet, but the terminal says it cannot localize the package and I downloaded the .deb version. What am I doing wrong?

Did you install the .deb file?
If the installation has unmet dependency then try running

sudo apt --fix-broken install

Btw, while I didn't find a permanent solution to the blank issue, the quickest way to refresh it is via killall gnome-software

Found permanent solution: uninstalling flatpak's addon for flatpak apps appearing in the gnome-software permanently removed the issue. :slight_smile: