Installed zorin 15.3 core but no idea how to connect to wifi

okay ...
currently, i am still with z15.3 and started this series of posts on the 16th of august originally asking how to get connected to wifi.
can't remember who but someone in the forum suggested i should try z/lite because it might be easier then core 16 was released then someone (else?) suggested i install that instead because it should might solve the wifi problem so i opted for 16.
with loads of posts going back and forth, i think i'm possibly near at the point installing 16 if i can get the laptop to install it but hey, what do i know??
i think that pretty much covers your first two questions.
as regards the third one, think i've attempted rufus, unetbootin and etcher with unetbootin finally enabling my usb to be converted to a bootable drive (i don't know how to confirm that) but obviously 16 didn't get installed so maybe unetbootin failed somehow.
with the 3 rufus (etc) programmes, i've tried to get them working a number of times all without success. in fact, i've gone back right to the start and appear to getting kicked back. all this process. is said to be an easy job ... well, could've fooled me. having said that, i don't want to give up 'cos i hate defeat.
my thanks to all of you.
that's about it and fogive my gripe.

later ...
michael.

Good attitude.

As @Aravisian said, this thread has grown big, so was useful for you to give a current situation report.

If you have Z16 on a bootable USB via Unetbootin, can you try to boot from it and do the "Try Zorin" option. That will prove the USB works or not before you attempt a full install.

The idea behind going to Z16 was to give you more uptodate drivers and kernel to see if that overcomes your wifi woes.

1 Like

Is Zorin 15.3 installed or is that what we are working to install?

hi ...
no ... i'm still aiming to install core 16 which i'm presuming will delete 15.3 during the 16 install.

with 'try zorin', how does that work? do i install it on the laptop or the bootable usb drive (if its still bootable)? as with 15.3 and 16, when i download the "try zorin", do i then make sure that it goes onto what i hope will be the bootable drive or do i just make sure that it's in home/recent/download and if so, can you tell me what the code is to copy it over?

on the point of the usb drive, if i covert it to a bootable drive, does it stay a bootable drive or do i need to go through the convertable process a second or third time etc. etc. whenever i attempt an installation of any other particular programme in the future?

I think the best approach would be to take it step by step and ensure each step along the way.
First, you need to Download Zorin OS 16 as an .iso file. If you do this on Linux, it will be in your Downloads folder.
To burn this .iso to disk:

Insert the USB disk you want to burn the iso to into the usb port.
Open Unetbootin.
Click on Diskimage to select it.
Click the ... button on the far right. On the left, select Computer. Then on the right side, select /. Now, select home. Next, select your user name (Should be the only option). Next, Downloads and finally, select the Zorin OS 16 .iso
Now, click the OK button.

hi ...
first thing first ... i've already got 2 or 3 copies of the zorin-os-16-core-64-bit-r1.iso files which i downloaded a few days ago ... one of them should be fine for what i want it to do.
secondly ... my usb drive is connected to the laptop.
thirdly ... the unetbootin-linux64-702.bin file is also in the home/download folder along with the 16core iso file. each time i tried to open the bin files, it gives the following msg:
"could not display unetbootin-linux64-702.bin" ... is unknown.
there are 2 buttons ... 1) no applications exist for etc... and 2)brings me back to the home/download folder.
so i can't open the file nor click on anything else.

I strongly recommend installing unetbootin directly.

sudo add-apt-repository ppa:gezakovacs/ppa

sudo apt-get update && sudo apt-get install unetbootin

okay ...
did all that ...

right at the end, after "E: ..... basically says zorin doesn't have a release file ...
then under that, after "N: ..... says updating from such a repository can't be done securely therefore disabled by default ...
then finally another "N: ... see apt-secure(8) manpage for repository creation and user configuration details ...

Can you either post a screenshot or copy paste the entire message so we can see with repo or packages are in question?

hope this works ...

umm ... tried copy and paste (ctrl+C) but didn't work ...
does linux work with a diff. combination?

In terminal, you can Right Click to find copy or paste in the context menu.
In terminal only, you will find that ctrl+shift+c is needed, even though it is ctrl+c everywhere outside of the terminal. This is because within the code for the terminal (xterm), ctrl+c is already used for another function and it is locked in. Similarly, the keyboard shortcut to paste in the terminal is ctrl+shift+v

gm2fz@gm2fz-Latitude-E7440:~$ sudo add-apt-repository ppa:gezakovacs/ppa
[sudo] password for gm2fz:
UNetbootin http://unetbootin.github.io/ is a cross-platform utility that can create Live USB systems and can load a variety of system utilities or install various Linux distributions and other operating systems without a CD.

Homepage: http://unetbootin.github.io/
Wiki: Home · unetbootin/unetbootin Wiki · GitHub
Downloads: Releases · unetbootin/unetbootin · GitHub
Sourceforge: UNetbootin download | SourceForge.net
Launchpad: http://launchpad.net/unetbootin
More info: UNetbootin PPA : Geza Kovacs
Press [ENTER] to continue or Ctrl-c to cancel adding it.
sudo apt-get update
Ign:1 cdrom://Zorin-OS 15.3 Core 64bit bionic InRelease
Err:2 cdrom://Zorin-OS 15.3 Core 64bit bionic Release
Please use apt-cdrom to allow APT to recognise this CD-ROM. 'apt-get update' cannot be used to add new CD-ROMs
Get:3 Index of /ubuntu bionic-updates InRelease [88.7 kB]
Hit:4 Index of /ubuntu bionic InRelease
Hit:5 Index of /danielrichter2007/grub-customizer/ubuntu bionic InRelease
Get:6 Index of /ubuntu bionic-security InRelease [88.7 kB]
Hit:7 Index of /gezakovacs/ppa/ubuntu bionic InRelease
Hit:8 Index of /zorinos/apps/ubuntu bionic InRelease
Hit:9 Index of /zorinos/drivers/ubuntu bionic InRelease
Get:10 Index of /ubuntu bionic-backports InRelease [74.6 kB]
Hit:11 Index of /stable/ bionic InRelease
Hit:12 Index of /patches/ bionic InRelease
Get:13 Index of /ubuntu bionic-security/main amd64 Packages [1,871 kB]
Get:14 Index of /ubuntu bionic-updates/main amd64 Packages [2,217 kB]
Hit:15 Index of /apps/ bionic InRelease
Hit:16 Index of /drivers/ bionic InRelease
Hit:17 Index of /zorinos/patches/ubuntu bionic InRelease
Get:18 Index of /ubuntu bionic-security/main Translation-en [341 kB]
Get:19 Index of /ubuntu bionic-updates/main i386 Packages [1,345 kB]
Hit:20 Index of /zorinos/stable/ubuntu bionic InRelease
Get:21 Index of /ubuntu bionic-security/main amd64 DEP-11 Metadata [51.4 kB]
Get:22 Index of /ubuntu bionic-security/universe amd64 DEP-11 Metadata [57.9 kB]
Get:23 Index of /ubuntu bionic-security/multiverse amd64 DEP-11 Metadata [2,464 B]
Get:24 Index of /ubuntu bionic-updates/main amd64 DEP-11 Metadata [293 kB]
Get:25 Index of /ubuntu bionic-updates/universe i386 Packages [1,575 kB]
Get:26 Index of /ubuntu bionic-updates/universe amd64 Packages [1,749 kB]
Get:27 Index of /ubuntu bionic-updates/universe amd64 DEP-11 Metadata [295 kB]
Get:28 Index of /ubuntu bionic-updates/multiverse amd64 DEP-11 Metadata [2,468 B]
Get:29 Index of /ubuntu bionic-backports/universe amd64 DEP-11 Metadata [9,272 B]
Reading package lists... Done
E: The repository 'cdrom://Zorin-OS 15.3 Core 64bit bionic Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
gm2fz@gm2fz-Latitude-E7440:~$ sudo apt-get install unetbootin
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
linux-headers-5.4.0-80-generic linux-hwe-5.4-headers-5.4.0-47
linux-hwe-5.4-headers-5.4.0-80 linux-image-5.4.0-80-generic
linux-modules-5.4.0-80-generic linux-modules-extra-5.4.0-80-generic
python3-click python3-colorama
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
extlinux mtools syslinux syslinux-common unetbootin-translations
Suggested packages:
floppyd
Recommended packages:
gksu | kdesudo
The following NEW packages will be installed
extlinux mtools syslinux syslinux-common unetbootin unetbootin-translations
0 to upgrade, 6 to newly install, 0 to remove and 42 not to upgrade.
1 not fully installed or removed.
Need to get 2,075 kB of archives.
After this operation, 8,675 kB of additional disk space will be used.
Do you want to continue? [Y/n] Y
Get:1 Index of /gezakovacs/ppa/ubuntu bionic/main amd64 unetbootin amd64 681-1~bionic1 [221 kB]
Get:2 Index of /ubuntu bionic/universe amd64 extlinux amd64 3:6.03+dfsg1-2 [131 kB]
Get:3 Index of /ubuntu bionic/main amd64 mtools amd64 4.0.18-2ubuntu1 [177 kB]
Get:4 Index of /gezakovacs/ppa/ubuntu bionic/main amd64 unetbootin-translations all 681-1~bionic1 [233 kB]
Get:5 Index of /ubuntu bionic/main amd64 syslinux amd64 3:6.03+dfsg1-2 [142 kB]
Get:6 Index of /ubuntu bionic/main amd64 syslinux-common all 3:6.03+dfsg1-2 [1,171 kB]
Fetched 2,075 kB in 1s (2,507 kB/s)
Selecting previously unselected package extlinux.
(Reading database ... 347157 files and directories currently installed.)
Preparing to unpack .../0-extlinux_3%3a6.03+dfsg1-2_amd64.deb ...
Unpacking extlinux (3:6.03+dfsg1-2) ...
Selecting previously unselected package mtools.
Preparing to unpack .../1-mtools_4.0.18-2ubuntu1_amd64.deb ...
Unpacking mtools (4.0.18-2ubuntu1) ...
Selecting previously unselected package syslinux.
Preparing to unpack .../2-syslinux_3%3a6.03+dfsg1-2_amd64.deb ...
Unpacking syslinux (3:6.03+dfsg1-2) ...
Selecting previously unselected package syslinux-common.
Preparing to unpack .../3-syslinux-common_3%3a6.03+dfsg1-2_all.deb ...
Unpacking syslinux-common (3:6.03+dfsg1-2) ...
Selecting previously unselected package unetbootin.
Preparing to unpack .../4-unetbootin_681-1~bionic1_amd64.deb ...
Unpacking unetbootin (681-1~bionic1) ...
Selecting previously unselected package unetbootin-translations.
Preparing to unpack .../5-unetbootin-translations_681-1~bionic1_all.deb ...
Unpacking unetbootin-translations (681-1~bionic1) ...
Setting up linux-image-5.4.0-84-generic (5.4.0-84.94~18.04.1) ...
Setting up syslinux-common (3:6.03+dfsg1-2) ...
Setting up mtools (4.0.18-2ubuntu1) ...
Setting up unetbootin-translations (681-1~bionic1) ...
Setting up extlinux (3:6.03+dfsg1-2) ...
Setting up syslinux (3:6.03+dfsg1-2) ...
Setting up unetbootin (681-1~bionic1) ...
Processing triggers for desktop-file-utils (0.23-1ubuntu3.18.04.2+zorin1) ...
Processing triggers for install-info (6.5.0.dfsg.1-2) ...
Processing triggers for menu (2.1.47ubuntu2.1) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Processing triggers for gnome-menus (3.13.3-11ubuntu1.1) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for linux-image-5.4.0-84-generic (5.4.0-84.94~18.04.1) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-5.4.0-84-generic
W: Possible missing firmware /lib/firmware/i915/tgl_dmc_ver2_04.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_guc_33.0.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_guc_33.0.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_33.0.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/glk_guc_33.0.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_33.0.0.bin for module i915
W: Possible missing firmware /lib/firmware/i915/icl_guc_33.0.0.bin for module i915
/etc/kernel/postinst.d/zz-update-grub:
Sourcing file `/etc/default/grub'
/usr/sbin/grub-mkconfig: 1: /etc/default/grub: CODESELECT: not found
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 127
dpkg: error processing package linux-image-5.4.0-84-generic (--configure):
installed linux-image-5.4.0-84-generic package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
linux-image-5.4.0-84-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
gm2fz@gm2fz-Latitude-E7440:~$ ^C
gm2fz@gm2fz-Latitude-E7440:~$

thank you for the copy code ....

got it ...

Can you please open Software & Updates from the Zorin Menu.
Select the Other Software tab.
At the very top, UNcheck the box for cdrom://Zorin-OS 15.3 Core 64bit bionic InRelease
Once done, close Software & Updates (let it reload).

Open terminal and run:

sudo apt clean && sudo apt autoremove

sudo apt dist-upgrade

Once done, please relay any errors.


Launch unetbootin from the Zorin Menu and continue from that point in the .iso burning process.

okay ... from the "Z" icon on the far left of the bar at the bottom of the screen, tapped software then updates ... all it showed was "software is up to date" ... nothing else ...

The app is named Software & Updates. If you type out the whole name, just as that, it should show up.

you mean, in the "Z" icon ?

in the z/icon, then in the search bar at the bottom of the small window, everything i ever type in there, never seems to activate except delete what i typed in ... there is nothing i can see to 'send' what i typed in ... so i'm always back to square one .....

in what window do i have to get on screen to tap in 'software & updates' ... ?

As you type, it responds automatically, there is no "enter" function.
But, for now, let's just open it from terminal to make things easier.

software-properties-gtk

thanks ... okay ...
that brought up a small window headed 'software & updates' with a list ...

tabs are z/software, other s/w, updates, authorisation & add. drivers .......
what should i pick ? updates ...?