Installed Zorin 16 Pro and lost sound

Hello Everyone,

I just installed Zorin OS 16 Pro on an older Surface 3 tablet . Everything seems to be working but I have no luck with onboard sound. External Bluetooth and USB sound works , But onboard speakers don't.

I have completely exhausted all the solution and wondering if anyone can help in resolving this.


Have you tried:

sudo apt install firmware-sof-signed

I havent , but i dont seem to have that option

sudo apt install firmware-
firmware-ath9k-htc firmware-microbit-micropython
firmware-ath9k-htc-dbgsym firmware-microbit-micropython-dl
firmware-b43-installer firmware-microbit-micropython-doc
firmware-b43legacy-installer firmware-tomu

You can try downloading it as a .deb pacakge here:

I recommend using Gdebi to install:

sudo apt install gdebi

Ok thanks will give it a try and let you know ,

1 Like

Still no luck seems like Im getting an error message , as cannot overwrite an existing file

That tells us that it is already included though- and not a likely solution.
Back to the drawing board...

Time to do some experiments using alsamixer I reckon.

From terminal (Ctrl+Alt+T), type alsamixer

Hit [F5] to display all your sound channels, i.e. both capture and output.

Post a screenshot on here and we will have a look.

Hello , Here's the output for the alsamixer

Hit [F6] and select the rt5645 card.
Then post screenshot of sound channels.

Here's the screenshot

Every channel that you see marked MM is currently muted.
So starting from the Headphone channel on left unmute by typing "M" (without the quotes"
I suggest you unmute all channels marked MM as experiment.

You can save your alsamixer settings using the terminal command:

sudo alsactl store

PS: I hope your problem with sof-bytcht is easier to fix than this one:

EDIT: I have also done a websearch using "sof-bytcht rt5645 Ubuntu 20.04"
Results include ref to alsa changes v1.2.2. v1.2.3. @Aravisian may be able to understand it better than me.

1 Like

All the channels are unmuted now , but still no luck.


Can you [F5] for all sound channels and do screenshot again.

Here it is ,

OK. I was looking to see if you had a 'Loopback' setting or a 'Auto-Mut(e)' setting you could have a play with. But seems not.

I am out of ideas now myself, but others may be able to help.
My main concern is that you may have to use a different kernel or Linux distro as the other user with sof-bytcht sound @heerenleed did.

Tried this?:


Tried this still no luck

rohanpathak@rohanpathak-Surface-3:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Audio [Intel HDMI/DP LPE Audio], device 0: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Audio [Intel HDMI/DP LPE Audio], device 1: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Audio [Intel HDMI/DP LPE Audio], device 2: HdmiLpeAudio [Intel HDMI/DP LPE Audi]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: rt5645 [sof-bytcht rt5645], device 0: PCM () []
Subdevices: 0/1
Subdevice #0: subdevice #0
card 1: rt5645 [sof-bytcht rt5645], device 1: PCM Deep Buffer (
) []
Subdevices: 1/1
Subdevice #0: subdevice #0

What about:

sudo lshw -c multimedia

Here's the output it shows as unlcaimed

sudo lshw -c multimedia
*-multimedia UNCLAIMED
description: Multimedia controller
product: Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series Imaging Unit
vendor: Intel Corporation
physical id: 3
bus info: pci@0000:00:03.0
version: 20
width: 32 bits
clock: 33MHz
capabilities: pm msi cap_list
configuration: latency=0
resources: memory:d1000000-d13fffff