No automute when headphone is connected, other strange bahaviour of audio

Hi there, I am completely new to linux and i recently decided to say goodbye to MS and installed the beautiful Z16. Everything works a treat and my very small Asus R209H is faster and more responsive than it was in its last W10 days. However, I have an audio issue. I do have sound, but when I plug in the headphones the speakers do not automute. Did a search (many searches) and found I needed to use alsamixer. BUT Alsamixer has no automute column, the first column is called headphone but the title is in red and the values are 00. Can anyone point me in the right direction? I need to add that when trying to adjust the sound settings from the taskbar, when testing the speakers the right and left channel are randomly swapped sometimes, for no obvious reason. Thanks for any help.

Hi and welcome to the forum. Can you please edit your forum profile to indicate which edition of Z16 you have e.g. Core, Lite etc.

Can you enter alsamixer, hit F6 and check correct sound card is shown as default. Then hit F5 to show All channels and post a screenshot here.

Hi and thanks for your answer. I have now completed my profile and I am running Z16 core. When I enter alsamixer and hit F6 I can see that there is no default sound card at all. I include a screenshot of this. Hitting F5 has no effect, if I scroll down to soundcard one I get a number of inactive and inaccessible columns. As I explained I am new at this.
no controls

schermafdruk 2

My mistake, do sudo apt —reinstall install alsa-utils

[quote="carmar, post:4, topic:14823"]
sudo apt —reinstall install alsamixer[/quote]

I tried it, it returned 'invalid command', then took out the space after apt, even altered the command a little to try again, but this returned 'command not found.

schermafbeelding 3
tried sudo apt-uninstall alsamixer as well, also 'not found'.

My mistake, do sudo apt —reinstall install alsa-utils

Sorry, instead of posting I accidentally edited my old post. Please use alsa-utils instead of alsamixer in the reinstall command.

PS - also, I recommend seeing Using apt Commands in Linux [Complete Guide] - It's FOSS , as an aside.

1 Like

nope, same result:
Tried some variants as you can see to make sure, but no, alas.

EDIT: SORRY, missed the second hyphen, tried again, now it seems to work, but the result when retrying alsamixer has not changed.

1 Like

Hi @heerenleed disclaimer: I am not a Zorin support team member, just a user, like you, who has spend 3 days with a different sound question. I'm also running Z 15, not 16.
I have just, a few minutes ago, posted a solution to my issue.
I would link you to it but don't know how! :worried:

I am not sure if this is helpful but, in the screen you posted - shown below - click on the various options, maybe 0 is a good start. Hopefully you may see something like my image which may give you more options play around with.

Thanks, I will certainly try.
Edit: tried it, but I get no return at all.

The default is the one displayed i.e. "Intel HDMI/DP LPE Audio" but is showing no controls for that.

For your "sof-bytcht cx2072X" can you hit F5 to display All channels, not just Playback and post screenshot.
But looking at Playback controls for that card, it does not look promising.

EDIT: I have done a websearch "cx2072X ubuntu 20.04" but not many hits. This one mentions a bug which is solved in Ubuntu 20.10, but Z16 is based on Ubuntu 20.04.
See last item in this:

Ahhh, sorry, I am a one trick pony.

Do you know your sound card details?
There is a command you can use via TERMINAL - you can search for this. I have it somewhere but might take me a while to get back.

It was a long shot, but as your screen shot looked very much like mine in default mode (no sound card) I thought it was worth a try as my issue was, sort of, reverse of yours.

Hopefully someone more qualified can jump in here.
Sorry again.


Here is the screenshot. I find this a worrying problem. I could have lived without the automute, but I also get a very loud whistle every couple of minutes. Unplugging and replugging the earphones stops it, but only temporarily. I can tell you, it is not pleasant. I fear, if there is no solution, I won't be able to use Zorin16, much to my regret.
Alsa shot

I should maybe add that, while 'trying' Zorin the audio problems do not occur. Not in Zorin Lite, not in Zorin Core. Only after installing it the problems start.

See my edited post #10 above. No automute when headphone is connected, other strange bahaviour of audio - #10 by zabadabadoo

What happens if you unmute (hit M) on the "DAC1" channel in alsamixer?

I just looked again at your #10 post, I have little time as I need to leave for the afternoon soon, but it looks like it is a bit over my head, but I will put some effort into it later. As for unmuting the DAC1 channel (I see two with that name, but only the one on the left reacts. I get 00 in a green background, but I lose all sound when i do.

OK. Worth a try, but I am now out of ideas considering bug fix reference to Ubuntu 20.10. i.e. beyond current Z16.

Hi again, still the same one trick pony, but looking at your latest screen shot it is similar to one "chart" that I ran up against. Except mine were named something other than DAC.

So, as an extreme shot - first, the second DAC on the right, can you control it via the arrow keys - up / down?
The last slider in my setup was responsible for white noise which turned into an ear splitting whistle when I turned it up, diminished as I turned it down down. In my case I was actually able to disable it without any system ill defect.

An even longer shot, which probably you have tried, but ref the first switches with no slider. In my case once I selected one I was able to activate and increase the slider, hence volume, again via the arrow keys.

If that works, then I am afraid it is a time consuming job of working out which key combinations control head set and which speakers, then turning those on and others off.
If like me you are wired for creativity and not technology, it is a bit of a challenge, good old coloured pencils and paper help!

I scribbled around a dozen pages of notes for my solution, if I can think of anything else I will let you know.
Sadly, computer sound is something of a contradictory enigma -one would expect it to be logical and therefore one solutions fits all, but in truth is not.

I know this is not a great introduction to Linux or Zorin in particular, but don't throw the baby out with the cabbage water. It is worth perceiving.


Hi there again, thank you for taking your time. Indeed I am wired like you, as a writer, so while I don't have a problem with tinkering with my computer to try new things, at the end of the day things should work as intended. What I managed to do when trying as you suggested was getting my speakers switched off, so I only had my headphones working. After that, I could not switch them on again. What was - and is - worse, is that the screaming noise still occurs at random intervals, and I now noticed that when that happes the computer stops all processes until the noise stops, which I sometimes can provoke by unplugging and/or replugging the earphones. All quite discouraging. I have also tried the script as suggested by Zabadabadoo, but that did not help either as somewhere in the return it stated that my cx2072x was not found. sigh.

Hello, I am really, really sorry you are having a difficult time with Linux. It is, as you say, not a very good start.
The rest of this is off topic, likely not helpful, but might be interesting background.

OK, my guess was fairly correct - your issue is reverse to mine.
I could activate headset but not internal speakers. "Tinkering" with the ALSA slider controls turn speaker on but with white noise - background hiss. Mistakenly switching to head set resulted in an ear splitting scream. Problem was MIC settings.
Eventually found the combination to be able to use both comfortably.

I just have one question, which may seem stupid, but; when you talk about SPEAKERS, are you referring to external or internal?
My issue was internal.

I ask as I had something similar with a friends desk top machine, years ago. She was trying to run desktop (ext) speaker from the same rear output jack as her mic via a splitter plug.

I am not a sound engineer, but I learnt from working on theatre sets that often talent's mic has to be re calibrated several times depending on each "act" as the "gain" often caused squeal. ( a lot of other elect / radio hardware on set) Or the mic wasn't shielded properly. In almost all speaker screeching, the issue is almost always MIC or some other electrical or radio appliance creating "feedback." As I said, this was not a one time fix for all - different stage positions needed different fixes. It's probably automated by now!

My ALSA settings showed a MIC slider, equal to the old GAIN control I worked with decades back so I took a punt and killed that. Problem solved.

Anyway, I just needed to confirm as I was thinking you were referring to built in speakers - you mentioned a tiny Asus.
If they are external, maybe ALSAMIXER is not relevant.

Your post reads you are running Z16 pure?
Or dual boot with another O/S?
Did you use auto install or "something else?"
Did you try a reinstall when the issue first presented?
I ask as I'm just a bit confused by your last para ref the various versions.

Finally, it reads as if you were able to activate the sliders on the first 4 switches, (as shown in your last screen shot) using the arrow keys. Can you include a screen shot please?
Probably not directly helpful, but one never knows - might just be someone else reading who recognises it~

Sorry this is long and rambling, but the more info we can put out, the better the chances of finding a solution.
A writer huh, small world!

Blockquote> just have one question, which may seem stupid, but; when you talk about SPEAKERS, are you referring to external or internal?

Thanks again for taking the time. I only have internal speakers.

Blockquote Your post reads you are running Z16 pure?
Or dual boot with another O/S?
Did you use auto install or "something else?"
Did you try a reinstall when the issue first presented?
I ask as I'm just a bit confused by your last para ref the various versions.

I a running Z16 pure, as I said, it's a tiny machine with only 32G, so hardly any space to have anything else on the side. I did an auto-install for the same reason, as I wanted a clean install without any old rubbish sticking around. As for reinstalling, I think I did that about twenty times. And I did try the Z16 Lite version as well. And as I said, while still in the 'try Zorin' mode the audio worked as it should. Only after installing Z16 the screaming started. I really am at a loss.

Blockquote Finally, it reads as if you were able to activate the sliders on the first 4 switches, (as shown in your last screen shot) using the arrow keys. Can you include a screen shot please?

no, I was not able to activate the sliders on the first four switches, I enclose the screenshot. You probably saw the activated sliders I reached when using thte tab key.

Frankly, I am on the verge of giving up on Zorin. Much to my regret as the distro is a treat for sore eyes and there are some very good functionalities. But I also compose videos using OpenShot and sound is essential. Plus, I can't have the computer freeze when the screaming starts again at random intervals, which it does. As we speak I am downloading the latest Mint Cinnamon as I read about someone with the same machine who experienced the same problems and found that everything worked out of the box using Mint 20. So I think I am going to give that a go. I have spent too much time getting nowhere.
I will keep an eye out though for any possible solution, as I would rather stick with Zorin. But as I said, as it is now it is unusable.
I will let you all know if the problem occurs in Linux Mint. If it does I see no other solution than tuck my tail and reinstall Windows10, - perish the thought.


I missed that on first reading 2days ago as I just concentrated on the alsamixer screenshot.
This has not been the first time I have heard that sound/wifi etc work OK on "Live USB" but not after installation. There may be a clue there.

I cannot see where I have suggested a script. If that came from the link I gave to Launchpad (post #10), I said to see last item that referred to ubuntu 20.10.

In my experience sound problems on Linux are not straightforward or logical to diagnose and solve. A lot of trial-and-error messing about is sometimes called for. It is one reason why I have stuck with Z15.3, after some problems getting my sound (internal speakers) working on that.

If anyone reading this can explain why @heerenleed had audio working on "Live USB" but not since installation, please contribute.