Installed Zorin but full of bugs

I can't even access the usb drive it says error mounting...Bad superblock

So, I Suggest reinstalling Brave Using the Terminal if internet is working,

sudo apt purge brave-browser
rm -rf ~/.config/BraveSoftware
rm -rf ~/.cache/BraveSoftware
sudo apt autoremove

To Install

sudo apt install apt-transport-https curl

sudo curl -fsSLo /usr/share/keyrings/brave-browser-archive-keyring.gpg

echo "deb [signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg arch=amd64] stable main"|sudo tee /etc/apt/sources.list.d/brave-browser-release.list

sudo apt update

sudo apt install brave-browser

Shouldn't Firefox work fine? Because it has the same connection issue

Have you tried?
Actually, You should switch back to mac os, It is a headache for users using Zorin and other Ubuntu Distributions with mac hardware.

I'm on a pc

Just by restarting my PC it's just full of error messages and failed to connect msgs. Failed to parse and more. Failed any suggestions how I can test this using terminal?

Is there a way to undo commands in terminal?

No, Have you made a back up or something?

No unfortunately not

The Only Thing we can Do here is try a reinstall and if that gives the same problems, then, maybe your mac is not supported by zorin and you should probably switch back to mac OS

I am on a Dell windows PC not a mac.

You made a lot of Confusion for me, Are you Dual Booting? using Windows and Can you create a boot drive?

Ok I'm on a pc no dual booting. I just typed into terminal curl -i and a Webadress and I get the error 6 could not resolve host.

I don't have the os on a usb anymore. Firefox or brave both can't connect to host.

Internet is definitely here some I'm using it on my phone and it is fairly fast too

Okay, what we need is a usb. Please Arrange and how did you installed Zorin btw?

I have a usb stick but the computer says it can not read it.

Please access another computer and make it Bootable. The Installation is Corrupt.
Please Follow this Guide,

Could try to do a desktop reinstall from terminal, although a fresh install maybe better.

sudo apt reinstall zorin-os-desktop && sudo apt reinstall zorin-os-standard && sudo apt reinstall zorin-os-default-settings

See if reinstalling those packages helps

Also want to add, a quick trick is you can often use your phone as an internet source over usb, using usb tethering to get packages updated / reinstalled for linux. I have to do this for my laptop as the wifi is not supported oob

I tried my hotspot on my phone but for some reason that didn't work either. No webpage was loading correctly.