Installer Crash when installing Zorin OS Lite 16 via USB

This error pops up on the last installation page (Installation Type) where you pick a partition table. On this page, It doesn't show ANY partition tables. When I click the + button to try and add one, the error pops up:

We're sorry; the installer crashed. After you close this window, we'll allow you to file a bug report using the integrated bug reporting tool. This will gather information about your system and your installation process. The details will be sent to our bug tracker and a developer will attend to the problem as soon as possible.
** **Traceback (most recent call last):** ** File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 1514, in on_partition_list_new_activate** ** self.partman_dialog(devpart, partition)** ** File "/usr/lib/ubiquity/ubiquity/plugin.py", line 48, in wrapper** ** return target(self, *args, **kwargs)** ** File "/usr/lib/ubiquity/plugins/ubi-partman.py", line 1177, in partman_dialog** ** if create and partition['parted']['type'] == 'pri/log':** **TypeError: 'NoneType' object is not subscriptable** **
May I get some guidance here please?

Hi and welcome to the forum.
First I will point you to this advice thread for new ZorinOS installers. Before you install
Did you check the SHA256 checksum of the downloaded iso?
Which USB creator tool did you use to prepare your Live USB?

2 Likes

I used Rufus to prepare the live USB. If it makes a difference, I was able to successfully install Zorin on my other Laptop (Acer with 4 GB). Right now I am trying to install it on my HP Laptop (8 GB) with the sam USB. I've also disabled secure boot through BIOS settings, but still no luck.

Should I flash the USB again with another computer? Am I not allowed to use the same USB I used to install Zorin on another laptop?

Lastly, how do I know this is just a hardware issue? (Although, I am able to run a live session of Zorin after the failed install so I don't really think it is a hardware issue)

You are totally allowed.

This looks like an issue with your partitions.
Have you ever had Windows installed on that computer?
If so, did you disable Fast boot or Fast startup in Control Panel > Power settings?
Fast boot locks the hard drive, preventing write access.

Was your selected partition for the install too small?

Have you run a S.M.A.R.T. test on the drive to check for corruptions (Sometimes, a corrupted Windows sector is the issue)?

Did you set the mount point to /?

I did have Windows 10 installed on it. It doesn't load up Windows 10 anymore (not sure why) which is why I am trying to install Linux.

I don't ever recall disabling Fast Boot or Fast Startup. I am not sure how I would do that if I can't boot up Windows 10 anymore.

I was not even given an option to select a partition. When I get to the 'Installation Type' part there are no partitions to select from.

How do I run a S.M.A.R.T text on the drive to check for corruption? (I don't think I have done this)

How do I set the mount point to "/" (I don't think I have done this)

Appreciate you getting back to me!

This... may be important...
Definitely sounds like a corrupted drive.

1 Like

Thanks, I will look into this a little more. Are there any forums or sub-reddits you know of that can likely help me out in this area?

I don't... Most other forums I torment are Science discussion groups, not computers...

The above link should help guide you through S.M.A.R.T. test, though.
In short, you could try completely wiping and formatting the drive (You can do this using the Live USB Zorin by running gparted, just wipe and reformat the drive before running the installer), just to see if that clears up the drive.

1 Like

Thanks, I will try that!

Sorry, I am a bit lost with GParted. All I see when the program loads is my Linux Mint partition. Am I supposed to see my drive on here?

It shows a 60 gig partition on /sda... It looks like a bootable .iso

If you look at the Upper right side, you will see a button with a drop down menu. Clicking that should allow you to examine other drives connected, if there are any.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.