Installer crashes

I got this error message when I try to install the OS.
Win10 64bit, 2gigram, Zorin OS core. Fastbook disabled

1 Like

2 GB is not much. You should properly get the lite version .

Such errors may indicate faulty image. Try re-download. Which application did you use to make the image on the USB stick?

1 Like

Rufus

1 Like

Are you trying to install Zorin 15.3 (Strongly recommend Zorin OS Lite)?

If so, please boot the Live USB media into the Trial Desktop.

First, check that you have active net connection. Then, open a Terminal (ctrl+alt+t keyboard shortcut or you can search the App Menu for Terminal)
Input the following commands one by one (You might email these commands to yourself, then open your email in the Try Zorin browser and just Copy and paste each command into the terminal):
Change directory to home downloads folder:

cd ~/Downloads

Use wget to fetch the Ubiquity Installer patch

wget https://code.launchpad.net/~azzar1/ubiquity/+git/ubiquity/+merge/345056/+preview-diff/831305/+files/preview.diff --output-document ubiquity.patch

Copy the patch in the proper location to make a bkp:

sudo cp /usr/lib/ubiquity/ubiquity/misc.py /usr/lib/ubiquity/ubiquity/misc.py.original

apply the patch:

sudo patch /usr/lib/ubiquity/ubiquity/misc.py ubiquity.patch

Do not reboot or you will need to repeat the above steps.
Next, run the Install Zorin icon from the desktop and start the installer.

Reversed (or previously applied) patch detected Assume -R? [n]

What will I type??

You can skip with n.

1 Like

Still getting the same error

Ok, close out the installer with error and in Live Zorin terminal:

sudo apt update

sudo apt install ubiquity

If Ubiquity installs successfully, try running the Install Zorin installer, again.

1 Like

Jeez. Still the same issue.

What is the year, make and model of your computer?

Have you considered beating the operating system into it with a Hammer?

Is Secure Boot disabled in UEFI settings?

Innjoo Leapbook A100, 2017.
I don't know if secure boot is disabled though

You are not alone in this...

So even if I try the lite version, I won't be able to run Zorin?

I am not sure... That thread above demonstrates that your particular machine (same as that poster) seems to show the same error.
I'm searching the web now seeing if anything else comes up...

Okay. But I booted Lubuntu without problems.

which version?

This thread suggests using this command in terminal prior to installing;

LC_ALL=C.UTF-8

https://ubuntu-bugs.narkive.com/SwHbp5eY/bug-1740026-re-ubiquity-crashed-with-unicodedecodeerror-in-decode-utf-8-codec-can-t-decode-byte

https://www.mail-archive.com/search?l=ubuntu-bugs@lists.ubuntu.com&q=subject:"\[Bug+1010316\]+Re\%3A+ubiquity+crashed+in+install.py\"%2C+line+218%2C in+generate_blacklist+\%3A+UnicodeDecodeError\%3A+'utf\-8'+codec+can't decode+byte+0x8b+in+position+1\%3A+invalid+start+byte"&o=newest&f=1

Run the command after try Zorin?

I want to switch to the Lite version, but hope I won't run into this same crash

Had same error with lite version

1 Like