Installing Language Tool extension in Libre Office

Dear Community,

I yesterday installed Zorin OS, its a stable and great OS.
After that i tryed install the extension for libre office, as you can find it here:
https://extensions.libreoffice.org/en/extensions/show/languagetool

But when i try libre office it gave me the next fail:
(com.sun.star.uno.RuntimeException) {{Message = "[JavaVirtualMachine]:An unexpected error occurred while searching for a java, 11 /build/libreoffice-FUsBEB/- (com.sun.star.uno.Xinterface) @0 }}

After this error i delete the extension and installed:
OpenJDK 11 SDK Extension from the software centre.

After this i restarted the computer and tryed to install the extension again, but it gaves the same error.

Finaly i tryed the following command on the terminal:
sudo apt-get install openjdk-16-jre
And try it again, but again the same error :frowning:

Can somebody help to make this work? Thanks a lot...

I corrected a tiny typo in the title and added "Libre Office" to attract more help from other volunteers.

2 Likes

I also corrected a minor typo in the title - no big deal.

I have asked this question in another thread (Reference Managers (Zotero, Mendeley, Sciwheel...)) where a plug-in could not be installed, so will ask again here.

@Eismckwadraat19
Are you using LibreOffice that came with ZorinOS or have you downloaded a different version from Snap or AppImage?

Thanks for correcting, i use the libre office that came with zorin OS

Ah. So was the user in the other thread :frowning_face:
So we can't blame Snap for this.

1 Like

Have you see this item included in LanguageTool webpage: Installation Issues with LibreOffice/OpenOffice : LanguageTool

thank you i have read it, but i think these errors are different...

Have you checked the language settings in Libre Office?
This is probably a longshot, excuse me if I waste your time, I don't know if this will help but maybe the Language Tools needs you to choose the same language as the LanguageTool will use before you install it.
If you want to try this, start Libre Office Writer, Tools, Options, Expand Language Settings, Languages and change all settings to the Language your Language Tool will be used for:

Restart Writer and go back and check the settings, this is how it looks for me after restart:

Actually I now find I dont need to install the Language Tool because Spellcheck and Menus are now running in Swedish (my native languauge).

I don't know if Libre Office found the language files I downloaded and extracted automatically (I didn't install them, don't know how to).

2 Likes

Change the language settings in Libre Office as shown above, then check this site: Installation Issues with LibreOffice/OpenOffice
From there you can download a language tool writer file (click on the link "load this document"). Very useful. Hopefully you will find menus in the language of your choice and spell check working.

1 Like

Check this site: Installation Issues with LibreOffice/OpenOffice
From there you can download a language tool writer file (click on the link "load this document"). Very useful.