Installing Samsung printer and scanner driver

Hello,

I am new to linux and just installed Zorin Core on an Acer Aspire x3950 with i3 540 @ 3.07GHz, 4GB memory, Intel HD graphics, 1TB HD. It is dual booted with Win10 64bit. Zorin has 350GB on the HD. I am trying to install a Samsung CLX 3305FW Multifunction Printer that is on my home network. Zorin installed this printer automatically during installation so that was great.

However, the printer functionality is limited and I have no scanning ability meaning SimpleScan does not see my printer.

I have tried installing another driver downloaded from HP for the Samsung printer into: Downloads/uld_V1.00.39_01.17.tar.gz and following the instructions https://easylinuxtipsproject.blogspot.com/p/samsung-printers.html
that I originally followed from https://zoringroup.com/forum/5/8878/

It installs but I cannot find this “new” printer when adding new printer. Tried reinstalling and it says it is already there.

I have tried this https://tutorialforlinux.com/2018/03/26/ubuntu-18-04-samsung-printer-driver-install-guide/ but I have also run into other problems after running this:
sudo apt install suld-driver2-1.00.36
The error I get is it cannot install this because a dependancy is missing libusb-0.1-4.

I tried to install this but get the following error:
$ sudo apt-get install libusb-0.1-4
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libusb-0.1-4 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘libusb-0.1-4’ has no installation candidate

So I am stuck. Any guidance anyone can provide is greatly appreciated. Many thanks in advance.

Hi, sj60.

A few questions and suggestions, in order:

  1. When you first plugged-in the printer, did it appear under Zorin menu->Settings->Devices->Printers? If not, did you try Adding using the button on that window? This is before you even tried the driver or other steps.
  2. When you moved to downloading the driver, can you confirm that you downloaded the driver (I found this) extracted it, ran install.sh (can directly double-click, make sure Permissions (right-click->Properties-Permissions) has box checked to allow executing as program)?
  3. Can you install Synaptic and see if there are any packages listed under “Broken” (see first pic on that linked page)? If they are broken, please right-click and Fix and Apply.
  4. If after any of these steps (including next step) you see a printer appear, and see a duplicate, remove one of them. In my experience remove the one not listed as CUPS. Aravisian here advises related steps here - try his recommendations too.
  5. Does this work?

PS - You some times have to wait for Simple Scan to recognize the printer. It is quick on some machines and not so on others. This is assuming it shows up under Devices, as I mentioned earlier.

1 Like

Hello Carmar,

Thank you for the suggestions above.

I have the similar issues with the Simple Scanner with my Samsung M2070W Printer-Scanner. When I start Simple-Scanner, it seems to recognise that I am using a Samsung Scanner but wants me to install additional drivers.

Happy to say I have no problem with the printer recognition though. I tried using Linux Mint and Ubuntu in the past and they both recognise my this printer-scanner model.

The installation process was simple: sudo sh install-scanner.sh and sudo sh install-printer.sh.

Also tried the Synaptic and Simple Scanner is not “Broken”.

Are there further troubleshooting steps that I can try out next?

Kind regards…

Hi, Munso.

Simple scan can be fickle. I installed it on my wife’s laptop a while back and it never gave me problems. Then I installed it on my wife’s desktop and it refused to recognize the attached Brother scanner. I removed and reinstalled Simple scan using Synaptic about 3 times before it finally behaved. It could have been that some time in-between those 3 times I installed the manufacturer provided ubuntu driver that may have helped. But I recall that Zorin had automatically recognized the device without the manufacturer driver. So, I hate to say this but uninstalling and reinstalling is a tactic that worked for me. I also recall removing the non-CUPS device (same printer was listed under Settings->Devices as two separate devices after the manufacturer driver installation) and then the Simple scan worked.

On the other hand, you could try what is suggested here: https://askubuntu.com/questions/969238/samsung-m2070w-scanner-no-longer-working-in-17-10

I also recommend trying steps #4 and #5 (in my earlier post), if you haven’t already tried them.

Hi carmar

Thank you for your reply.

When I first installed Zorin, the installation picked up my networked printer and installed it. I was happy to see it under Devices->Printers. And this was before I tried to install any other drivers for it or take the other steps I noted.

Yes this is the driver I downloaded. As in my original post it was uld_V1.00.39_01.17.tar.gz

The file install.sh is checked to allow executing as program. However I installed it using sudo sh install.sh andwith the terminal window maximized as per the instructions in


indicated in my OP. Everything seemed to install fine with no errors.

I tried to install this but ran into trouble.

simon@Entertainment:~$ sudo apt install synaptic
[sudo] password for simon:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package synaptic is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘synaptic’ has no installation candidate

I then tried to update, and received this message:

simon@Entertainment:~$ apt-get update
Reading package lists… Done
E: Could not open lock file /var/lib/apt/lists/lock - open (13: Permission denied)
E: Unable to lock directory /var/lib/apt/lists/
W: Problem unlinking the file /var/cache/apt/pkgcache.bin - RemoveCaches (13: Permission denied)
W: Problem unlinking the file /var/cache/apt/srcpkgcache.bin - RemoveCaches (13: Permission denied)

I am sorry I have not progressed much beyond this step.

I have noticed that Zorin has installed a second Samsung printer called “driverless” today when I launched it. Not sure why – it is all a mystery to me at this moment. In any case Simple Scan still does not see my printer.

Many thanks for your help!

Your update command failed because you didn’t run it with sudo.

No matter. Can you do the following? Zorin Menu -> System Tools -> Software Updater -> Settings -> Zorin Software -> make sure “Download from” pointing to the Main Server. It should look like the screenshots (including the checked boxes). Also check the Other Software tab.
mainserver


Then please let the Software Updater run any updates and install them. Once those are done then try and install Synaptic again.

Thank you carmar.

These latest steps helped to install synaptic.
Synaptic did not find any Broken packages.

I was able to get the driver installed using Synaptic Package Manager GUI. It also helped to install all dependencies.

Simple Scan now recognises the Samsung CLX 3305 scanner and I am able to scan a test page.

However as mentioned in my previous response, I now have two “identical” Samsung printers listed. “identical” meaning the printer has a “.local” extension to the name and is described as local raw printer. Both “printers” seem to be non-CUPS. I do not know what CUPS refers to. These two printers seem to cause a conflict and I can no longer print. I cannot delete them either – as soon as I delete them they are being automatically reinstalled.

So I gained scanning but lost printing. I feel I am just a small step to solving this.
Thank you in advance if you have any other suggestions I could try.

CUPS: https://ubuntu.com/server/docs/service-cups

To remove a printer, use lpadmin -x <PrinterName> but before that, please go to Synaptic and Search for “samsung” (without quotes). On mine I see one driver named ‘printer-driver-splix’. Can you see if you have more? I’m guessing any other ones may be the one you installed in the very beginning from the file you downloaded and it may be interfering with the removal. If you’re unsure then just use the lpadmin command.

Samsung Installed Drivers that are installed:
printer-driver-splix version 2.0.0+svn315-sfakesync1 Driver for Samsung and Xerox SPL2 and SPLc laser printers
suld-driver2-1.00.36 version 1.00.36-4 Samsung unified linux driver2
suld-driver2-common-1 version 1-12 Samsung unified linux driver2 (common files)
suld-ppd-4 version 1.00.39-1 Samsung unified linux driver2 (ppd files)
suldr-keyring version 2 Samsung unified linux driver repository keyring

Do I still remove them all using lpadmin ?
Once I remove them all do I then reinstall the driver I installed before?

Many thanks!

If I had to guess:
2. suld-driver2-1.00.36 version 1.00.36-4 Samsung unified linux driver2
3. suld-driver2-common-1 version 1-12 Samsung unified linux driver2 (common files)
4. suld-ppd-4 version 1.00.39-1 Samsung unified linux driver2 (ppd files)
are the ones you installed before you posted on the forum. Remove these using Synaptic. Use “Completely Remove” option (right click on the package name on Synaptic) on the drivers and then see if you get your printing back with just:

  1. printer-driver-splix version 2.0.0+svn315-sfakesync1 Driver for Samsung and Xerox SPL2 and SPLc laser printers
  2. suldr-keyring version 2 Samsung unified linux driver repository keyring
    left on the Synaptic list.
    The goal is to only let Zorin detect the printer and use its own driver.

lpdamin removes printers, not the drivers - you can get the printer names using lpstat -p or lpstat -a. Then you use lpadmin -x <PrinterName> with whatever names came out. Don’t use this yet. See if the package (driver) removal does the trick. This is only because you wrote that you have duplicates of the same printer, so only use if distinct names pop out and not just one name.

Hi carmar

unfortunately your suggestions did not work and I lost printing and scanning functionality.

So after removing all printers using synaptic and then lpstat -p and lpadmin -x, I reinstalled using synaptic:

but deleted:

I ensured that printers via the printer manager were all removed.

Once these were reinstalled, I used the printer manager to find and install the networked printer.
This resulted in two semi-identical (this time) printers being installed again, with #2 popping up automatically once #1 was installed.
#1 called Samsung-CLX-3300 driverless;
#2 called Samsung_CLX_3300_Series_SEC001599D21FF6_

This gave me back scanning functionality and semi-printing functionality.
By semi-printing meaning a test page sent to #1 would only print in colour mode, but any changes to print only in monochrome or grey scale would print garbage until it emptied my paper tray. Sending a test page to #2 prints garbage regardless.

Printing only in colour mode would be fine when printing text IF the print came out purely in black and white but it doesn’t. For some reason it tries to mimic b&w and the print is more black text with a background trying to be white but comes out hints of greyish or psuedo-grey, something like a scanned text page which is then printed. This results in an unclean print for me.

I tried using Libre writer and default text editor to the same results (thinking maybe it had something to do with how the driver was implemented).

So either the linux drivers available for my printer do not seem to do a great job at printing or the double installation of the printers are again causing conflicts.

I will be doing some trial and error in the next few days and removing and installing printers etc in various combinations to see what happens.

Thank-you again for all the help you have given. Have a great weekend!

sj60,
Sorry to read about your troubles.

The packages on Synaptic are not printers - they are drivers and supporting files. If you remove one (or more) driver for a printer it simply means that the printer may still be recognized by Zorin but would use whatever remaining drivers it finds available.
In contrast, the system recognizes printers and displays/manages them using lpadmin and lpstat.

My intent was to remove any conflicting drivers because that seems to be what is interfering. Hence, removal of whatever you had installed before. When I read that you had problems installing Synaptic, I realized your updates weren’t being pulled from the correct repositories, hence my subsequent post on the Updater. That would also imply that Zorin’s driver may have been able to help you print properly without the need for the external HP driver but the Zorin driver was not given a chance since your Software Updater wasn’t updating properly. Since you had already installed the HP driver, I naturally suspected that was causing interference between printing and scanning. Note that once we corrected the Software Updater, the Zorin driver may have also loaded while the HP driver was also already loaded (partially or otherwise) on the system.

Given all that you have been through, I completely understand if you decide to troubleshoot yourself. I can only suggest that to start from a baseline, I recommend removing all Samsung drivers listed on Synaptic and removing all printers using lpadmin. Also make sure no printers are showing under Zorin menu -> Settings. I only suggested lpadmin because you stated that you are unable to permanently remove the duplicate installed printers using Settings. With this clean slate, and all updates installed from Software Updater, then plug your printer back in to the computer and see what happens. That is the only way I can think of to conclusively eliminate any interference from multiple installed drivers. However, it is just a suggestion.

Thank you carmar for all your help on this issue.

I believe I have now sorted it out and replicated it on one other computer to make sure.

The following are steps I took to install a Samsung CLX3305FW multifunction printer that is on my local home network. It’s a combination of the steps you suggested above. Hopefully it works for others but my situation may be unique - who knows. So here are the steps as cleanly as I can describe.

The issue: Zorin automatically detects my networked printer on start up and installs drivers it assumes will work however whatever it installs does not seem to work in my case. Printing is limited/problematic and there is no scanning access. See my OP. And no matter how many times I remove the printer from the Settings -> Printers menu, it reinstalls the printer right away.

Solution:

  1. Install Synaptic if you havent as this simplifies some of the steps below. See above how to install this. Use Synaptic to search for samsung and remove all samsung printer packages. In my case it was printer-driver-splix and it had a red-orange icon. I also used the terminal when needed or convenient based on the steps described in the links I used below.

  2. Download the Samsung linux driver from
    https://support.hp.com/us-en/drivers/selfservice/samsung-clx-3305-color-laser-multifunction-printer-series/17156918
    You will have to choose manually the OS and version, in my case linux, ubuntu. The driver will be Samsung Linux Print and Scan Driver v1.00.39_01.17, size 14.8 MB, 1 Sep 2017.

  3. From terminal use lpstat -a to list the printers. Then lpadmin -x <PrinterName> where for PrinterName I copied and pasted from the list. I am not sure if this step was needed, seeing that my printer gets automatically reinstalled, but I did it anyway.

  4. I then followed the steps in
    https://easylinuxtipsproject.blogspot.com/p/samsung-printers.html
    particularly their step 6. Although the steps in this link say it is now installed, for me I saw no new printer even after reboot and updating. Even Synaptic, doing a search for samsung, did not see the drivers to be installed.

  5. This site that was referred to below suggested that I needed to create a repository.
    https://tutorialforlinux.com/2018/03/26/ubuntu-18-04-samsung-printer-driver-install-guide/
    Some of the links on this site seem to be missing or corrupt, at least for me, so I used the steps described in
    https://www.bchemnet.com/suldr/index.html
    following the directions in “Setting Up the Repository”. I used Synaptic in these steps. After doing this I was able to see the packages listed in Synaptic.

  6. I then followed the instructions in “Selecting Packages to Install”.
    It recommended that if you were having trouble, which I had, to use the Minimum Version found here
    https://www.bchemnet.com/suldr/supported.html
    So I chose suld-driver-4.00.39 for my CLX3300 rather than the latest driver like I did before.

  7. It also suggested that if you wanted to use Samsung’s GUI to install a configurator package. It recommended suld-configurator-2-qt4 for my printer.

  8. I selected items in 6 and 7 above in Synaptic and installed them.

  9. Then Settings -> Printers menu and added the printer Samsung CLX now listed. Once it did its thing, it showed up with toner details and status. Under Systems Tools menu, the Samsung Unified Driver GUI showed up and allowed me to interact with the printer and scanner. Text now prints as true black and white. Simple Scan also connected with the scanner and successfully scanned.

  10. I am now a happy camper. :grinning:

1 Like

Good to hear and thanks for sharing. This will make a useful resource for future readers. Can I bother you to mark your post as solution, so that future readers can jump to it when they browse this thread?