Installing Z16 in a VM

Is there anything I should know about setting Z16 up in a VM on a Linux box?

No, there are no general tweaks or changes necessary.

If something specific should come up during the process, please feel free to ask, though.

2 Likes

I downloaded VMware for Linux from it's website and then clicked on it

VMware-Player-Full-17.0.0-20800274.x86_64-bundle

to install but got this instead..

Failed to install file: Not supported

Ideas?

Did you first right click the file, then select Properties > Permissions - set file as Executable?

No I didn't then but did now and chose Run then I got this. Is this normal ?

VMware im-launch

That is normal to be there. It checks if you are logging in on Wayland.

Just close then ? No add ?

Did VMWare install?

To test this I downloaded the same bundle, gave it permissions and ran the file. Nothing happened. Nothing. My CPU fan did not even sigh. No sign of VMWare on my machine. Wondering if you had the same result.

Yes the same.
Did it twice. Zip. Nada, Nothing at all.
Not in /var/lib/ either

Can you please open terminal

sudo -i

Remember to replace the generic $USER tag with your own actual username:

cd /home/$USER/Downloads

Then run the installer with the console tag and to ignore error warnings:

./VMware-Player-Full-17.0.0-20800274.x86_64.bundle --console --ignore-errors

I think that what is going on here is that Zorin OS 16 is on the same kernel as Ubuntu 22.04. The installer is balking at the Higher Kernel.

Okay doing that, but the licence went on for seemingly 50 or so page, with no sign of finishing, so stopped it thinking I'd start again.
But it said install already running which must be finished before second install. Then it finished on cursor, so not sure what is happening now. Can't see anything happening.

I just noticed that Virtual box is already installed, so if no good with VM I'll try that.

Not sure what happened to VMWare so I am using VirtualBox.
I went to install Zorin16.2 into VB using all defaults and I got this..

Failed to open a session for the virtual machine Zorin 16.2.

VT-x is disabled in the BIOS for all CPU modes (VERR_VMX_MSR_ALL_VMX_DISABLED).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}

Looks like something in the Bios but not sure what..

Did sudo lshw and got a whole bunch of info about the box but not sure if it tells me if it will run a virtual machine.

EDIT:
Enabled Virtual in Bios and now Z16 is running in VB except somehow I set the DVD to be the VB drive not the actual Hard drive so my next job is to try and change that so it resolves on the hard drive.

Whew..

Still not sure how to choose a bootable drive for the VB. Here is what the system admin says..

If a Virtual install gets bungled, it's easier to just delete it and make a new one. Unless you have had it around a while and built stuff on it.

Select "New"
Then set the bootable to be the .iso in whichever directory you are keeping it in. In my lazy case, usually ~/Downloads

Thanks. Yes did a new install in VB and 16.2 install is starting up, just chose install, so we'll see.
Ahh, says it needs 30GB and I have only allocated 12GB.
Can I fix this without having to start at the top ?

EDIT: Enlarged the drive okay then did re-install

EDIT: ON install of Z16 in VB, it gets to the location map them freezes. The right side of the map isn't seen as it is outside the screen frame, so I cannot click okay for the time zone.
I left it overnight in case it corrected but this morning came back to a stuck black screen.

Is it possible to make the VB screen larger. I know there is a ctrl F for full screen however the VB screen still goes outside the right side of the display.

As a summary I think I will delete Z16 in VB and install the lite version to see if that makes any difference.

I personally have always struggled with VirtualBox.

Another you can try:
Gnome-Boxes: I found this the simplest and most straight-forward to use. It worked well.

1 Like

Thank you.
I am trying Z lite basic so will see if that works first.
You see how the screen is out of the frame so hard to hit the Continue if it's not shown. I thought would do it but no.

Well after a lot of time on VB and still not getting too much happiness installing either of Z16's, I am now trying Gnome as you mentioned. I looked at a couple of youtubes and it could be all I need. Really just to stop anyone getting to my LAN if they enter through the website I set up.

I downloaded and installed it however even after trying to start it, it doesn't appear. Not sure whether there is supposed to be an desk or start menu icon or whether it is from the command line every time.

These are the last commands I did.. and the reactions.

At the end I am still at a cursor with no sign of a gnome box.

david@david-HP-Compaq-6000-Pro-MT-PC:~$ sudo apt install snapd
Reading package lists... Done
Building dependency tree
Reading state information... Done
snapd is already the newest version (2.57.5+20.04).
snapd set to manually installed.
The following package was automatically installed and is no longer required:
xdg-desktop-portal-gtk
Use 'sudo apt autoremove' to remove it.
0 to upgrade, 0 to newly install, 0 to remove and 44 not to upgrade.
david@david-HP-Compaq-6000-Pro-MT-PC:~$ sudo snap install gnome-boxes
2022-11-27T14:05:34+11:00 INFO Waiting for automatic snapd restart...
gnome-boxes 42.0.1-5-ga2f71278db from Ken VanDine installed
david@david-HP-Compaq-6000-Pro-MT-PC:~$ sudo /etc/init.d/gdm3 start start gnome environment
Starting gdm3 (via systemctl): gdm3.service.
david@david-HP-Compaq-6000-Pro-MT-PC:~$

You can install gnome-boxes straight from APT

sudo apt install gnome-boxes

You could try installing Virtual Macine Manager.

sudo apt-get install virt-manager

And installing Zorin in there. That's what I did.

Though if you want to use @Aravisian's suggestion, that's fine.