Internal microphone not working on new install

Hi, I'm very happy with new Zorin install on Imac 2017. The exception being the microphone which isnt working. I have gone into the settings and it is not registering/indicating input sound levels. Any advise appreciated.

This might seem silly but I also encountered a similar issue and realized that the input volume was set to 0. Can you verify that in the Sounds option in the settings, the input source is correctly selected and is not set to 0(slider all the way left) ?

Go into terminal and type Alsamixer
The Alsamixer sound settings window will then appear showing sliders for your sound inputs and outputs.

Check that your mic (inputs) settings that appear to the right of the speakers etc (outputs) sliders are not set muted [M]. You can unmute and increase the input volume levels.

You can then save those settings using
sudo alsactl store

Thanks but did not resolve

Thanks but I can not see input/mic, I think its a driver issue!

Screenshot from 2021-05-07 19-38-22

From your Alsamixer, S/PDIF is shown MM i.e. Muted. What happens if you type M there?

But that Alsamixer display looks wrong to me.

I have had a quick web search using "HDA Intel PCH Cirrus Logic Generic Ubuntu" but can see no definitive fixes being posted by others. e.g.

Hi thanks, if I unmute this is what I get

Is that the full extent of your Alsamixer display? If that is true, then it looks wrong for [All] Playback + Capture channels. i.e. cannot see any speakers, mic's or any other sound channels there.

Can you confirm you have sound output (speakers/headphone) working OK and problem just no Internal Mic?

Did you have a look at the link I posted above?

Yes that is the full extent of Alsamixer and yes, speakers work! Only issue is mic...
The link was all Greek to me, sorry

on closer inspection, internal sounds work but speakers do not. I am using a USB connection to Hi-Fi, otherwise there is no sound. You were right

I am afraid I don't think many on here may have an iMac with Zorin OS installed, so support may rely on web searches and results like that I posted above. I have not seen any simple solution.

Which version and flavour of ZorinOS do you have e.g. Z15.3 Core, Lite etc or Z16 Beta

You can then refine your search term to say either Ubuntu 18.04 or Ubuntu 20.04 in place of Z15 or Z16.

Another link which seems to arrive at same Sound solution:

Scroll down to "Sound" you will see:


If you have an aluminum iMac and you do not have sound :
open /etc/modprobe.d/options :
sudo nano /etc/modprobe.d/options
and add "options snd-hda-intel model=imac24" to the file and save ( ctrl+o and ctrl+x to exit )
then reboot.

My O/S is Z15.3 Core, I appreciate your monumental help. Unfortunately my understanding is basic. Not sure how to execute the sound solution you provided. i open sudo nano /etc/modprobe.d/options in terminal but then I dont know how to proceed exactly.

When you have never done something before, it looks daunting. Like riding a bike.
When you open /etc/modprobe.d/options in terminal using nano, it creates a text editor in the terminal.
Since it is based on actual input instead of a standard GUI, you must use your Arrow Keys to navigate the cursor.
I believe that in Zorin 15, the referenced file is not used unless it has the .conf extension.
If you would prefer a GUI method, then you can open the Gedit text editor as root.
In terminal, enter

sudo -i

This will elevate the terminal to the Root Directory. Now, launch the text editor with


Paste the following into it:
options snd-hda-intel model=imac24

Now click Save and it will open a popover window. At teh very top, type the name of the file: options.conf
Now navigate the tree to the location to save it to: Hit "other locations" on the treeview on the left. Then, in the main window, select "computer."
Double click etc
Scroll all the way down to modprobe.d and double click that.
Now you can click save and the file is created and saved.

1 Like

This was so helpful and thanks for introducing me to this process, unfortunately with this application it didn't work. There is a patch here Ubuntu Forums
but I dont have the expertise to try? perhaps I should go back to apple O/S. Shame because I love Zorin

Just as above, some say that using the line:
options snd-hda-intel model=mbp101 works.

Another user suggested installing pavucontrol, then opening it and
in the Input Devices tab choosing Microphone (unplugged) instead of Line In (plugged in).

1 Like

Still no joy!

Have you checked through PulseAudio Control?

sudo apt install pavucontrol

Then run with


Yes, audio/mic options still not evident

Have you tried out Z16 Core Beta from a USB. I am wondering if later kernel etc may be of benefit to you. It would not be too difficult for you to test that.

1 Like

nope, still nothing