Volume and brightness slider not working

Could you check the Sound in Settings to see if you selected a correct output?

It's correct, I also tried every output but still no sound

You could try installing Pulseaudio from Software which gives you more control for sound.

1 Like

sudo apt install pavucontrol

Will also work. Then,



Using the pulse control doesn't fix it either -- no sound. I decided to restart just a moment ago and the sound comes back. I can change the volume of each individual app, but changing the system volume doesn't do anything. Brightness slider doesn't work again.

The only other solution I can think of is Alsamixer.
If you do not have it, you need to install it from the terminal.

sudo apt install alsa-utils



Tried playing around with it, but noting seem to work... Could this be a problem with a driver or something?

You have Intel HD audio controller, the driver for this should be included in the Linux kernel.
2 years old solution, but this might help:

A little more recent tutorial:

It's still not working, but luckily audio works like it should when I plug in my headphone. As for the brightness, I just need to suspend my computer and it'll work again. It's a bit of a bit of a pain to do, but I can live with it. Thanks so much for helping me out though.

I see these as clues for the next Step...

Oh sure, there's still way to fix this? I'll give it some more try then since I got nothing to lose anyway.

I'm running out the door at the moment but will look into and see if I can possibly help when back.
I'm sure that the fix is waiting to be found.

It means your sound card is working.
What is not working is the internal built-in speaker.

It reminds me of the situation for a netbook of my daughter-in-law. I remember I wrote a short script for her to run each time she needs the internal speaker. Now where did I keet that script... memory fails :frowning:

Is there any chance for you to post the screenshot of your Alsamixer setting?

Mine looks like this:

My bad, I think I forgot to mention that the speaker do works after I turn on/restart my computer, I just can not change the system volume. After I suspend my computer, the speaker then doesn't work, which can be fix by restarting my computer again. (headphone works on both before and after suspend my computer though)

In summary
before suspend: speaker works, but system volume slider don't, brightness slider not working
after suspend: speaker doesn't work, brightness slider work

This is the default one (same as 0 HDA Intel HDMI)

This one is 1 HDA Intel PCH

@Artties Sound problems are sometimes hit-and-hope, but looking at your screenshots I see a couple of things to try.

In Alsamixer try setting [Auto-mut] i.e. Automute to "Disabled"

Also in Alsamixer, what happens if you unmute the [S/PDIF] channel.

1 Like

I also noticed that default settings only showing SPDIF output.
You can see in my Alsamixer settings, default is set to D30 and all possible outputs are displayed.

I have just done a websearch for "Cirrus Logic CS4208 sound output Ubuntu 21"

Found this:

EDIT: Also this:

But I also have a nagging memory of other Mac/Cirrus Logic CS4208 sound output problems posted in the past. I will try and find.

EDIT: Found them, but bad news is nothing we suggested worked at the time and so suggested Z16 which was Beta at that time. If you want to read:

1 Like

I get this like every day and my 'search forum' skills are terrible...

How about using external search engine?
This works in Duck for example:

imac sound site:forum.zorin.com

1 Like

I'm still not be able to fix anything, but here's some stuff that I think might be useful.

The grey dash line (the thing that go up and down when volume increase/decrease -- i don't know what's it called) seem to freeze around 10sec after I launch the setting, but in pulse control it's still working completely fine.



unmute S/PDIF and Disable Mute doesn't seem to do anything.

My guess is that suspend the computer change something to the default output speaker and the display, which is audio disappear after suspending the computer, and toggling the brightness slider become usable again. Also, by locking the computer and login again doesn't have the same effect as suspend(audio is still working, but can't change volume, and brightness slider not working).

Another thing to mention:
sudo alsa force-reload gives me this

which I'm not sure if it's an error or not, because someone reply in this post that this fix the problem no sound after suspend, but I did mine and the problem still occur...

1 Like