Muffled/unclear audio output

I recently installed Zorin OS on a 2012 iMac. Playing audio results in output that sounds muffled/unclear. I've tried a bunch of solutions but nothing seems to solve the issue. Can I get some help with this?

1 Like


Please post which version of Zorin you use and what solutions you have tried, so we don't suggest them again, thanks.

1 Like

I'm using 15.3 Core.
I don't remember all of the solutions I've tried, but one of them was reinstalling alsa drivers, which didn't seem to work.

There are two threads where sound problems have been reported for imac

Is it headphone output or speaker output or both that are muffled?

Have you tried running Alsamixer from terminal, and have a play around with the settings and sliders for sound outputs? Post a screenshot of your Alsamixer would be good.

The output from the speakers sounds muffled. I don't hear anything if I plug in headphones.
Below is a screenshot of alsamixer.
Screenshot from 2021-07-30 19-09-19

Your speaker output volume is set 77/10 left and 61/100 right.

Headphone is showing "MM" i.e. muted. Move across to it and unmute that and move the volume slider up.

What happens if you go to Auto-Mute and set that to "Disabled"

Can you see a setting called "Loopback" try changing that from "Disabled" to "Enabled" and see what happens.

I am afraid that from pesonal experience, sound problems are more magic than science. Hence my use of words like "try playing with ..."

Edit: Just done a websearch using"imac 2012 CS4206 sound problem ubuntu 18.04" gives:

1 Like

Playing around with the settings in alsamixer seems to make no difference. Toggling the headphones slider hasn't done anything nor has disabling auto-mute. I also can't see the Loopback setting.
I went through the link you sent but I'm unable to install HDA Analyzer. I added options snd-hda-intel model=imac27_122 to alsa-base.conf but it doesn't seem to have made a difference, even after rebooting. Do you know of any other solutions?

Have you tried with Pulseaudio control app?

Yes, I have. Nothing there seemed to make a difference.

In Alsamixer hit F5 to show All sound channels, not just Playback.

Also, what does F6 give you as choice of sound cards?

Loopback still doesn't appear after showing all sound channels.
As for the sound cards, I get:

  1. Default
  2. HDA Intel PCH
  3. HDA NVidia

It would do no harm to try the other two listed and see what happens.

Nothing seems to happen by switching to the other sound cards. The audio is still the same.

Sorry, I'm at a loss to help you. I can only suggest further research on the internet. As ZorinOS 15 is based on Ubuntu 18.04, you can use that as a search term as I suggested earlier.

You could maybe try Z16 Core Beta, which is reported to be good and stable, to see if that overcomes your sound output problems.

Sure! Thank you so much for your input!

I wonder this, too. I recall several months ago some users noting the same exact problem and I was unable to help them, either on Zorin OS 15.3 on Mac.
Zorin OS 16 has more drivers available in the kernel.