Internal notebook keyboard not working once booted

[Laptop Internal Keyboard not working Zorin OS 16.1 based on Ubuntu 20.04.1 Linux Kernel 5.15.0-46-generic]

My Laptop's (Acer Swift 3 Intel Core i3 6006U) internal keyboard stopped working. The touchpad is working fine. The keyboard is working neither on the login screen nor after login anywhere like on the terminal, text editor, browser etc.), The keyboard is working fine in BIOS.

The external wireless keyboard and mouse are working fine. I tried both X11 and Wayland sessions. I have also installed all the updates and upgrades available.

I also tried blacklisting intel_vbtn as suggested in On-board keyboard and trackpad not working 20.04 but it didn't work. My chassis type is 10 (cat /sys/class/dmi/id/chassis_type).

I also tried to install xserver-xorg-input-all but it says xserver-xorg-input-all is already the newest version (1:7.7+19ubuntu14). Then I removed it and reinstalled it. Does not help.

I also tried live USB (Ventoy) Ubuntu 22.04 & Fedora 36, in both of them previously the keyboard used to work, but now it's not working, the keyboard is working in the Ventoy boot menu though.

I am replying here, tell me if I need to create a new query.

Have you seen this: updates - Ubuntu 20.04 - keyboard not working - Ask Ubuntu

(Edit) Also this: 20.04 - Keyboard not working after shutdown (ASUS Zenbook 13 OLED UM325S) - Ask Ubuntu

thanks for reply @zabadabadoo
I have already tried solution of first link. I will look into the 2nd link, and also now I have backed up my data I will also format and fresh install the OS. Will update the findings here.

@dexter. Suggest you first check your keyboard is working with the Live USB option of ZorinOS before you go and reinstall the OS.

@zabadabadoo no it's not working in live USB too. I have tried Ubuntu 22.04 & Fedora36.
Someone suggested me to check it with Windows installation and also to reflash the BIOS.

Either the keyboard failed or you need a newer kernel. Most of what i read was refering to pre 5.13 kernels, but you may have to jump to 5.14 (which is possible). I believe zorin is all but at the 5.15 kernel.

I'm thinking that keyboard is done. You can purchase a replacement and install it if you want to keep the laptop.

Zorin 16 prefers Libinput over xorg-input-all

Have you tried completely removing xorg-input-all and then reinstalling Libinput?

sudo apt remove --purge xserver-xorg-input-all && sudo apt install --reinstall libinput-tools

If that fails, you may need a different kernel, as @337harvey suggests. You might try the 5.8 kernel, rather than going to a higher kernel than Zorin offers, due to it being an i3 processor.

Hi, so i have found the issue, the keyboard is working in BIOS & Windows installation except its Spacebar key.
I don't know why, but it looks like Linux (Zorin, Ubuntu, Fedora i tried all three) is disabling the keyboard entirely but in Windows 10 only the Spacebar key is not working and sometimes it is being entered repeatedly on its own.
I am looking for new keyboard for my laptop, till then using external one.

Thanks everyone for your suggestions.