Internet Issues With Zorin 16 Pro Lite (Dell Precision T1600)

I'm a new user to Zorin and just installed 16 Pro Lite onto my Dell Precision T1600, with dual boot for Windows 7 still attached. However, my WiFi TP Link AC1300 won't connect, which means my WiFi isn't working, and thus unable to also get Windows App Support which my TP Link needs in order to be installed onto Zorin properly. Keepung in mind that the TP Link worked fine on my Windows 7 (which is still attached via dual boot).

Must I reinstall Lite or are there terminal commands I can use that will make it work?

Update: Having done the lsusb command and a few others on my terminal, I've found that some of the packages were either ignored or obsolete during installation, which made some of them broken. Might need to definitely reinstall again as my WiFi isn't on but comment if there's another way to fix them, etc.

Please follow the instructions here: GitHub - RinCat/RTL88x2BU-Linux-Driver: Realtek RTL88x2BU WiFi USB Driver for Linux

1 Like

Not easy for a newbie, but it can be done.

1 Like

Hi and welcome to the forum.
Just another thing for you to check or change if you have just installed ZorinOS.
Go to Software Updater and set to to "Main Server" not a local server for source of updates.
You can also check for Additional Drivers whilst there.

1 Like

I have downloaded the GitHub file on my Windows 7, but can't seem to open it properly either on the Zorin OS requiring Windows App Support (which right now can't be downloaded without internet access), or because on my Windows one it needs the right zip file app which will extract it properly.

I have done some more terminal commands like (install git-all), which revealed one package that required an update but with the others seemingly okay. Is there a way I can get Windows App Support properly onto Zorin OS via a download file?

Thanks, I hope that I can.

I'll check again if I can access "Main Server", although from what I remember it wouldn't show much when I clicked on it with there being no WiFi access.

I downloaded (see 1st pic) and extracted (see second pic). Zorin is able to open this file with the default archiver.


I may be wrong but I think you're under the impression that you can install the windows driver for this device and make it function in Linux. That is not the case - you have to install Linux drivers for it.

1 Like

I have the same impression. Windows App Support (WINE) can run Programs, not System Software.
System Software is OS Dependent so any System Software must be Linux on Zorin OS.


Fair point. Something for later when you do get wifi working.

Are you able to connect to your router using a ethernet cable?
(to do the GitHub download)

1 Like

Just tried it, but likely due to having no WiFi access I likely cannot extract them properly. As Windows App Support isn't already downloaded onto my apps.

I am trying to, but the TP Link wireless (if it counts as a form of ethernet) isn't being recognised.

Here are the failed packages that my terminal can't seem to fetch:

This the ethernet that appears on my Zorin, but can't seem to connect to:

If unable to connect to the net, then any downloading, installing from the net or updating from the net will not yet be possible.
If you cannot connect using either Mobile Hotspot, Ethernet or WiFi; your best bet is to download the files you need and transfer them with a USB stick.

Open a terminal In the directory that contains those files.
In this case, within the RTL88x2BU-Linux-Driver directory. Some file managers allow Right Click > Open In Terminal to do this.
Or you can Change Directory (cd command) in the terminal to reach that directory. For example, if you transfer the file into your Downloads folder..

cd ~/Downloads/RTL88x2BU-Linux-Driver-master

Then run



sudo make install

Just tried the first command after pasting the zip file, but it said it found no such file or directory.



Still hasn't worked... :confused:

Can you outline what happened?

It just responded with the same answer: bash [] no such file or directory.