Invalid magic number

I'm trying to install Zorin 16 for the first time. I keep getting this error.

Please help

This can mean several things.

  • It may mean that the USB stick is faulty
  • The .iso burn to bootable drive failed
  • The download was corrupted or not downloaded from a reliable source

What etcher did you use to burn the .iso to teh USB to make a bootable copy? Unetbootin? Balena? Rufus?
Did you download from
Did you check the 256SHA?

I downloaded from Zorin and I used balenaetcher that it recommends. I don't know what the 256SHA is.

SHA256 file checksum. You should verify that the .iso file you downloaded is not currupted, by testing its calculated SHA256 checksum against the published SHA256 checksum on the Zorin website.
See this:

1 Like

In this case (in addition to Zabas post above), I can only suggest

  • trying a different USB stick
  • trying a different USB port
  • Redownload and reburn the .iso. Personally, I recommend Unetbootin.

Thank you guys! I'll try that as soon as I can.

Balenaetcher gaved me a faulty flash. At the end it verified the files and came with a error. After reflashing it worked.

OK, in full transparency, I used to be a believer in the Belena Etcher. But historically, it managed to etch itself into stone as the worst ISO burner in history. I no longer use it, as its been known to destroy USB drives as well, which IMO, is the worst possible scenario!

I really like the APP called Popsicle...

This APP is wonderful. It is super light weight, its not fat with bloat. If comes with a HASH checker, which can be set to scan the 256checksum. And, its an ISO burner AIO. Thats right, no need for two different APPS to do what a single APP can do.

Burning Zorin OS 16 PRO to a VectoTech 128GB SSD USB drive!


Thank you guys so much for your help! I redid all of it and put it on a different USB and now it works.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.