Invalid partition table after 17 core install

I installed Zorin 17 core on a Dell Latitude E5430 with an i5 processor, 4 cores, 8 Gb RAM. Install worked but with 1 issue:

  1. when I boot up I get a message "Invalid partition table!" and it will just sit there. If I hit Enter, the boot up proceeds without any problem.

I would like to resolve this so I don't have to wait on the machine to hit enter when it gets to that message. Please keep in mind I am new to Linux and Zorin so I need some handholding...

Thanks in advance.

Is it a Dual-Boot System or only Zorin? Is it possible that You can make a Screenshot from Your Partitions so that we can take a Look on it?

Only Zorin. It was originally Win 7 64 bit. Can you tell me how to make a screen shot of the partitions?

Have a look at solution (post #10, bottom of page 1) here: [SOLVED] Invalid partition table!

1 Like

Seems like Legacy boot support might be enabled in BIOS - from the linked thread via @zabadabadoo ..

What is the status of your Legacy boot support option in BIOS?

You can use the built-in Disc-Tool. It looks like this:
Bildschirmfoto vom 2024-04-12 18-52-59

For the Screenshot You can simply push the prnt-Button if Your Keyboard have one. If not go to the Quick Settings (the little Symbols in the Corner click on them) and there is on the top left a Camera Symbol. Click on it. Look here:

Also please be advised that in Zorin 17 the screenshots were moved from just the Pictures Folder to a folder with in the Pictures Folder named Screenshots ..... it took me forever to find this out .....


Ok I ran the tool and screenshot everything it had. Here are the results:

1 Like

You have GPT partitioning.

Which software you used to create the flash usb?

  • if it was Rufus then have you selected GPT from its menu or not?

And as PlumpKibbles suggested, Go to your bios and check the status of Boot mode. If it's set to UEFI then the flash usb must be created by selecting the GPT.

1 Like

I used Balena Etcher.

I'm not technical so I don't know what you mean by "Go to your bios and check the status of Boot mode. If it's set to UEFI then the flash usb must be created by selecting the GPT.

Go to your BIOS by tapping F2 after power-on (for Dell).
I think you should look at General>Boot Sequence page.
On that page you will see whether you are using "UEFI" or "Legacy".
Let us know what you see, or take a photo of that screen and post it here using the "Upload" tool (7th icon from left on the Reply Box toolbar).


You may get an better idea what is BIOS and how to access it from this:

1 Like

It is legacy.

1 Like

There is the problem. Balena etcher burn the iso to the usb using GPT only (afaik). But for legacy boot MBR partitioning is recommended.

I will suggest use Ventoy to create the flash drive again with MBR partioning and then Reinstall the OS once again.

Or wait for someone else to comment on it if it's possible to alter the partitioning without reinstall that I'm unaware of.

Thanks for the link. I read thru it quickly and then scanned for any mention of GPT or MBR. There is none, so assuming I follow the steps exactly, how will I know if the Ventoy flash will be MBR? is it that way by default?


Well I didn't get far. I followed the instructions until I got to the part where I am supposed to go to Ventoy server with URL. Here is the message I got.

site can’t be reached

I tried turning off the firewall UFW, but it still didn't work.

If You can use Windows on another PC (maybe from a Friend or Neighbor) to create a bootable USB Stick, You could use Rufus. It is a good Tool where You can directly choose between GPT and MBR.

Should I be able to use rufus if I run within Wine?

To be honest: I don't know. I think theoretically it could work. If it works good ... I don't know. You can try it if You want. But I think it would be easier to use it on a Windows Platform.

Unetbootin will make a legacy MBR style boot device by default - just FYI! :+1: