Issue Booting after latest Zorin Update


About a week ago, I updated my laptop with the latest Zorin updates. Upon reboot, I failed to log into my device and have the cryptoLUKs password prompt appear. I got the following message:

cryptsetup: Waiting for encrypted source device UUID=43a6...

Then it drops me into initramfs command prompt, where seemingly no commands work.

I tried booting into recovery mode, of the same kernel (5.14.9-051409), and that failed. I tried booting into an older kernel version that does not support my laptop's WIFI or bluetooth card (5.12.0-051200). I was able to boot into this with no problem.

I tried updating initramfs by doing the following command, hoping it would fix it:

sudo update-initramfs -u -k all

That did not resolve the issue, or seem to do anything upon rebooting and booting into 5.14 kernel.

Any ideas on how to go about resolving this issue? Here are some outputs from fstab, crypttab, and lsblk.

Hardware wise, I am using a i5 Framework Laptop. Details of that laptop hardware can be found on website.

danielh@aule:~$ cat /etc/crypttab 
nvme0n1p3_crypt UUID=43a6282d-7a2d-48e0-802c-78371fc519ca none luks,discard
danielh@aule:~$ cat /etc/fstab 
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
/dev/mapper/vgzorin-root /               ext4    errors=remount-ro 0       1
# /boot was on /dev/nvme0n1p2 during installation
UUID=12ceaf52-1852-42f1-aeb3-8b114acc8ad4 /boot           ext4    defaults        0       2
# /boot/efi was on /dev/nvme0n1p1 during installation
UUID=71F5-BEA3  /boot/efi       vfat    umask=0077      0       1
/dev/mapper/vgzorin-swap_1 none            swap    sw              0       0
danielh@aule:~$ lsblk -f
NAME                 FSTYPE      LABEL UUID                                   FSAVAIL FSUSE% MOUNTPOINT
loop0                squashfs                                                       0   100% /snap/core18/2246
loop1                squashfs                                                       0   100% /snap/gtk-common-themes/1519
loop2                squashfs                                                       0   100% /snap/notion-snap/6
loop3                squashfs                                                       0   100% /snap/snapd/14066
loop4                squashfs                                                       0   100% /snap/gnome-3-28-1804/161
loop6                squashfs                                                       0   100% /snap/core18/2253
loop7                squashfs                                                       0   100% /snap/spotify/53
loop8                squashfs                                                       0   100% /snap/spotify/56
loop9                squashfs                                                       0   100% /snap/bare/5
loop10               squashfs                                                       0   100% /snap/snapd/14295
├─nvme0n1p1          vfat              71F5-BEA3                               505.8M     1% /boot/efi
├─nvme0n1p2          ext4              12ceaf52-1852-42f1-aeb3-8b114acc8ad4    354.9M    42% /boot
└─nvme0n1p3          crypto_LUKS       43a6282d-7a2d-48e0-802c-78371fc519ca                  
  └─nvme0n1p3_crypt  LVM2_member       9zRJUZ-ZIsE-tJCQ-YDFo-dYze-86Nh-hoo0tb                
    ├─vgzorin-root   ext4              0df273cb-51e9-4b37-8431-b44ba0a680e1    398.1G     7% /
    └─vgzorin-swap_1 swap              35347cf8-8ba6-49b1-b45f-f1d276b64c97                  [SWAP]

Thanks for any help,


Hi and welcome to the forum :slight_smile:

How come you have the latest kernel?
My Zorin 16 is still using
5.11.0-41-generic #45~20.04.1-Ubuntu


Do you have Secure Boot enabled in your BIOS settings?

You appear to have installed a later kernel. (As also noted by @FrenchPress above).

I think I see, now...

I am also not seeing your UUID=43a6282d... in your fstab file.

1 Like

I upgraded to later kernels to support the Wifi and Bluetooth Functionality of my laptop. I was aware that this isn't "officially" supported, however right now I am just trying to figure out how I can resolve the issue.

If you type exit at the boot screen error, does it relay more information or allow you to proceed to boot?

1 Like

Should it be? I am not sure how fstab references UUID in a cryptoluks setup.

No, now I am second guessing myself. Ignore that...

1 Like

I assume you mean at the initramfs prompt, then no it does not seem to take any command (exit, or reboot).. I tried few others and it just terminated to clean prompt and doing nothing.

Are you using Swap partition or Swap file?
If so, you might try:

sudo swapoff -a && sudo update-initramfs -u

1 Like


I get the following output:

danielh@aule:~$ sudo swapoff -a && sudo update-initramfs -u
Place your finger on the fingerprint reader
update-initramfs: Generating /boot/initrd.img-5.14.9-051409-generic.signed
W: missing /lib/modules/5.14.9-051409-generic.signed
W: Ensure all necessary drivers are built into the linux image!
depmod: ERROR: could not open directory /lib/modules/5.14.9-051409-generic.signed: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
cat: /var/tmp/mkinitramfs_emCLKR/lib/modules/5.14.9-051409-generic.signed/modules.builtin: No such file or directory
depmod: WARNING: could not open modules.order at /var/tmp/mkinitramfs_emCLKR/lib/modules/5.14.9-051409-generic.signed: No such file or directory
depmod: WARNING: could not open modules.builtin at /var/tmp/mkinitramfs_emCLKR/lib/modules/5.14.9-051409-generic.signed: No such file or directory
1 Like

What about temporarily connect to the net with a cable (LAN) and revert back to the supported kernel? Then taking update before installing the latest kernel for those peripherals.

Forgot to answer this question. Yes, I do:)

Which is interesting cause I do not have the signed version of 5.12 in my MOK config I beleive....

Linux does not need secure boot.

Did some digging

I think we are getting somewhere...


Doesn't sound like bad plan at all. However, I am not sure how the zorin update software will respond, since it seems to already be installed. I hoenstly forgot how I udpated the kernel in the first place. Would it be the same process to downgrading? Any tips on that would be beneficial.


I'd try the .deb package linked above, then running the command above to disable swap, then update initramfs.
If that fails, you can downgrade to a supported kernel, then fully reinstall 5.14


What does "trying the .deb package" entail in this? Installing it? Its the same version to what I am running.

You can do that in Synaptic.