Issue Booting after latest Zorin Update

but he can do that during booting, no?

For the re-install of 5.14, yes. For 5.11, no.

Glad you are back :sweat_smile:

1 Like

Ok, I just updated the initramfs and grub on 5.11. giving this another try

1 Like

Success! Ok, now what should I do that I'm on an "officially supported kernel"?


I think you can now take all updates without breaking anything.

If you use USB Bluetooth and USB WiFi, you could stay with the 5.11 kernel.

USB Bluetooth that works OOB


1 Like

Make sure to remove newer kernel versions because your system will default to them.

1 Like

Good point Harvey!
I forgot to mention that.

I hope OP will come back soon and tell us his progress.

Apologies for slow reply! Had get some food and take a break from trying fix this.

So USB NICs or wifi doesn't work on 5.11, so I couldnt even connect to a network to perform upgrades. I rebooted, and turned off secure boot, and booted into the non-signed kernel image of 5.14. I am now on that and wifi is working. However, my .signed kernel is what it defaults to. I am just gonna not do secure boot cause it's not like it is making my machine that much more secure, and I've already run into complications with it when upgrading kernels and other software updates.

With that said, what steps do I need make to change grub to default to that?

If you are running 5.14 kernel, it will run with that kernel on the next boot.
If you want, you can remove the older kernel with this command:
sudo apt autoremove

When I run it, it says its removing 5.11 kernel. Doesn't seem like the install I did yesterday did anything (just added it as an option).

Then you are good to go.

I don't think that solves it though. Even after upgrading to 5.11 yesterday, it still defaulted to booting into 5.14 .signed (now I just want to change it to 5.14 unsigned, which is what I am currently booted in)

I think Synaptic will let you install signed kernel only.
To install unsigned kernel....I will ask @Aravisian
I've never done it myself :sweat_smile:

Both are "signed" I believed, I just setup a .signed kernel image for secure boot specifically

Can you issue this command?
uname -a
and paste the result.

danielh@aule:~$ uname -a
Linux aule 5.14.9-051409-generic #202109300934 SMP Thu Sep 30 09:39:33 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

You are using the kernel you wanted to use.
Everything look OK to me :slight_smile: