Issue Booting after latest Zorin Update

When I run it, it says its removing 5.11 kernel. Doesn't seem like the install I did yesterday did anything (just added it as an option).

Then you are good to go.

I don't think that solves it though. Even after upgrading to 5.11 yesterday, it still defaulted to booting into 5.14 .signed (now I just want to change it to 5.14 unsigned, which is what I am currently booted in)

I think Synaptic will let you install signed kernel only.
To install unsigned kernel....I will ask @Aravisian
I've never done it myself :sweat_smile:

Both are "signed" I believed, I just setup a .signed kernel image for secure boot specifically

Can you issue this command?
uname -a
and paste the result.

danielh@aule:~$ uname -a
Linux aule 5.14.9-051409-generic #202109300934 SMP Thu Sep 30 09:39:33 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

You are using the kernel you wanted to use.
Everything look OK to me :slight_smile:

Yea correct. I edited /etc/default/grub file with


1 for advanced menu and two for third option for unsigned kernel. This seems to have solved my issue in the mean time


I could be wrong but I got an impression that the whole problem is caused by the secure-boot. You are not the first one to have such issue and disabling secure-boot helped many.

I've never enabled secure-boot on any of my laptops and desktops. One of my laptops has a dual-boot Windows on it, but never had a single issue without secure-boot.

It works once you set it up, but when you start to upgrade anything it breaks:)

1 Like

So the trick is to disable secure-boot and downgrade the kernel before the update?
Sounds like a lot of work to me.

Secure Boot is for Windows. It really does nothing for you on Linux - except create problems on occassion.
Secure Boot checks a Microsoft Vetted List for programs that may conflict with Microsoft Software.

The reason why Secure Boot is somewhat integrated into Ubuntu: Dual Boot Users.

Yes, you can set grub to boot the kernel that you wish on each boot. I wrote a guide on the forum around here somewhere, but you seem to have found your way.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.